none
Pinned shortcuts ignore the "Run" parameter. RRS feed

  • Question

  • Shift Right-Click a pinned Task bar shortcut like Windows Explorer and select Properties. Now you should be on the "Shortcut" tab and there should be a section called "Run" that controls the state of the application window when the program is run. (Maximized/Restored)

     

    I set Windows Explorer to always open Maximized yet Windows Explorer ignores the setting and uses the last known window state. So if I had the window Restored the last time I used it then it will be Restored when I run it from the shortcut instead of Maximized.

     

    Windows XP, ME, 98se, 98 and maybe 95c all honored the setting correctly.


    Core i7 920 @ 2.66GHZ | ASUS P6T Mother Board | 6 gig DDR3 1600 RAM | 2x 500g SATA2 HDD | Integrated sound | Gainward Geforce 250gts "Deep Green" 1024MB PCI-E (latest drivers) | Windows 7 Home Premium x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.
    Thursday, June 2, 2011 2:35 PM

Answers

  • It's by design since Windows Vista. One workaround I've come up with is to modify the Explorer shortcut adding the /separate option:

    %Windir%\explorer.exe /separate

    The downside of this workaround is that each Explorer window will open on its own process, so the system will use more RAM.


    Microsoft MVP Windows Expert Consumer | http://www.wintecnico.com

    Thursday, June 2, 2011 9:35 PM
    Answerer
  • Actually, this solution of yours causes Windows Explorer to always open at My Documents. Is there a way to use your solution while retaining the default location Windows Explorer opens at?

     

    Or if possible utilize your solution and have it open with My Computer expanded and none of the other entries?


    Core i7 920 @ 2.66GHZ | ASUS P6T Mother Board | 6 gig DDR3 1600 RAM | 2x 500g SATA2 HDD | Integrated sound | Gainward Geforce 250gts "Deep Green" 1024MB PCI-E (latest drivers) | Windows 7 Home Premium x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.


    To open Windows Explorer pointing to your Computer folder, the path should be:

    %windir%\explorer.exe /e,::{20D04FE0-3AEA-1069-A2D8-08002B30309D} /separate

    Also, with the default Windows Explorer shortcut, if you close the window in a maximized state, Windows remembers this and will open Windows Explorer maximized the next time you click the shortcut. If you always work with maximized windows, the final effect will be the same.


    Microsoft MVP Windows Expert Consumer | http://www.wintecnico.com

    Saturday, June 4, 2011 10:45 AM
    Answerer

All replies

  • It's by design since Windows Vista. One workaround I've come up with is to modify the Explorer shortcut adding the /separate option:

    %Windir%\explorer.exe /separate

    The downside of this workaround is that each Explorer window will open on its own process, so the system will use more RAM.


    Microsoft MVP Windows Expert Consumer | http://www.wintecnico.com

    Thursday, June 2, 2011 9:35 PM
    Answerer
  • That's an acceptable work around, can such a thing be applied to other non-MS programs or not?
    Core i7 920 @ 2.66GHZ | ASUS P6T Mother Board | 6 gig DDR3 1600 RAM | 2x 500g SATA2 HDD | Integrated sound | Gainward Geforce 250gts "Deep Green" 1024MB PCI-E (latest drivers) | Windows 7 Home Premium x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.
    Friday, June 3, 2011 6:17 AM
  • That's an acceptable work around, can such a thing be applied to other non-MS programs or not?
    Core i7 920 @ 2.66GHZ | ASUS P6T Mother Board | 6 gig DDR3 1600 RAM | 2x 500g SATA2 HDD | Integrated sound | Gainward Geforce 250gts "Deep Green" 1024MB PCI-E (latest drivers) | Windows 7 Home Premium x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.

    I'm testing with some third party applications and they all honor the window size setting correctly. Could you give us an example?

    Microsoft MVP Windows Expert Consumer | http://www.wintecnico.com


    Friday, June 3, 2011 8:50 AM
    Answerer
  • Ah never mind then. It was mostly just Windows Explorer pissing me off. You're correct about 3rd party programs honoring the setting correctly.

    Core i7 920 @ 2.66GHZ | ASUS P6T Mother Board | 6 gig DDR3 1600 RAM | 2x 500g SATA2 HDD | Integrated sound | Gainward Geforce 250gts "Deep Green" 1024MB PCI-E (latest drivers) | Windows 7 Home Premium x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.
    Friday, June 3, 2011 2:42 PM
  • Actually, this solution of yours causes Windows Explorer to always open at My Documents. Is there a way to use your solution while retaining the default location Windows Explorer opens at?

     

    Or if possible utilize your solution and have it open with My Computer expanded and none of the other entries?


    Core i7 920 @ 2.66GHZ | ASUS P6T Mother Board | 6 gig DDR3 1600 RAM | 2x 500g SATA2 HDD | Integrated sound | Gainward Geforce 250gts "Deep Green" 1024MB PCI-E (latest drivers) | Windows 7 Home Premium x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.
    Friday, June 3, 2011 5:58 PM
  • Actually, this solution of yours causes Windows Explorer to always open at My Documents. Is there a way to use your solution while retaining the default location Windows Explorer opens at?

     

    Or if possible utilize your solution and have it open with My Computer expanded and none of the other entries?


    Core i7 920 @ 2.66GHZ | ASUS P6T Mother Board | 6 gig DDR3 1600 RAM | 2x 500g SATA2 HDD | Integrated sound | Gainward Geforce 250gts "Deep Green" 1024MB PCI-E (latest drivers) | Windows 7 Home Premium x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.


    To open Windows Explorer pointing to your Computer folder, the path should be:

    %windir%\explorer.exe /e,::{20D04FE0-3AEA-1069-A2D8-08002B30309D} /separate

    Also, with the default Windows Explorer shortcut, if you close the window in a maximized state, Windows remembers this and will open Windows Explorer maximized the next time you click the shortcut. If you always work with maximized windows, the final effect will be the same.


    Microsoft MVP Windows Expert Consumer | http://www.wintecnico.com

    Saturday, June 4, 2011 10:45 AM
    Answerer
  • Excellent work, thanks very much for the help :)
    Core i7 920 @ 2.66GHZ | ASUS P6T Mother Board | 6 gig DDR3 1600 RAM | 2x 500g SATA2 HDD | Integrated sound | Gainward Geforce 250gts "Deep Green" 1024MB PCI-E (latest drivers) | Windows 7 Home Premium x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.
    Saturday, June 4, 2011 12:33 PM
  • Actually, this solution of yours causes Windows Explorer to always open at My Documents. Is there a way to use your solution while retaining the default location Windows Explorer opens at?

     

    Or if possible utilize your solution and have it open with My Computer expanded and none of the other entries?


    Core i7 920 @ 2.66GHZ | ASUS P6T Mother Board | 6 gig DDR3 1600 RAM | 2x 500g SATA2 HDD | Integrated sound | Gainward Geforce 250gts "Deep Green" 1024MB PCI-E (latest drivers) | Windows 7 Home Premium x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.


    To open Windows Explorer pointing to your Computer folder, the path should be:

    %windir%\explorer.exe /e,::{20D04FE0-3AEA-1069-A2D8-08002B30309D} /separate

    Also, with the default Windows Explorer shortcut, if you close the window in a maximized state, Windows remembers this and will open Windows Explorer maximized the next time you click the shortcut. If you always work with maximized windows, the final effect will be the same.


    Microsoft MVP Windows Expert Consumer | http://www.wintecnico.com


    Well, after using the /separate command some more I've noticed that yes Windows Explorer does remember the state of the window from the last time you used Windows Explorer but it does not remember the initial state the program opens in when using the /separate command.

     

    I Mean if I open Windows Explorer via the shortcut then it opens maximized yet if I open a folder on the Desktop it opens in a restored window.  I have to either open Windows explorer from the shortcut and Restore/Maximize to get it to remember the maximized state for when opening Windows Explorer via alternative methods or maximize the Windows Explorer session generated when opening the folder from the Desktop.


    Core i7 920 @ 2.66GHZ | ASUS P6T Mother Board | 6 gig DDR3 1600 RAM | 2x 500g SATA2 HDD | Integrated sound | Gainward Geforce 250gts "Deep Green" 1024MB PCI-E (latest drivers) | Windows 7 Home Premium x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.
    Sunday, June 5, 2011 3:57 PM
  • Actually, this solution of yours causes Windows Explorer to always open at My Documents. Is there a way to use your solution while retaining the default location Windows Explorer opens at?

     

    Or if possible utilize your solution and have it open with My Computer expanded and none of the other entries?


    Core i7 920 @ 2.66GHZ | ASUS P6T Mother Board | 6 gig DDR3 1600 RAM | 2x 500g SATA2 HDD | Integrated sound | Gainward Geforce 250gts "Deep Green" 1024MB PCI-E (latest drivers) | Windows 7 Home Premium x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.


    To open Windows Explorer pointing to your Computer folder, the path should be:

    %windir%\explorer.exe /e,::{20D04FE0-3AEA-1069-A2D8-08002B30309D} /separate

    Also, with the default Windows Explorer shortcut, if you close the window in a maximized state, Windows remembers this and will open Windows Explorer maximized the next time you click the shortcut. If you always work with maximized windows, the final effect will be the same.


    Microsoft MVP Windows Expert Consumer | http://www.wintecnico.com


    Well, after using the /separate command some more I've noticed that yes Windows Explorer does remember the state of the window from the last time you used Windows Explorer but it does not remember the initial state the program opens in when using the /separate command.

     

    I Mean if I open Windows Explorer via the shortcut then it opens maximized yet if I open a folder on the Desktop it opens in a restored window.  I have to either open Windows explorer from the shortcut and Restore/Maximize to get it to remember the maximized state for when opening Windows Explorer via alternative methods or maximize the Windows Explorer session generated when opening the folder from the Desktop.


    Core i7 920 @ 2.66GHZ | ASUS P6T Mother Board | 6 gig DDR3 1600 RAM | 2x 500g SATA2 HDD | Integrated sound | Gainward Geforce 250gts "Deep Green" 1024MB PCI-E (latest drivers) | Windows 7 Home Premium x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.


    If you want to open in a maximized state every Explorer window and not only Explorer.exe shortcuts (for example, the taskbar pinned icon), use this registry tweak:

    Close any Windows Explorer you may have open. Open Registry Editor (Regedit.exe) and browse to this key: HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags\AllFolders\Shell

    In the right pane, set the ShowCmd value to 3. Set the WFlags value to 2. Close Registry Editor and open any folder. It should maximize automatically. Is that what you want?


    Microsoft MVP Windows Expert Consumer | http://www.wintecnico.com

    Monday, June 6, 2011 3:55 PM
    Answerer
  • Yeah... but upon checking those settings, they're already configured like you said D: (So they don't have any effect)
    Core i7 920 @ 2.66GHZ | ASUS P6T Mother Board | 6 gig DDR3 1600 RAM | 2x 500g SATA2 HDD | Integrated sound | Gainward Geforce 250gts "Deep Green" 1024MB PCI-E (latest drivers) | Windows 7 Home Premium x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.
    Tuesday, June 7, 2011 8:25 AM