locked
Cannot install mouse - Windows Vista Home Premium RRS feed

  • General discussion

  • Hi,

    I'm going to try to be as thorough as possible with the problem to save time.

    About 2 weeks ago my girlfriend broke her USB Cordless Mouse.  A Microsoft branded one, can't remember the exact model off hand.  Being that she and I are gamers, she couldn't live without a mouse for too long so she bought a cheap generic plug and play corded USB mouse in the meantime while the Logitech V470 was put on order.

    This was essentially the beginning of the problem.  Upon plugging in and attempting to install the device we were greeted with the infamous message:

    Windows encountered a problem installing the driver software for your device

    Windows found driver software for your device but encountered an error while attempting to install it.

    USB HID Device (or something like that)

    Access is denied.

    So, after an hour or so of wrestling with it, I gave up and loaned her my Logitech MX510 which worked with full functionality after installing Setpoint 4.2.4 (I believe) and I have been using the generic plug and play USB mouse in the meantime.  Feeling a bit more confident that the Logitech V470 will work, we waited for the delivery with the present hardware exchange.

    The V470 finally arrived yesterday and I began the installation process and was again greeted with the error mentioned earlier, the device name now being listed as Bluetooth HID Device, but otherwise exactly the same error.

    Since the first time the error occured, I have been researching the problem for a cause and a solution and other than the advice to install a couple of hotfixes, KB937187 and KB940199, and even deleting the infcache.1 file so that it can be rebuilt, there's has been no progress at all.

    Is there even a more concrete solution than these available?  I'm incredibly tempted to reformat and install XP instead just because Vista has given us such a huge problem but because the PC we're trying to connect the mouse to is a laptop, the problem of finding XP drivers for all the integrated hardware isn't sounding too appealing.

    Can anybody advise me on how to resolve this problem or will it be a case of waiting until SP1 goes live, if that will even fix the issue anyway?
    Wednesday, February 27, 2008 7:43 AM

All replies

  • Hi,


    Due to security reason, by default, Windows Vista is not allowing bluetooth devices to connect to your PC/Notebook. You can change this behavior by do following steps:

    1. Open Bluetooth Device dialog
    2. Open Option tabs
    3. Check Allow Bluetooth devices to connect to this computer check box
    4. To get notice every time when there is untrusted device that want to connect to your PC/Notebook, check also Alert me when a new Bluetooth device wants to connect check box
    --------------------
    Regards,
    Eric Zhang
    Microsoft Online Community Support



    Friday, February 29, 2008 10:00 AM
  • Hi,

     

    Thanks for the reply. Sadly, your advice was unhelpful.  I neglected to mention that the laptop can detect the mouse via bluetooth and it does connect, but it cannot install the drivers. To echo this, I will explain another route I have used for the installation process.

     

    1.   Opened Bluetooth Devices

    2.   Clicked the Devices tab.

    3.   Clicked Add

    4.   Ticked the My device is set up and ready to be found.checkbox then clicked Next

    5.   Selected the Bluetooth Travel Mouse as detected by the adaptor in the device list then clicked Next.

    6.   Selected the No Passkey option as passkeys are unsupported by the device and clicked Next

    7.   The dialogue box then tells me that the device is connected and installed and the Found New hardware box pops up prompting for me to choose an option.

    8.   Selected Locate and install driver software (recommended since it's the only option that will actually let me install a device where as the other two are both to decline installation.  Not sure why Vista needs to give 2 options to essentially decline an installation in the wizard yet not offer the choice to do a manual installation.  But I digress...

    9.   Waited for a few moments and then was greeted with the same pop up window as described in my first post.

     

     

    This is definitely a problem with Vista and not the device as I have tested this on an XP system and it works without fault.  This also very much appears to be a fairly common problem since there are at least 2 KB articles regarding the error.

     

    Any further thoughts on a solution?

    Friday, February 29, 2008 11:51 AM
  • Hi,

    Did you install Setpoint on your laptop?

    Also, please try to manually install the mouse driver.

    --------------------
    Regards,
    Eric Zhang
    Microsoft Online Community Support



    Monday, March 3, 2008 9:53 AM
  • Forgive me if this comes across a little rude but have you actually read any of my posts before?

     

    1. I already told you I have installed Setpoint.

    2. I have also already told you that I have attempted to install the driver manually.

    3. You will also find in my first post the reason Vista gives on both occasions why the driver will not work.  The driver is found by Vista but is unable to allow access to it.

     

    Really this should be a very simple fix, but as I don't know my way around Vista as well as I know my way around 3.11 through to Server 2003 and everything in between, I cannot work out how to allow the device to gain access to the driver.

     

    Now please, stop insulting my intelligence by giving me advice in the shape of things I have already tried, and I've already told you I've tried, and be a little more helpful.  If you don't know how to solve the problem, admit defeat and pass me on to someone that does know.

     

    Yes, I am aware that I'm coming across with a disgruntled demeanor but imagine how you'd feel if you went to a doctor complaining about a shortness of breath and the doctor asks you if you've tried breathing.

    Monday, March 3, 2008 12:19 PM
  • Hi,

    Could you please open Event Viewer and check whether there is any error related to mouse driver installation?

    --------------------
    Regards,
    Eric Zhang
    Microsoft Online Community Support





    Wednesday, March 5, 2008 9:43 AM
  • Hi,

    As this thread has been quiet for a while we will be changing the issue type to ‘Comment’.

    If you wish to return to this question you can go ahead and change the type back to ‘Question’. Then you can edit your initial post and change the radio button at the top of the post editor window.

    If the issue has been resolved, we’d love to hear your solution. By sharing your experience you can help other community members facing similar problems.

    Thanks!

    --------------------
    Regards,
    Eric Zhang




    Wednesday, March 12, 2008 2:24 AM
  • Are you sure the drivers won't install? I just solved a very similar problem, where my v470 mysteriously ceased to work on my notebook computer because I rashly allowed Windows Update to install drivers for my Synaptics touchpad.

     

    After this happened, drivers would certainly install, but they wouldn't start. The mouse was detected, inspected, connected and rejected (a little Arlow Guthrie for you there) with an error 10. It didn't actually say error 10, it just complained that the HID couldn't start. Installing the SetPoint BCA didn't help except insofar as it showcased the fact that the HID driver couldn't start.

     

    Uninstalling the Synaptics driver (it was properly listed in appwiz.cpl) followed by a reboot was enough to resolve the problem: the mouse miraculously started to work, although I must say BCA needed two tries to get there.

     

    I don't much like BCA since it provides no benefit over Vista's intrinsic mouse configuration, so I removed that too, but only after the mouse was resurrected.

    Monday, June 9, 2008 1:38 PM