none
PowerQuery will not load to Excel 2010 under User Acount RRS feed

  • Question

  • I cannot get Power Query to load in Excel 2010 (32 bit) while signed in under a user (non-admin) account. If I sign in as an admin it loads fine.

    The Add-in manager shows it as a disabled add-in, but no matter what I do,  I cannot get it to load.

    Actions tried so far:

    1.  Activate in Add-in manager (several times)

    2.  Uninstall PowerQuery - download latest installation package and reinstall

    3.  Repair Office installation and reboot.

    Running Windows 7 (32-bit)

    Anyone have any ideas on what's wrong; how to fix it?

    Monday, February 16, 2015 6:59 PM

Answers

  • In the "Manage:" drop down, select "Disabled Items" and press "Go...". Are you able to enable Power Query from that dialog?
    • Marked as answer by Dull Razr Thursday, March 5, 2015 10:01 PM
    Thursday, March 5, 2015 8:57 PM
  • OK, that worked!

    I selected "Disabled Items"In the "Manage:" drop down and pressed "Go...". 

    In the dialog box that opened, I selected the Power Query Add-in and hit Enable.  Nothing happened yet.

    So I went back to the Manage: drop-down  and selected COM Add-ins again hit the GO... button.

    In the dialog box, I checked Microsoft Power Query for Excel and hit OK.

    It finally loaded.

    Thanks!

    • Marked as answer by Dull Razr Thursday, March 5, 2015 10:09 PM
    Thursday, March 5, 2015 10:09 PM

All replies

  • Can you check the value of this key in the registry?

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Excel\Addins\Microsoft.Mashup.Client.Excel\LoadBehavior

    Tuesday, March 3, 2015 2:39 AM
  • There is nothing beyond HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft

    There is only one registry setting on that path REG_SZ and the value is not set.


    • Edited by Dull Razr Thursday, March 5, 2015 11:46 AM
    Thursday, March 5, 2015 11:45 AM
  • Sorry, I missed your comment about running 32-bit Windows. Can you look at this key instead?

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Excel\Addins\Microsoft.Mashup.Client.Excel\LoadBehavior

    Thursday, March 5, 2015 7:39 PM
  • The Type is REG_DWORD and the Value is 3 (Hex 0x00000003)
    Thursday, March 5, 2015 7:46 PM
  • Thanks. You mentioned the add-in appears as a disabled add-in in the Add-in Manager, can you elaborate on what that means? Does "Microsoft Power Query for Excel" show up in the COM add-ins list, and is it checked?
    Thursday, March 5, 2015 7:53 PM
  • When I bring up the add-ins screen (File>Options>Add-ins), It does not show up in the top part of the screen under the header "Active Application Add-ins".  It appears at the bottom of the screen under a heading "Disabled Application Add-ins".

    When I select COM Add-ins in the Manage: drop-down at the bottom of the screen and select the GO... button, Microsoft Power Query for Excel shows up in the dialog box but it is unchecked.  When I select the entry the information at the bottom of the dialog reads:

    Location: C:\Windows\system32\mscoree.dll

    Load Behavior: Unloaded

    If I check it and select OK,  It does not load the add-in.  If I bring up the dialog again, it has reverted to unchecked.

    Thursday, March 5, 2015 8:05 PM
  • In the "Manage:" drop down, select "Disabled Items" and press "Go...". Are you able to enable Power Query from that dialog?
    • Marked as answer by Dull Razr Thursday, March 5, 2015 10:01 PM
    Thursday, March 5, 2015 8:57 PM
  • OK, that worked!

    I selected "Disabled Items"In the "Manage:" drop down and pressed "Go...". 

    In the dialog box that opened, I selected the Power Query Add-in and hit Enable.  Nothing happened yet.

    So I went back to the Manage: drop-down  and selected COM Add-ins again hit the GO... button.

    In the dialog box, I checked Microsoft Power Query for Excel and hit OK.

    It finally loaded.

    Thanks!

    • Marked as answer by Dull Razr Thursday, March 5, 2015 10:09 PM
    Thursday, March 5, 2015 10:09 PM
  • Great, glad to hear that worked!
    Thursday, March 5, 2015 10:18 PM