locked
Error on Portal Migration from SPS 2003 to MOSS RRS feed

  • Question

  • Hi,

    We are trying to migrate  portal site from SPS2003 to MOSS.We are following database migration approach and the steps followed are
    Ran Prescan and copied the Custom Site definitions
    Took the Backup of _SITE Database on restored on MOSS Database Server.
    Created Upgrade Definition File.
    Ran stsadm -o addcontentntdb for migration.
    Ran stsadm -restoressp to restore _PROF DB.
    After migration we are able to ge the default.aspx with some webpart error but browsing to other pages gives the below error(_layouts/settings.aspx or _layouts/viewlsts.aspx)

    The file '/_layouts/1033/PortalHeader.aspx' does not exist.   at System.Web.UI.Util.CheckVirtualFileExists(VirtualPath virtualPath)
       at System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)
       at System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)
       at System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean noAssert)
       at System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp, Boolean noAssert)
       at System.Web.UI.PageHandlerFactory.GetHandlerHelper(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath)
       at System.Web.HttpApplication.MapHttpHandler(HttpContext context, String requestType, VirtualPath path, String pathTranslated, Boolean useAppConfig)
       at System.Web.HttpServerUtility.Execute(String path, TextWriter writer, Boolean preserveForm)

    I have an entry in Onet.xml ragarding Header as AlternateHeader=PoratlHeader.aspx.
    But in MOSS i dont find any aspx page with name portalheader.aspx but the page is present in SPS 2003.When i copy that page and put into MOSS it leads to the below error



    Unknown server tag 'SPSWC:PageRedirectControl'.   at System.Web.UI.TagPrefixTagNameToTypeMapper.System.Web.UI.ITagNameToTypeMapper.GetControlType(String tagName, IDictionary attribs)

    we are able to get in to the Document libraries and lists which are migrated successfullly.
    But only AllItems.aspx in all lists and Document libraries are visible.
    If i click on new item or Click on upload it leads to "potalheader.aspx error"

    Is that something i missed out
    Please share your ideas.

    Thanks,
    Anu
    Monday, November 3, 2008 4:02 AM

Answers

  • Did you perform any customizations to your environment?  What were the results of your prescan? 

    If you altered your default templates for SPS 2003 there is a chance they will not come over correctly in the migration in which case you would have to reset all the site content to the default template in the Site Settings page.

    BP
    • Marked as answer by Lionel Chen - MSFT Friday, November 14, 2008 8:44 AM
    • Unmarked as answer by Anu Pravinya Wednesday, December 3, 2008 2:38 PM
    • Marked as answer by Anu Pravinya Wednesday, December 3, 2008 2:39 PM
    Monday, November 3, 2008 6:42 PM

All replies

  • Hi,

    We are using Database Migration Approach to migrate the Sites from SPS 2003 to MOSS 2007.
    We have some custom permissions and groups created in SPS 2003.When we migrate them they get migrated with a different name like Customxx,Customyy...xx and yy are two digit numbers like 78,27 et.,
    It can be any number prefixed by Custom.Is this is by default that Database Migration migrates the Custom groups by different names.

    Thanks,
    Anu
    • Merged by Mike Walsh FIN Monday, November 3, 2008 6:47 AM yet another "new" thread on exactly the same subject.
    Monday, October 6, 2008 10:26 AM
  • Hi,

    I have performed database migrations and have not seen this type of behavior.  Are you running your MOSS server with the latest Infrastructure Update or SP1? 

    Jason Medero, WSS MVP, B&R Business Solutions, www.sharepointblogs.com/jasonmedero
    Tuesday, October 7, 2008 4:27 AM
  • Do u have any errors in upgrade.log?!
    Did you try to open the page which throw you such error with SharePoint designer?!
    My blog http://spaces.live.com/laflour | Visual C# MVP
    Monday, November 3, 2008 5:04 AM
  • Thanks for your reply.No errros in upgrade log related to header.Moreover default.aspx of our site is disabled from opening in Sharepoint designer.(disabled on ONET.XMl)

    Now i have removed the problematic tag 'SPSWC:PageRedirectControl' from that page and now  i m able to browse to all pages.

    Not sure of the effect of removing this tag.Can you please share your ideas

    Thanks
    Anu

    Monday, November 3, 2008 5:25 AM
  •  
    Hi

    Can anyone tell me the best way to migrate "portal Listings" from SPS 2003 to MOSS
    We are following DB migration and after migration i find a list called "Listing" created by default.The description of the list says that "A system list used to store v2 listings.  It is created by upgrade. "But it doesn't have any contents inside it.Moreover i have not speicified the list in upgrade definition File.From the msdn link http://msdn.microsoft.com/hi-in/library/bb954662(en-us).aspx,
    i found that MOSS doen't have this feature and instead "Summary link webpart" is present.
    Any Suggestions.

    Thanks
    Anu
    • Edited by Anu Pravinya Monday, November 3, 2008 8:35 AM
    • Merged by Mike Walsh FIN Monday, November 3, 2008 9:47 AM same person; same subject
    Monday, November 3, 2008 8:34 AM
  • Please stop making identical posts and posts that could easily fit in your existing threads.

    I am going to merge this with the earlier thread which by memory has exactly this same text.

    (Note to other readers: This poster deleted this identical content that was posted earlier from the existing thread so you will not be able to see it)


    • Edited by Mike Walsh FIN Monday, November 3, 2008 9:49 AM Note to other readers added
    Monday, November 3, 2008 9:45 AM
  • Did you perform any customizations to your environment?  What were the results of your prescan? 

    If you altered your default templates for SPS 2003 there is a chance they will not come over correctly in the migration in which case you would have to reset all the site content to the default template in the Site Settings page.

    BP
    • Marked as answer by Lionel Chen - MSFT Friday, November 14, 2008 8:44 AM
    • Unmarked as answer by Anu Pravinya Wednesday, December 3, 2008 2:38 PM
    • Marked as answer by Anu Pravinya Wednesday, December 3, 2008 2:39 PM
    Monday, November 3, 2008 6:42 PM