locked
Auto Client-Push installation Issues RRS feed

  • Question

  •  

    Hi Everyone. 

     

    I have an issue with an implementation of SCCM 2012 R2 (version 5.00.839.1000) (Installed on WIN2012 R2 Standard) inherited at a new position. In a nutshell, we've enabled automatic site-wide client push installation. Unfortunately, this is not working, has never been working. I believe it may be a configuration issues. As such, I've performed an audit on the installation instance and can find nothing out of the ordinary. This is a 1 site, two server system. 1. main site server with most roles. 2. database server with reporting services. As such and we are looking to expand the SCCM installation to service multiple locations (30+ and growing).

     

    Here is what I've found and some troubleshooting I've done so far.

     

    • After client computers are added to the domain, SCCM discovers them fairly quickly. However, the client push fails immediately. The client machine does not receive any log setup files from the CCMclient setup executable. There is no trace of CCM on the client machine. As such, I don’t believe it is a client issue but an SCCM configuration issue. The server is able to communicate to the clients. BUT……I am able to install CCM client on user machines from the SCCM console. Very Weird

     

    • Able to connect to \\client\admin$ from SCCM server using client push account.
    • Able to run wbemtest on the server and enumerate to client successfully. 

     

    • The accounts being used to push the clients are part of the domain admin group and have been added to the local administrators group on all machines in the domain. As part of a test I added both accounts locally to a test machine. Test machine is on the local network.

     

    • The firewall on the SCCM server is turned off and I turned off the firewalls on a test client. I don’t think the firewall is an issue because all client are getting windows updates from software update services from the SCCM service.

     

    • Both methods of client installation settings are enabled on the site server. I'm not sure if this is an issue.
      • Client Push Installation
      • Software Update-Based Client Installation

     

    • Boundaries are all properly configured. (IP subnets and AD Sites). All boundaries are part of a boundary group All boundary groups are assigned to a distribution point.

     

    • Client discovery period is set higher that the heartbeat discovery period. The clear installation flag is enabled in site maintenance window.

     

    • I've attached a recent copy of the ccm log. There are bunch of errors from machines that are not on the network or no longer part of the network.

     

    • I am unable locate any error information for machines that are discovered, on the network and part of device collection in SCCM.

     

    I am unsure of where to go from here. If I can't figure it out, I plan on running a site recovery to repair the installation and then trying to upgrade to see fi that will repair the issue.

     

    If anyone has any ideas, please let me know. Anything at this point would be greatly appreciated as I am not ready to entertain a "scorched earth" approach.

    Tuesday, March 13, 2018 2:52 PM

All replies

  • Here is  small sampling of the ccm log. im new to the site and am unable to attach the log file. 

    :53.612+240><thread=4552 (0x11C8)>
    Submitted request successfully  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:53.766+240><thread=3292 (0xCDC)>
    Getting a new request from queue "Retry" after 100 millisecond delay.  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:53.768+240><thread=3292 (0xCDC)>
    Found CCR "2097160417.ccr" in queue "Retry".  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:53.769+240><thread=3292 (0xCDC)>
    Execute query exec [sp_CP_GetPushRequestMachine] 2097160417~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:53.869+240><thread=3292 (0xCDC)>
    Successfully retrieved information for machine FKQ200-IQSITV68SBSP from DB  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:53.871+240><thread=3292 (0xCDC)>
    Execute query exec [sp_CP_GetPushRequestMachineIP] 2097160417~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:53.871+240><thread=3292 (0xCDC)>
    Execute query exec [sp_CP_GetPushRequestMachineResource] 2097160417~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:53.872+240><thread=3292 (0xCDC)>
    Execute query exec [sp_CP_GetPushMachineName] 2097160417~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:53.874+240><thread=3292 (0xCDC)>
    Received request: "2097160417" for machine name: "FKQ200-IQSITV68SBSP" on queue: "Retry".  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:53.875+240><thread=3292 (0xCDC)>
    Error event time has expired for Request "2097160417" for machine "FKQ200-IQSITV68SBSP".  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:53.875+240><thread=3292 (0xCDC)>
    Stored request "2097160417", machine name "FKQ200-IQSITV68SBSP", in queue "Processing".  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:53.876+240><thread=3292 (0xCDC)>
    Execute query exec [sp_CP_SetPushRequestMachineStatus] 2097160417, 1~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:53.877+240><thread=3292 (0xCDC)>
    WARNING: High volume of CCRs. Slowing down the queue processing thread~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:53.879+240><thread=3292 (0xCDC)>
    ---> WNetAddConnection2 failed (LOGON32_LOGON_NEW_CREDENTIALS) using account etmcorad\administrator (00000035)  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:54.416+240><thread=5504 (0x1580)>
    ---> The device CORP-NPINERO does not exist on the network. Giving up~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:54.417+240><thread=5504 (0x1580)>
    ---> Trying the 'best-shot' account which worked for previous CCRs (index = 0x0)~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:54.418+240><thread=5504 (0x1580)>
    ---> Attempting to connect to administrative share '\\CORP-NPINERO.etmcorad.com\admin$' using account 'etmcorad\administrator'~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:54.418+240><thread=5504 (0x1580)>
    Submitted request successfully  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:55.048+240><thread=3288 (0xCD8)>
    Getting a new request from queue "Incoming" after 100 millisecond delay.  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:55.048+240><thread=3288 (0xCD8)>
    Found CCR "16777374.CCR" in queue "Incoming".  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:55.049+240><thread=3288 (0xCD8)>
    Execute query exec [sp_CP_GetPushRequestMachine] 16777374~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:55.149+240><thread=3288 (0xCD8)>
    Successfully retrieved information for machine MEM-LHOFFMAN from DB  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:55.151+240><thread=3288 (0xCD8)>
    Execute query exec [sp_CP_GetPushRequestMachineIP] 16777374~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:55.151+240><thread=3288 (0xCD8)>
    Execute query exec [sp_CP_GetPushRequestMachineResource] 16777374~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:55.152+240><thread=3288 (0xCD8)>
    Execute query exec [sp_CP_GetPushMachineName] 16777374~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:55.154+240><thread=3288 (0xCD8)>
    Received request: "16777374" for machine name: "MEM-LHOFFMAN" on queue: "Incoming".  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:55.155+240><thread=3288 (0xCD8)>
    Stored request "16777374", machine name "MEM-LHOFFMAN", in queue "Processing".  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:55.156+240><thread=3288 (0xCD8)>
    Execute query exec [sp_CP_SetPushRequestMachineStatus] 16777374, 1~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:55.157+240><thread=3288 (0xCD8)>
    WARNING: High volume of CCRs. Slowing down the queue processing thread~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:55.158+240><thread=3288 (0xCD8)>
    ---> WNetAddConnection2 failed (LOGON32_LOGON_NEW_CREDENTIALS) using account etmcorad\administrator (00000035)  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:59.455+240><thread=7536 (0x1D70)>
    ---> The device CORP-CMASI2 does not exist on the network. Giving up~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:59.456+240><thread=7536 (0x1D70)>
    ---> Trying the 'best-shot' account which worked for previous CCRs (index = 0x0)~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:59.457+240><thread=7536 (0x1D70)>
    ---> Attempting to connect to administrative share '\\CORP-CMASI2.etmcorad.com\admin$' using account 'etmcorad\administrator'~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:59.457+240><thread=7536 (0x1D70)>
    ---> WNetAddConnection2 failed (LOGON32_LOGON_NEW_CREDENTIALS) using account etmcorad\administrator (00000035)  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:59.846+240><thread=3140 (0xC44)>
    ---> The device CORP-JMORALES.etmcorad.com does not exist on the network. Giving up~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:59.847+240><thread=3140 (0xC44)>
    ---> Trying the 'best-shot' account which worked for previous CCRs (index = 0x0)~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:59.848+240><thread=3140 (0xC44)>
    ---> Attempting to connect to administrative share '\\CORP-JMORALES\admin$' using account 'etmcorad\administrator'~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:23:59.848+240><thread=3140 (0xC44)>
    ---> WNetAddConnection2 failed (LOGON32_LOGON_NEW_CREDENTIALS) using account etmcorad\administrator (00000035)  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:01.485+240><thread=5260 (0x148C)>
    ---> The device CORP-CGOWING.etmcorad.com does not exist on the network. Giving up~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:01.486+240><thread=5260 (0x148C)>
    ---> Trying the 'best-shot' account which worked for previous CCRs (index = 0x0)~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:01.487+240><thread=5260 (0x148C)>
    ---> Attempting to connect to administrative share '\\CORP-CGOWING\admin$' using account 'etmcorad\administrator'~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:01.487+240><thread=5260 (0x148C)>
    ---> WNetAddConnection2 failed (LOGON32_LOGON_NEW_CREDENTIALS) using account etmcorad\administrator (00000035)  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:01.504+240><thread=5260 (0x148C)>
    ---> The device CORP-CGOWING does not exist on the network. Giving up~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:01.505+240><thread=5260 (0x148C)>
    ---> ERROR: Unable to access target machine for request: "16782251", machine name: "CORP-CGOWING",  access denied or invalid network path.  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:01.506+240><thread=5260 (0x148C)>
    Execute query exec [sp_CP_SetLastErrorCode] 16782251, 53~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:01.507+240><thread=5260 (0x148C)>
    Stored request "16782251", machine name "CORP-CGOWING", in queue "Retry".  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:01.509+240><thread=5260 (0x148C)>
    Execute query exec [sp_CP_SetPushRequestMachineStatus] 16782251, 2~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:01.510+240><thread=5260 (0x148C)>
    Execute query exec [sp_CP_SetLatest] 16782251, N'03/13/2018 14:24:01', 4~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:01.524+240><thread=5260 (0x148C)>
    <======End request: "16782251", machine name: "CORP-CGOWING".  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:01.525+240><thread=5260 (0x148C)>
    ======>Begin Processing request: "2097157371", machine name: "PC630019F3-DEN"  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:01.529+240><thread=5260 (0x148C)>
    Execute query exec [sp_IsMPAvailable] N'ETM'~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:01.530+240><thread=5260 (0x148C)>
    ---> Trying the 'best-shot' account which worked for previous CCRs (index = 0x0)~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:01.531+240><thread=5260 (0x148C)>
    ---> Attempting to connect to administrative share '\\PC630019F3-DEN\admin$' using account 'etmcorad\administrator'~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:01.531+240><thread=5260 (0x148C)>
    ---> WNetAddConnection2 failed (LOGON32_LOGON_NEW_CREDENTIALS) using account etmcorad\administrator (00000035)  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.371+240><thread=4496 (0x1190)>
    ---> The device CORP-JMCCLOUD does not exist on the network. Giving up~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.372+240><thread=4496 (0x1190)>
    ---> Trying the 'best-shot' account which worked for previous CCRs (index = 0x0)~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.373+240><thread=4496 (0x1190)>
    ---> Attempting to connect to administrative share '\\CORP-JMCCLOUD.etmcorad.com\admin$' using account 'etmcorad\administrator'~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.374+240><thread=4496 (0x1190)>
    Submitted request successfully  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.880+240><thread=3292 (0xCDC)>
    Getting a new request from queue "Retry" after 100 millisecond delay.  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.881+240><thread=3292 (0xCDC)>
    Found CCR "2097160421.ccr" in queue "Retry".  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.881+240><thread=3292 (0xCDC)>
    Execute query exec [sp_CP_GetPushRequestMachine] 2097160421~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.982+240><thread=3292 (0xCDC)>
    Successfully retrieved information for machine HKQ200-P5IRT5EUH3UL from DB  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.984+240><thread=3292 (0xCDC)>
    Execute query exec [sp_CP_GetPushRequestMachineIP] 2097160421~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.985+240><thread=3292 (0xCDC)>
    Execute query exec [sp_CP_GetPushRequestMachineResource] 2097160421~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.986+240><thread=3292 (0xCDC)>
    Execute query exec [sp_CP_GetPushMachineName] 2097160421~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.987+240><thread=3292 (0xCDC)>
    Received request: "2097160421" for machine name: "HKQ200-P5IRT5EUH3UL" on queue: "Retry".  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.988+240><thread=3292 (0xCDC)>
    Error event time has expired for Request "2097160421" for machine "HKQ200-P5IRT5EUH3UL".  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.988+240><thread=3292 (0xCDC)>
    Stored request "2097160421", machine name "HKQ200-P5IRT5EUH3UL", in queue "Processing".  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.989+240><thread=3292 (0xCDC)>
    Execute query exec [sp_CP_SetPushRequestMachineStatus] 2097160421, 1~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.990+240><thread=3292 (0xCDC)>
    WARNING: High volume of CCRs. Slowing down the queue processing thread~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:03.991+240><thread=3292 (0xCDC)>
    Submitted request successfully  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:05.160+240><thread=3288 (0xCD8)>
    Getting a new request from queue "Incoming" after 100 millisecond delay.  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:05.160+240><thread=3288 (0xCD8)>
    Found CCR "16777448.CCR" in queue "Incoming".  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:05.161+240><thread=3288 (0xCD8)>
    Execute query exec [sp_CP_GetPushRequestMachine] 16777448~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:05.263+240><thread=3288 (0xCD8)>
    Successfully retrieved information for machine IND-GM-02 from DB  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:05.265+240><thread=3288 (0xCD8)>
    Execute query exec [sp_CP_GetPushRequestMachineIP] 16777448~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:05.265+240><thread=3288 (0xCD8)>
    Execute query exec [sp_CP_GetPushRequestMachineResource] 16777448~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:05.266+240><thread=3288 (0xCD8)>
    Execute query exec [sp_CP_GetPushMachineName] 16777448~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:05.268+240><thread=3288 (0xCD8)>
    Received request: "16777448" for machine name: "IND-GM-02" on queue: "Incoming".  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:05.269+240><thread=3288 (0xCD8)>
    Stored request "16777448", machine name "IND-GM-02", in queue "Processing".  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:05.270+240><thread=3288 (0xCD8)>
    Execute query exec [sp_CP_SetPushRequestMachineStatus] 16777448, 1~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:05.271+240><thread=3288 (0xCD8)>
    WARNING: High volume of CCRs. Slowing down the queue processing thread~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:05.272+240><thread=3288 (0xCD8)>
    ---> WNetAddConnection2 failed (LOGON32_LOGON_NEW_CREDENTIALS) using account etmcorad\administrator (00000035)  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:07.464+240><thread=5720 (0x1658)>
    ---> The device CORP-LMOZIAN does not exist on the network. Giving up~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:07.465+240><thread=5720 (0x1658)>
    ---> Trying the 'best-shot' account which worked for previous CCRs (index = 0x0)~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:07.466+240><thread=5720 (0x1658)>
    ---> Attempting to connect to administrative share '\\CORP-LMOZIAN.etmcorad.com\admin$' using account 'etmcorad\administrator'~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:07.466+240><thread=5720 (0x1658)>
    ---> WNetAddConnection2 failed (LOGON32_LOGON_NEW_CREDENTIALS) using account etmcorad\administrator (00000035)  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:07.927+240><thread=6256 (0x1870)>
    ---> The device NY06-WIN10.etmcorad.com does not exist on the network. Giving up~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:07.928+240><thread=6256 (0x1870)>
    ---> Trying the 'best-shot' account which worked for previous CCRs (index = 0x0)~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:07.929+240><thread=6256 (0x1870)>
    ---> Attempting to connect to administrative share '\\NY06-WIN10\admin$' using account 'etmcorad\administrator'~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:07.929+240><thread=6256 (0x1870)>
    ---> WNetAddConnection2 failed (LOGON32_LOGON_NEW_CREDENTIALS) using account etmcorad\administrator (00000035)  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:07.946+240><thread=6256 (0x1870)>
    ---> The device NY06-WIN10 does not exist on the network. Giving up~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:07.947+240><thread=6256 (0x1870)>
    ---> ERROR: Unable to access target machine for request: "16782256", machine name: "NY06-WIN10",  access denied or invalid network path.  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:07.948+240><thread=6256 (0x1870)>
    Execute query exec [sp_CP_SetLastErrorCode] 16782256, 53~  $$<SMS_CLIENT_CONFIG_MANAGER><03-13-2018 10:24:07.949+240><thread=6256 (0x1870)>
    

    Tuesday, March 13, 2018 2:55 PM
  • > "I am unsure of where to go from here. If I can't figure it out, I plan on running a site recovery to repair the installation and then trying to upgrade to see fi that will repair the issue."

    This won't change anything and will be a waste of time.

    What happens if you initiate a manual push to a recently discovered and valid system? Specifically, what does ccm.log say on the site server whn you do this?


    Jason | https://home.configmgrftw.com | @jasonsandys

    Tuesday, March 13, 2018 4:24 PM