locked
Unable to mount database RRS feed

  • Question

  • I have a brand new standalone Exchange server 2010 consolidated roles.  Also 1 DC.  Very simple setup (Lab).  After Exchange finished installing, the default database is not mounted.  Then I created a new DB and it wouldn't mount.   I thought I have to wait for replication... waited for DAYS, still don't mount.

    [PS] C:\Windows\system32>Get-MailboxDatabase

    Name                           Server          Recovery        ReplicationType
    ----                           ------          --------        ---------------
    Mailbox Database 0912309164    NEXUSEXCH2010   False           None
    mbx1                           NEXUSEXCH2010   False           None


    [PS] C:\Windows\system32>Mount-Database mbx1
    Couldn't mount the database that you specified. Specified database: mbx1; Error code: An Active Manager operation faile
    d. Error The Microsoft Exchange Replication service may not be running on server NEXUSEXCH2010.nexus13.local. Specific
    RPC error message: Error 0x6d9 (There are no more endpoints available from the endpoint mapper) from cli_MountDatabase3
    ..
        + CategoryInfo          : InvalidOperation: (mbx1:ADObjectId) [Mount-Database], InvalidOperationException
        + FullyQualifiedErrorId : 785BB2,Microsoft.Exchange.Management.SystemConfigurationTasks.MountDatabase
        + PSComputerName        : nexusexch2010.nexus13.local

    I've checked all MSExchange services are running.  Domain Controller is fine.  No idea what else to do?  Pls help


    Chau

    Monday, June 22, 2015 9:14 PM

Answers

All replies

  • Hi There,

    Did you check that all the Exchange services are running ?


    Exchange Blog:

    www.ntweekly.com

    MCSA, MCSE, MCITP:SA, MCITP:EA, MCITP:Enterprise Messaging Administrator 2010,MCTS:Virtualization

    Monday, June 22, 2015 10:19 PM
  • Sounds like a problem with the replication service even though it is running.  I had a similar problem on a 4 node dag where one of my servers was having a service issue.

    Try running: Test-ReplicationHealth -identity "server name" | fl and see if there are any replication errors.  If so try stopping and restarting the replication service.

    Tuesday, June 23, 2015 1:05 PM
  • Did you restart the server after the installation?

    Give it a restart anyway and check that ALL Exchange services are running on the box. Make sure that Exchange box can access the Domain controller.

    Tuesday, June 23, 2015 1:08 PM
  • Should I still run this even though its a single server with no DAG?

    Chau

    Thursday, June 25, 2015 3:35 PM
  • I've restarted so many times... Exchange and the DC are on the same subnet

    Chau

    Thursday, June 25, 2015 3:36 PM
  • Yes all services are running, tripled checked

    Chau

    Thursday, June 25, 2015 3:36 PM
  • I ran the test replication health and got this:


    [PS] C:\Windows\system32>Test-ReplicationHealth | select error | fl


    Error : An error occurred while reading the state of the Microsoft Exchange Replication service on server 'NEXUSEXCH201
            0'. Verify that the service is running. Error: Service msexchangerepl was not found on computer '.'.

    Chau

    Thursday, June 25, 2015 5:30 PM
  • Hi,

    For your question, it might be caused by the value of the ConfigurationDomainController parameter and the value of the PreferredGlobalCatalog parameter are different. Please run Get-ADServerSettings | FL to ensure.
    I find an similar thread about your question, for your reference: https://social.technet.microsoft.com/Forums/exchange/en-US/ee1895f7-cec6-4a37-be8a-4bdd621e8bc4/active-manager-failed-to-mount-database-mailbox-database?forum=exchange2010

    Thanks


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    • Proposed as answer by Allen_WangJF Monday, July 6, 2015 9:32 AM
    • Marked as answer by Allen_WangJF Tuesday, July 7, 2015 1:56 AM
    Saturday, June 27, 2015 3:45 AM