none
Can't set windows time on member domain controller to manual peer list

    Question

  • Hi, our scenario is as follows. We have a 'hub' datacenter at site A that houses our primary DC. This DC points to a GPS time source and all other domain controllers from other sites get time from this PDC.

    We've just lit up a new datacenter, Site B, across the country which has their own domain controllers but are still a part of the primary domain and get their time from the PDC at Site A.

    We have a request that the domain controllers at Site B get time from their own independent GPS time source located on site.

    I figured this would be easy enough by setting the manualpeerlist and syncfromflags switches on the member domain controller in Site B. However, after starting/stopping w32time service it reverts to Local CMOS Clock even though the config looks correct.

    Note, i've tried this on a workstation (not a DC) and it worked fine... it just seems to be failing on domain controllers.

    Command I entered:

    w32tm /config /syncfromflags:manual /manualpeerlist:gpsntp1.siteb.mycompany.com /update

    Status after shows using local:

    C:\Windows\system32>w32tm /query /status
    Leap Indicator: 3(last minute has 61 seconds)
    Stratum: 0 (unspecified)
    Precision: -6 (15.625ms per tick)
    Root Delay: 0.0000000s
    Root Dispersion: 0.0000000s
    ReferenceId: 0x00000000 (unspecified)
    Last Successful Sync Time: unspecified
    Source: Local CMOS Clock
    Poll Interval: 6 (64s)

    Config shows the correct ntpserver:

    C:\Windows\system32>w32tm /query /configuration
    [Configuration]

    EventLogFlags: 2 (Local)
    AnnounceFlags: 10 (Local)
    TimeJumpAuditOffset: 28800 (Local)
    MinPollInterval: 6 (Local)
    MaxPollInterval: 10 (Local)
    MaxNegPhaseCorrection: 172800 (Local)
    MaxPosPhaseCorrection: 172800 (Local)
    MaxAllowedPhaseOffset: 300 (Local)

    FrequencyCorrectRate: 4 (Local)
    PollAdjustFactor: 5 (Local)
    LargePhaseOffset: 50000000 (Local)
    SpikeWatchPeriod: 900 (Local)
    LocalClockDispersion: 10 (Local)
    HoldPeriod: 5 (Local)
    PhaseCorrectRate: 7 (Local)
    UpdateInterval: 100 (Local)


    [TimeProviders]

    NtpClient (Local)
    DllName: C:\Windows\system32\w32time.DLL (Local)
    Enabled: 1 (Local)
    InputProvider: 1 (Local)
    AllowNonstandardModeCombinations: 1 (Local)
    ResolvePeerBackoffMinutes: 15 (Local)
    ResolvePeerBackoffMaxTimes: 7 (Local)
    CompatibilityFlags: 2147483648 (Local)
    EventLogFlags: 1 (Local)
    LargeSampleSkew: 3 (Local)
    SpecialPollInterval: 3600 (Local)
    Type: NTP (Local)
    NtpServer: gpsntp1.siteb.mycompany.com (Local)

    NtpServer (Local)
    DllName: C:\Windows\system32\w32time.DLL (Local)
    Enabled: 1 (Local)
    InputProvider: 0 (Local)
    AllowNonstandardModeCombinations: 1 (Local)

    VMICTimeProvider (Local)
    DllName: C:\Windows\System32\vmictimeprovider.dll (Local)
    Enabled: 1 (Local)
    InputProvider: 1 (Local)

    Wednesday, January 18, 2017 12:31 AM

All replies

  • You might try portqry.

     

     

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Wednesday, January 18, 2017 12:50 AM
  • Hi, i know for sure that the ntp source is responding, I ran an NTP test tool from the domain controller and it responds just fine.

    The issue is with the Windows time service on the DC; it refuses to latch onto the NTP source specified and reverts to using Local CMOS clock. I can set the exact same settings on a desktop workstation in our environment and it latches on just fine to the NTP source; but the domain controller won't.


    • Edited by squishmike Wednesday, January 18, 2017 6:03 PM
    Wednesday, January 18, 2017 6:02 PM
  • After you do the w32tm /config you should also;

    net stop w32time

    net start w32time

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Wednesday, January 18, 2017 6:09 PM
  • Yea i've restarted the service many times
    Wednesday, January 18, 2017 6:25 PM
  • Just to clarify; i can successfully manually set the windows time service and sync to the manualpeerlist specified on ANY server/workstation in our domain, EXCEPT for our domain controllers. If I try to sync manually on a domain controller (other than our PDC) it reverts to using Local CMOS clock instead of domain time.

    My hunch is there is something somewhere in the domain controller roles that is preventing windows time from syncing to a manualpeerlist on a member DC...

    Wednesday, January 18, 2017 7:57 PM
  • Hi,

    Please check if you have any GPO's forcing the NTP settings.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, January 19, 2017 10:02 AM
    Moderator
  • Hi Alvwan, i've checked all GPs in our environment and none have settings for windows time.

    I've created a new GP with settings for windows time and have applied it to some test servers (non domain controllers). This works like a charm.

    I then apply the same GP to a domain controller and the DC reverts to using local CMOS clock.

    On the DC I run w32tm /query /configuration and it indeed shows the settings from the group policy.

    I then run w32tm /resync and get this error:

    C:\Windows\system32>w32tm /resync
    Sending resync command to local computer
    The computer did not resync because only stale time data was available.

    EDIT/UPDATE: Looks like the GP settings actually took on the domain controllers, so now the DC is correctly getting time via group policy. Funny that it needs to be through GP in order for it to work, you can't set it manually using w32tm commands on DCs...


    • Edited by squishmike Thursday, January 19, 2017 6:17 PM
    • Proposed as answer by AlvwanModerator Monday, January 23, 2017 3:57 AM
    Thursday, January 19, 2017 5:52 PM
  • Hi,

    Thanks for your update and glad to hear that the issue was resolved by setting the group policy.

    If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 23, 2017 3:57 AM
    Moderator