How to allow write access to a file in C:\WINDOWS ? RRS feed

  • Question

  • Hi,
     I've created a user on a public access computer and have locked the user down tight as necessary. However, one program that a public user can run requires write access to a .ini file in C:\WINDOWS. How do i enable this option or give back the user the option to write to C Drive(if necessary)? I tried unchecking "Prevent users from creating folders and files on drive C:\" option but that didn't work either. The program is an educational/learning tool, so disabling the program is not an option. Any advice would be appreciated. Thanks in advance.

    Monday, December 3, 2007 5:07 PM


  • Hi Pvang,


    This can be an expected behavior: Windows SteadyState will create a Restricted User Profile (belongs to User Group) by default, which will not have permissions to write to the Windows folder.


    Based on my test, to change files in the Windows folder, you at least should be a member of Power User Group


    You can change the group membership with the following steps:


    a. Log on with admin, click Start, and then click Run.

    b. In the Open box, type “control userpasswords2” without quotations and then click OK.

    c. Select the public account and click Properties. Under Group Membership tab, select “Standard user”. Click OK.

    d. Log on with your public account to test.



    You can also allow some users (or everyone) to save changes to drive C (or Windows folder)


    1. Open drive C.

    2. Right click the blank space (or the Windows folder) and then choose Properties.  Please check if there is Security tab.


    If there is no Security tab and this is a Windows XP Professional computer, let’s disable simple file sharing to show the Security tab


      a. Click Start, and then click My Computer.

      b. On the Tools menu, click Folder Options, and then click the View tab.

      c. In the Advanced Settings section, clear the Use simple file sharing (Recommended) check box. Click OK.


    If the system is Windows XP Home Edition, please press F8 when the computer starts and boot into Safe Mode with an administrator account to perform the following steps.


    3. Select the Security tab

    4. Please check if your public user account is in the list. If so, please make sure it has Write permission. Otherwise, click the Add button to add the public user to the list. High light the account we added. Select the Allow check box for Write Click OK.


    Note: We can also select Everyone from the user list and then allow the Write permission.


    After that, log on with the account to check the result.


    By the way, if possible, you can also install the program (or the INI file) to another location (if the program supports).


    Best Regards,


    Tuesday, December 4, 2007 11:28 AM