locked
Import Button not available, only download, after selecting updates from catalog!! RRS feed

  • Question

  • Morning,

    In a bit of a panic here this morning!!!. I have accomplished this many times in the not too distant past, now the feature is not available. All I get is a Download button followed which is followed by a Browse button to select where I want the updates downloaded to.???

    There have been no changes to the server that I am aware of, and I login with admin rights to the server where I run the admin console from.!

    Updates I have selected and are in the "basket":

    KB2729094,2731771,2533623,2670838,2834140,2639308,2888049,2882822

    WSUS Info: Server 2012R2, v6.3.9600.16384

    Any and all assistance is greatly appreciated!!!

    Tony

    Monday, October 12, 2015 11:57 AM

Answers

  • Afternoon, so here is the resolution, I am hoping and will verify (again) tomorrow.

    A redirect to go.microsoft.com happens on the way to the update catalog. If you have a f/w rule that not DOES NOT allow this redirect URL, the "Import directly into Windows Server Update Servcies" prompt on the web page does not appear, at least in this instance. So, knowing this functionality was available previously and not knowing what has changed elsewhere (Microsoft???), may be the answer.

    Will post back with the result.

    Tony

    • Proposed as answer by Steven_Lee0510 Monday, November 9, 2015 3:59 PM
    • Marked as answer by Steven_Lee0510 Monday, November 9, 2015 11:30 PM
    Tuesday, October 20, 2015 4:47 PM

All replies

  • Hi Tony,

    I tried to add the updates you mentioned above and I am able to import them.

    Here is the screenshot of my lab:

    Do you access the catalog through the WSUS console --> Import updates?

    Also, do you check the "Import directly into Windows Server Update Services" on the web page?

    If it doesn't work, please try to reset your IE.

    Best Regards.


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, October 13, 2015 2:06 AM
  • Morning,

    Thank you for your response. That is what I am used to seeing.

    However this is what I see now. I have reset IE and still get the same view.

    Tuesday, October 13, 2015 11:31 AM
  • A long shot, since I never use that option, did you install the active-x component?


    Rolf Lidvall, Swedish Radio (Ltd)

    Tuesday, October 13, 2015 11:44 AM
  • Morning,

    I saw that prompt a long time ago but not since. It has been working and now not working. Trying to pin down what has changed but not seeing anything that jumps out at me.

    Thanks!

    Tony

    Tuesday, October 13, 2015 11:50 AM
  • Check your IE add-ons, if it's installed it will be listed:


    Rolf Lidvall, Swedish Radio (Ltd)

    Tuesday, October 13, 2015 12:01 PM
  • Morning,

    The add-on was no longer there, regegistered the dll (MicrosoftUpdateCatalogWebControl.dll) and the add-on is back. However this did not resolve the issue.

    Continuing to research, any other suggestiojns welcomed!!

    Tony

    Tuesday, October 13, 2015 12:56 PM
  • I've seen similar problems with MS sites in IE 11 if you don't add "microsoft.com" to the Compatibility View...

    To make the setting effective, you must restart IE.


    Rolf Lidvall, Swedish Radio (Ltd)


    • Edited by Rolf Lidvall Tuesday, October 13, 2015 1:09 PM
    • Proposed as answer by Steven_Lee0510 Tuesday, October 20, 2015 4:21 PM
    • Unproposed as answer by Steven_Lee0510 Monday, November 9, 2015 3:59 PM
    Tuesday, October 13, 2015 1:08 PM
  • Morning,

    That is there as well.

    Thanks again!

    Tony

    Tuesday, October 13, 2015 2:21 PM
  • Afternoon, so here is the resolution, I am hoping and will verify (again) tomorrow.

    A redirect to go.microsoft.com happens on the way to the update catalog. If you have a f/w rule that not DOES NOT allow this redirect URL, the "Import directly into Windows Server Update Servcies" prompt on the web page does not appear, at least in this instance. So, knowing this functionality was available previously and not knowing what has changed elsewhere (Microsoft???), may be the answer.

    Will post back with the result.

    Tony

    • Proposed as answer by Steven_Lee0510 Monday, November 9, 2015 3:59 PM
    • Marked as answer by Steven_Lee0510 Monday, November 9, 2015 11:30 PM
    Tuesday, October 20, 2015 4:47 PM
  • IE must be a default browser than button Import updates in WSUS will work correctly.

    If your link looks like this http://www.catalog.update.microsoft.com/Home.aspx?SKU=WSUS&Version=6.3.9600.18838&ServerName=SERVERNAME&PortNumber=8530&Ssl=False&Protocol=1.8 so it is not correct. Usually it happened when catalog is opened in different browser without appropriate ActiveX.

    Correct link: http://catalog.update.microsoft.com/v7/site/Home.aspx?SKU=WSUS&Version=6.3.9600.18838&ServerName=SERVERNAME&PortNumber=8530&Ssl=False&Protocol=1.8

    Roman

    Friday, May 24, 2019 7:01 AM
  • In my case it worked with two following conditions:

    • microsoft.com site is added to Compatibility View;
    • I am running Import Updates right from the WSUS console (if the page is reloaded I still see the basket, but the Import directly ... checkbox disappears).

    So my advise is to add the site to Compatibility View, close IE and re-run the action.

    Hope it will work for you.

    Good luck!

    Monday, September 30, 2019 11:08 AM