locked
A problem about the SCCM2012 RRS feed

  • Question

  • There is a problem about the read-only mode of the primary site.

    The hierarchy of the SCCM system is as below. 
    There is one central administration site and two primary sites.
    After installing the primary site 1, it has some problems. The Configuration Manager of the primary site 1 lost in read-only mode, and we cannot edit on this site.

    We noticed the following window popup when i started the Admin Console:
    Your Configuration Manager console is in read-only mode while this site completes tasks related to maintenance mode. After these tasks are complete you must reconnect your Configuration Manager console before you can edit or create new objects.

    After click OK, we can see the status of the primary site 1. In the site hierarchy, we can only see the local site (the primary site 1), while the central administrator site is unavailable.

    And the link state of database replication is unknown. And the percentage is 0%.

    Next, we open the configuration manager of the central administration site, the link state of database replication is being configured. And the percentage is 0%, too.

    Then we run the Replication Link Analyzer on the central administrator site, and the results are as below. (Server-ad is the name of the central administrator site.)
    Checking connectivity at site Server-ad to the SQL Server Server-ad.
    Connection failure detected between Server-ad and the SQL Server Server-ad. Check network and firewall settings between these computers. It may take several minutes for firewall changes to take effect. Connection failure message: Failed to get SQL connection to……

    After we check the problem, it shows the problem as below:
    Initiate public key transfer for target site 001 on source site 002.
    Inconsistent public keys can be remediated by initiating a public key transfer between sites 002 and 001.

    Next, we initiate public key transfer for target site 001 on source site 002, the troubleshooting report result shows there is an error:
    Replication initialization is healthy on site 001 and site 002.

    The problems are presented above. Now we can’t edit the primary site 1, and we don’t have any effective solutions.
    Hope you can help us, thank you!

    Monday, March 20, 2017 1:32 AM

All replies

  • So this is a brand-new setup and it never worked? Why did you decide to go for a CAS at all?
    Have you already examined rcmctrl.log?

    Torsten Meringer | http://www.mssccmfaq.de

    Monday, March 20, 2017 7:19 AM
  • Yes, it's new. And I checked the rcmctrl.log, but didn't find the reason. 
    Tuesday, March 21, 2017 8:40 AM
  • The rcmctrl.log says

    Checking if initialization request is needed for replication group Hardwre_Inventory_25 from site 002.

    Publisher 002 is not active, so not requesting  site data this time.

    Checking if there are bcp file to apply for replication group Hardware_Inventory_25.

    No tracking data for bcp files.

    Retry for process replication is requested.

    Could you give me some ideas?

    Tuesday, March 21, 2017 9:07 AM
  • You haven't answered Torsten's question: why do you want to install a CAS (central administration site)? Won't a single Primary site fulfill your needs? How many clients will you go to manage by SCCM? We are trying to avoid using CAS because there will be many replication issues. 

    Since it's a new installation, I suggest that you can wait for some time because some components may still be installing background. You can try to reboot servers to see if this makes any difference.

    Some troubleshooting regarding replication at below blog:

    https://www.niallbrady.com/2012/07/23/why-is-my-system-center-2012-configuration-manager-console-in-read-only-mode/


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    • Edited by Frank Dong Tuesday, March 21, 2017 4:08 PM
    Tuesday, March 21, 2017 4:08 PM
  • The problem I have is different from the the promlem in the blog:

    https://www.niallbrady.com/2012/07/23/why-is-my-system-center-2012-configuration-manager-console-in-read-only-mode/

    As is explained before, In the site hierarchy of the primary 1 site, we can only see the local site (the primary site 1), while the central administrator site is unavailable. And the link state of database replication is unknown. And the percentage is 0%.

    While in the configuration manager of the central administration site, the link state of database replication is being configured. And the percentage is 0%, too.

    The situation is very different from that of the blogs.

    Friday, March 24, 2017 2:06 AM
  • Is it a secret why you decided to use a CAS? It's not needed in 99% of all cases.
    Posting just log snippets is useless because the context is missing.

    Torsten Meringer | http://www.mssccmfaq.de

    Friday, March 24, 2017 6:58 AM
  • Because we are a big company and we need th CAS to manage.
    Tuesday, March 28, 2017 9:05 AM
  • Hello, may I know if the issue got solved? If so, could you share us the solution?

    If it's still there, I suggest that you can open a Microsoft Support case.

    Thanks in advance.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Sunday, April 9, 2017 12:22 PM