none
GPO created is not taking effect.

    Question

  • Hello All,

    I put together a GPO to disable Java Update in the registry settings according to the instruction located at the below URL.

    https://community.spiceworks.com/how_to/65555-how-to-disable-java-update-notifications-on-windows-7-network-computers

    Once I put the GPO together I linked it to an existing OU in my active directory environment.  I checked a few computers with in the OU and the registry settings are not being applied.  If I go to the Group Policy Management Console and run the "Group Policy Results Wizard" on a computer within the linked OU the generated report shows the GPO was applied successfully. But again once I check the registry to make sure the changes were applied it does not reflect. Thanks in advance.

    Wednesday, January 11, 2017 8:40 PM

All replies

  • Hi,

    Please check if the logon user account has the appropriate privilege to apply this GPO.

    Meanwhile, please temporary disabled the UAC for testing purpose, if this is win10.

    Besides, please check the GPO settings under your domain computer<dc>, ensure that it has no other settings covered it.<block inherit or enforced???>

    No filters for this GPO?

    Best regards,

    Andy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, January 12, 2017 5:39 AM
    Moderator
  • Hi Andy,

    Thanks for your response.

    I'm applying the GPO on the GPMC as a Domain Admin, unless you are referring to the user account logging onto the machine?  I could be wrong but I was always under the impression group policy is applied at system startup and nit during the winlogon process.

    The environment is a mix of Windows 7/10 but the computer I'm currently using as a test machine is a Windows 7 computer.

    The GPO settings look to be correct according to the Group Policy Results wizard, when you look at the result for the machine the winning GPO is the disable java GPO.

    Thursday, January 12, 2017 8:17 PM
  • Hello Will,

    Does a reboot of the system fixes your issue? Please try and let us know the results.


    This posting is provided AS IS with no warranties or guarantees , and confers no rights.

    Ahmed MALEK

    My Website Link

    My Linkedin Profile

    My MVP Profile

    Thursday, January 12, 2017 10:31 PM
  • > I put together a GPO to disable Java Update in the registry settings according to the instruction located at the below URL.
     
    A screenshot of your GPO might be helpful.
     
    Friday, January 13, 2017 9:52 AM
  • Hello Will,

    Does a reboot of the system fixes your issue? Please try and let us know the results.


    This posting is provided AS IS with no warranties or guarantees , and confers no rights.

    Ahmed MALEK

    My Website Link

    My Linkedin Profile

    My MVP Profile

    Hello Mr X,

    I have rebooted the test machine in question many times while working through trial and error.

    Friday, January 13, 2017 5:26 PM
  • > I put together a GPO to disable Java Update in the registry settings according to the instruction located at the below URL.
     
    A screenshot of your GPO might be helpful.
     

    Thanks Martin,

    Here are screenshots of the created GPO.  Please let me know if I can help with anymore detail.

    Friday, January 13, 2017 5:29 PM
  • > Here are screenshots of the created GPO.  Please let me know if I can help with anymore detail.
     
    Hm - you said you linked your GPO to an OU containing computers, but I see that you used user configuration for your Java values... Cut/Paste them to computer configuration instead.
     
    Monday, January 16, 2017 11:04 AM
  • My apologies Martin you are correct. I had made the change over to the computer configuration that same day I took the screen shots but unfortunately the GPO is still not being pushed.
    Thursday, January 19, 2017 2:48 AM
  • Hi will,

    did you try to apply gpupdate /force to the client?

    regards,


    Donski

    Thursday, January 19, 2017 5:10 AM
  • Hi will,

    did you try to apply gpupdate /force to the client?

    regards,


    Donski

    Agree with this, do gpupdate /force.

    GPO is applied to "Authenticated Users"?


    Every second counts..make use of it. Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.


    Thursday, January 19, 2017 5:16 AM
  • Hello Newbee,

    Yes I've run gpupdate as well as rebooted the machine.  Once either is performed I run gpresult /r but the GPO does not show as an applied GPO.

    Thursday, January 19, 2017 11:33 PM
  • Yes the GPO is applied to "Authentcated Users" and is linked to the proper OU containing the computer objects I wish to apply the GPO to.
    Thursday, January 19, 2017 11:35 PM
  • did you enforce the additional GPO that you created in the OU?

    Donski

    Friday, January 20, 2017 1:05 AM
  • did you enforce the additional GPO that you created in the OU?

    Donski

    in addition for this. did you check your new created GPO if it is enable? to check right click the GPO and make sure the enable is check.

    Donski

    Friday, January 20, 2017 1:52 AM
  • > Yes the GPO is applied to "Authentcated Users" and is linked to the proper OU containing the computer objects I wish to apply the GPO to.
     
    If you run gpresult from an elevated command line, does it show up in the "denied" GPOs? If yes, what reason?
     
    Friday, January 20, 2017 10:36 AM