none
Windows 10 not auto connecting to wireless

    Question

  • Hey all,

    Windows 10 across our various devices (surface pro 3, lenovo x240, dell e7250) does not auto connect to our wpa 2 enterprise wireless network. We deploy it via group policy and under win 7 and 8 all machines connect ok automatically

    With windows 10, the machines do not auto connect on startup. We have to manually connect to the network (which works fine). 

    Any ideas? I recreated the GP just in case but it had no effect

    thanks

    Wednesday, August 19, 2015 11:37 PM

Answers

  • Thanks for the help so far.

    I was able to solve this. In our group policy we had enabled the following setting

    Computer config\Administrative Templates\System\Internet Communication Management\Internet Communicating Settings\Turn off Windows Network Connectivity status indicator active tests

    For some reason, in windows 10, this stops wireless from auto connecting to networks. We have since changed this back to not configured and now wireless automatically connects. Seems like a bug to me as this setting should not stop auto connects, it merely should just stop the tests to check for internet connectivity

    Hope this helps others out there

    • Marked as answer by The Admin User Thursday, August 20, 2015 3:01 AM
    Thursday, August 20, 2015 3:01 AM

All replies

  • Hi,

    Thanks for the suggestion. Unfortunately these are clean installs of windows 10 and we don't any third party VPN providers installed.

    Any other ideas?

    Thursday, August 20, 2015 12:18 AM
  • Open Device Manager and uninstall wifi network driver, Restart your system. Let windows detect the wifi card. Now update your wifi card driver by downloading the latest driver from the website of the manufacturer.

    If this doesn't help then reset your Router.


    S.Sengupta, Windows Experience MVP

    Thursday, August 20, 2015 1:26 AM
  • Thanks for the help so far.

    I was able to solve this. In our group policy we had enabled the following setting

    Computer config\Administrative Templates\System\Internet Communication Management\Internet Communicating Settings\Turn off Windows Network Connectivity status indicator active tests

    For some reason, in windows 10, this stops wireless from auto connecting to networks. We have since changed this back to not configured and now wireless automatically connects. Seems like a bug to me as this setting should not stop auto connects, it merely should just stop the tests to check for internet connectivity

    Hope this helps others out there

    • Marked as answer by The Admin User Thursday, August 20, 2015 3:01 AM
    Thursday, August 20, 2015 3:01 AM
  • Hi,

    Glad to see your problem resolved, thanks for your sharing the solution with us.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, August 20, 2015 5:08 AM
    Moderator
  • This was 100% spot on the fix for me too. 

    Thanks for your assistance.

    B. Duncan

    Monday, June 27, 2016 5:58 AM
  • Thanks - fixed my problem with connecting to the internet after Windows 10 install,
    Friday, January 13, 2017 11:02 PM
  • With windows 10, the machines do not auto connect on startup. We have to manually connect to the network (which works fine). 

    One reason this happens it seems is when the system is multi-homed.  E.g. W10 seems to always pick my Ethernet to use and then leaves the Wi-Fi not connected.  So if I want to use it I have to manually start it.  No extra authentication is required, since it still shows as "Connect automatically."  It just needs that manual click to get it going.


    Robert Aldwinckle
    ---

    Sunday, January 15, 2017 3:20 AM
  • We have the exact same problem with Win10 1607 and 1703.  The deletion of the WiFi card in device manager fixes this for a short period, as does removing the known APs from the history.

    The Fix above isnt applicable to us as not enabled.

    Win7 worked flawlessly.  So far win10 is a pile of poo.

    Friday, June 30, 2017 3:12 PM
  • Hi, we have the issue with Intel adapters, if we install the PROSet software it connects automatically, if it's not installed we see a 1 minute delay.

    Check the WLAN-AutoConfig log in eventvwr for a 8002 event, WLAN AutoConfig service failed to connect to a wireless network. Failure Reason: The driver disconnected while associating.

    That's our issue, have Cisco wireless gear.

    Thanks
    Ben

    Monday, July 3, 2017 12:22 AM