none
Hyper V Cannot Ping Host from VM RRS feed

  • Question

  • Hi

    Server running Windows 2016 with 1 x VM using Hyper V (Also Running Server 2016) 2 x NIC 

    I have tried every configuration but i cannot get a constant connection between VM \ Host \ Client - when i do the internet drops off the main server.

    I have 1 NIC IP 192.168.7.250 /24 DG 192.168.7.1 DNS 192.168.7.3 - 192.168.7.3 is the DC and DNS Server

    The vethernet adapter in the VM is 192.168.7.254 /24 

    IN Hyper V Virtual Switch i have tried internal and external and linked to this NIC but still no luck

    Any ideas?

    Friday, February 22, 2019 12:07 PM

All replies

  • Please copy paste the IP configuration from Hypervisor by running command ipconfig/all

    and run the same command on the VM as well and paste the output.

    Thanks,


    Regards, NSeth

    Friday, February 22, 2019 12:22 PM
  • For future reference, the Hyper-V forum is here: https://social.technet.microsoft.com/Forums/en-US/home?forum=winserverhyperv&filter=alllanguages

    This forum is for Virtual Server 2005.  You'll find a lot more activity on that forum.

    If you want access to the network outside of the host, you need to create an external virtual switch.

    Make sure you've done that and that it is connected to an active (plugged in) NIC, since you've mentioned you have two.

    Have you updated your Windows firewall to allow pings?  Default blocks ping.

    Correct gateway?  

    Is there a restriction on your switch for number of MACs per port?  Some organizations have these and this will effectively block your VM's network connection.

    Friday, February 22, 2019 10:57 PM