locked
Security Compliance Manager 3.0 "The data could not be exported to Excel" (Office 365 complication) RRS feed

  • Question

  • Situation: *I have a bad feeling there is no actual fix for this other than to uninstall and install msdn office 2013 instead... but, I am posting this not only for posterity/Internet searches, but also for the Developers of the SCM 3.0.  

    I am posting this so that they know they will need to readdress their workmanship of the macro-based Excel Compare; since, to assume that everyone has Macros turned "on" in the first place is a VERY BAD assumption, but also if/when there are problems in adding VBA/"Always On Macro Support - as in some Admins won't allow this in their environment because Users are stupid and click on anything"... it would behoove them not to assume that such an environment exists; they should develop their tools for the "Least Privileged User" and the Most Restrictive setup of toolsets...  Don't "Ass-u-me".

    Win 7 workstation - domain joined, I am a domain admin, but running the tool on desktop as User

    SCM 3.0, Office 365 (FYI... you absolutely no control over Excel/Office Tools "Features" in Office 365. You "should have" Visual Basic for Applications available for Macros to work correctly from the Solution Accelerator.  But you have no way of knowing whether or not it is actually installed and/or working when its Office 365, due to only "Repair" or "Uninstall" options are available.  "Change", i.e., "Add or Remove Features" is not available in the 365 version.)

    **************OK, with that said and off my chest ***********************

    Have 2 GPOs imported, ready to "Compare/Merge".  In the Compare/Merge Screen, click on Export to Excel > Excel Opens, however:

    It prompts you to "Export to Excel" which is actually a "Save As" dialog box... which defaults to My Documents (first Screenie) and give you the error (seen in second screenshot).  Compare/Merge pops open a "CompareExport.xlsm" file which is supposed to AutoLaunch via an Excel Macro and show you your settings.

    The file has no data.

    ***UPDATE: I don't know if this will work for others?  But I chose "Desktop" lastly, and it finally worked /sigh effing sigh...

    I am not about to solution their own product for them; but it seems (guess) that perhaps there is a "security feature" in regards to "where" exactly you are trying to save the file?  WHo knows... Just keep messing about, you may have luck...

    Grrrrrrr

    Thursday, February 26, 2015 7:01 PM

All replies

  • I get this error no matter where I try to export as excel.

    Office Pro Plus 2013 with VBA feature installed and macros set to enable .... 

    Pity as none of the other export types are human readable for embedding into documentation... 

    Tuesday, June 16, 2015 11:48 AM
  • Having the same issue. Ensured same settings as above and no joy. Any chance of a fix in the next version please?
    Wednesday, February 10, 2016 1:37 PM
  • I know this is very old but, I ran in to this issue today.  I did everything it said and it still happened.  What was odd was this just worked the other day with another GPO->excel.  I realized the only difference was I had other spreadsheets open.  Once I closed my other spreadsheets / excel processes and ran it again, it loaded.  Hope this helps.

    Tom

    • Proposed as answer by Z Godwin Wednesday, September 21, 2016 7:11 PM
    Tuesday, September 13, 2016 12:42 PM
  • This issue still exists in version 4.0. But the workaround suggested still works.
    Wednesday, September 21, 2016 7:12 PM