none
DPM library could not reserve the drive resource HP MSL6000 RRS feed

  • Question

  • We formerly had this HP DL380 G4 connected to an HP MSL6000 tape library functioning properly with windows server 2003 and HP Data Protector 6.0 installed, we decided to move to windows server 2008 R2 and DPM 2010 because we already have a DPM installed and we would like to synchronise these, one for short term protection and this server for long term.

    After re-installing the server completely and installing DPM, the tape library showed up properly in management - libraries with the slots and everything. In device manager the tape drives and the medium changers are shown, we tried installing the latest available drivers

    -HP StorageWorks MSL6000 series Medium Changer (HP version 3.0.2.0)
    -2x HP LTO-Ultrium-2 drive (HP version 1.0.6.3)

    When we try to "identify tape" or "erase tape" we get this: DPM could not reserve the drive resource because one of required drive resources is not online or it needs cleaning or servicing. (ID 24052)

    I tried the HP tape tools program and even updating the firmware, everything works also when I install HP Data Protector back i can use the tape drive and not in DPM. From what I have read is that HP data protector will use it's own drivers to control the tape library, DPM will use the windows drivers. Could this be why it's not functioning properly although it's shown in management - libraries?

     

    Thank you,


    Kind regards, Neirynck Davy - MCTS
    Monday, February 14, 2011 7:22 AM

Answers

  • Hi

    Regarding the MSL6000 the driver isn't 100%. I had the same problem with one customer and after I disabled one tape drive I got it working. I don't think the HP will write a new driver since it's a very old product.

    Consider upgrading your medium changer to MSL4048 or higher since the drivers from HP is 100% compatible with DPM.

     

    BR

    Robert Hedblom

    MVP DPM



    Check out my DPM blog @ http://robertanddpm.blogspot.com

    • Marked as answer by davy.neirynck Tuesday, March 8, 2011 8:59 PM
    Monday, February 14, 2011 1:42 PM
    Moderator