locked
WSUS problem RRS feed

  • Question

  • Hy there.

    I have recently made a virtual machine , WSUS, with Windows Server 2012 R2. I have synced with everything ineeded, and it seems to work just fine. The problem is that myWindows 2008 Domain controller does not seem to apply the group policy for WSUS. I attached some pics. I don't know what iam doing wrong, it worked just fine with the same setting on the old 2003 WSUS. Why not work now? When isay they don't work, imean that the Computers and servers are not in the WSUS console, nor can they access updates.

    In addition, we use Windows Defender, and I want Windows Defender to get updates from WSUS, I already configured WSUS to pull these updates. But will Defender automatically get it from there? Or do I have to do something else?

    Friday, October 24, 2014 7:22 AM

Answers

  • Hi,

    Check from a target server :-

    1. Open command prompt and type "GPRESULT /H GPReport.html" Check the output for applied policy.

    2.If the Policy is set than open "gpedit.msc" from target server check the WSUS Path is set on policy or not.

    3. Telnet to WSUS Server port 80 and confirm that the server is Accessible through Telnet or not.

    3. Also check the "tracert WSUS_IP " find out is their is any other HOP's are available or not.

    Post the update once you go through these steps.


    Regards, Koustov Choudhury

    • Marked as answer by Steven_Lee0510 Wednesday, November 5, 2014 9:52 AM
    Friday, October 24, 2014 9:16 AM
  • in Specify Intranet, instead of putting http://host, I put http://host.company.ro:8530 ....for some reason that all it took.

    I noted that the string in your blanked out GPO image was pretty darn short anyway. (Hiding information from those trying to help you unnecessarily delays the troubleshooting. Had we been able to see the port suffix was actually missing, you might could have had a solution in the FIRST reply, 6 hours ago.)

    But yeah... WSUS on WS2012 installs, by default, to port 8530. This is a pretty common mistake among admins migrating from WSUS v3 to WSUS v6. Using the correct URL is always important. :)

    I would imagine http://host:8530 works just as well.


    Lawrence Garvin, M.S., MCSA, MCITP:EA, MCDBA
    SolarWinds Head Geek
    Microsoft MVP - Software Packaging, Deployment & Servicing (2005-2014)
    My MVP Profile: http://mvp.microsoft.com/en-us/mvp/Lawrence%20R%20Garvin-32101
    http://www.solarwinds.com/gotmicrosoft
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.


    Friday, October 24, 2014 2:24 PM

All replies

  • check at a workstation, using GPRESULT - is your GPO linked correctly, is correctly resolving, and the settings are they applying there ?

    (it seems you have done RSoP at the server ?)


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Friday, October 24, 2014 8:20 AM
  • Ok, in the mean tome 3 workstations and 1 server have appeared in the WSUS. The server says it has reported and the workstations say Not Yet Reported.

    I did a gpresult /r on the workstation, and it says :

    Friday, October 24, 2014 9:01 AM
  • Hi,

    Check from a target server :-

    1. Open command prompt and type "GPRESULT /H GPReport.html" Check the output for applied policy.

    2.If the Policy is set than open "gpedit.msc" from target server check the WSUS Path is set on policy or not.

    3. Telnet to WSUS Server port 80 and confirm that the server is Accessible through Telnet or not.

    3. Also check the "tracert WSUS_IP " find out is their is any other HOP's are available or not.

    Post the update once you go through these steps.


    Regards, Koustov Choudhury

    • Marked as answer by Steven_Lee0510 Wednesday, November 5, 2014 9:52 AM
    Friday, October 24, 2014 9:16 AM
  • Well I did the following:

    in Specify Intranet, instead of putting http://host, I put http://host.company.ro:8530 ....for some reason that all it took.

    Friday, October 24, 2014 10:37 AM
  • Hi,

    Are you able to communicate with the WSUS Host using telnet ?

    If yes than reboot your wsus server and check.


    Regards, Koustov Choudhury

    Friday, October 24, 2014 10:47 AM
  • in Specify Intranet, instead of putting http://host, I put http://host.company.ro:8530 ....for some reason that all it took.

    I noted that the string in your blanked out GPO image was pretty darn short anyway. (Hiding information from those trying to help you unnecessarily delays the troubleshooting. Had we been able to see the port suffix was actually missing, you might could have had a solution in the FIRST reply, 6 hours ago.)

    But yeah... WSUS on WS2012 installs, by default, to port 8530. This is a pretty common mistake among admins migrating from WSUS v3 to WSUS v6. Using the correct URL is always important. :)

    I would imagine http://host:8530 works just as well.


    Lawrence Garvin, M.S., MCSA, MCITP:EA, MCDBA
    SolarWinds Head Geek
    Microsoft MVP - Software Packaging, Deployment & Servicing (2005-2014)
    My MVP Profile: http://mvp.microsoft.com/en-us/mvp/Lawrence%20R%20Garvin-32101
    http://www.solarwinds.com/gotmicrosoft
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.


    Friday, October 24, 2014 2:24 PM