none
Bare linefeeds clogging journaling

    Question

  • Hi,

    We have a problem where emails that we receive from an automated service contain bare linefeeds and cannot be sent to the journaling mailbox.  Our Exchange server reports “Last Error: 400 4.4.7 The server responded with: 550 5.6.2 SMTPSEND.BareLinefeedsAreIllegal; message contains bare linefeeds, which cannot be sent via DATA. The failure was replaced by a retry response because the message was marked for retry if rejected.”

    I fully understand why this is happening and have contacted the sender.  Unfortunately they are a multi-national corporation and are showing little interest in my mail queue problem.  We also have no choice but to interact with them as they are part of the industry we operate in.

    My question is; Is there anything I can do to stop these messages from being archived, or is there any way I can disable the bare-linefeed check on the journal send connector?  Alternatively, I'm open to any other suggestions that you may have.

    Thanks in advance.

    Wednesday, November 11, 2015 10:09 AM

Answers

  • Yea, ultimately, you are stuffed  :P

    So you have access to the journaling servers SMTP logs?

    When I see "400 4.4.7 The server responded with: 550 5.6.2 SMTPSEND.BareLinefeedsAreIllegal; message "

    That tells me the recipient server is blocking it.  If you enable SMTP protocol logging on the send connector, you should see it as well.


    Twitter!: Please Note: My Posts are provided “AS IS” without warranty of any kind, either expressed or implied.

    Thursday, November 12, 2015 12:01 PM

All replies

  • You could try setting on the receive connector:

    https://technet.microsoft.com/en-us/library/bb125140%28v=exchg.160%29.aspx?f=255&MSPPError=-2147217396

    The BareLinefeedRejectionEnabled parameter specifies whether this Receive connector rejects messages that contain bare line feed (LF) characters in the SMTP DATA stream.

    Line feed characters that aren't immediately preceded by carriage return (CR) characters are known as bare line feeds. Bare line feeds aren't allowed in SMTP communications. Although it may be possible for a message containing a bare line feed to be delivered successfully, such messages don't adhere to the SMTP protocol standards and may cause problems with messaging servers. If you set this parameter to $true, the Receive connector rejects any messages that contain bare line feeds.

    The default value is $false.


    Twitter!: Please Note: My Posts are provided “AS IS” without warranty of any kind, either expressed or implied.


    Wednesday, November 11, 2015 12:39 PM
  • Thanks for the response Andy.  I'll look into that but I'm not sure which receive connector I would modify. Isn't this error generated by the send connector? I don't have a specific receive connector for the journaling mailbox, just a send connector which sends directly to our cloud based archiving facility.

    Wednesday, November 11, 2015 1:02 PM
  • Ok, so you want to still get these but not journal. There is no send connector setting I am aware of and that error in this case is actually being generated by external server then yes?

    400 4.4.7 The server responded with: 550 5.6.2 SMTPSEND.BareLinefeedsAreIllegal; message contains bare linefeeds, which cannot be sent via DATA. The failure was replaced by a retry response because the message was marked for retry if rejected.”

    If so, then the items arent being sent correct?

    I think you really have 2 options if the original sender isnt going to fix their broke cr@p.

    Reject on your end using that receive connector setting I mentioned above, or ask the archiving vendor to accept them. I dont think the journaling rules are descreet enough to simply exclude those specific messages from being journaled.


    Twitter!: Please Note: My Posts are provided “AS IS” without warranty of any kind, either expressed or implied.

    Wednesday, November 11, 2015 1:10 PM
  • I'm not convinced that it is being generated by the receiving server, for two reasons; a) I don't see anything in the receiving server's logs that the connection was even attempted, and b) the portion of the message "which cannot be sent via DATA" implies that the send connector has rejected it as it cannot complete the SMTP conversation.

    Queue log for one of the messages follows:

    Identity: MAILSERVER01\16\27573690040328
    Subject: ALL: File XYZZY00120151112020034.zip
    Internet Message ID: <7ee04ff6-21d3-4a99-badc-54021d85baa9@journal.report.generator>
    From Address: <>
    Status: Retry
    Size (KB): 47
    Message Source Name: Journaling
    Source IP: 255.255.255.255
    SCL: 0
    Date Received: 12/11/15 02:00:45
    Expiration Time: 
    Last Error: 400 4.4.7 The server responded with: 550 5.6.2 SMTPSEND.BareLinefeedsAreIllegal; message contains bare linefeeds, which cannot be sent via DATA. The failure was replaced by a retry response because the message was marked for retry if rejected.
    Queue ID: MAILSERVER01\16
    Recipients:  journaling@journal.organisation.com;3;2;[{LRT=};{LED=400 4.4.7 The server responded with: 550 5.6.2 SMTPSEND.BareLinefeedsAreIllegal; message contains bare linefeeds, which cannot be sent via DATA. The failure was replaced by a retry response because the message was marked for retry if rejected.};{FQDN=};{IP=}];0;CN=Journal Send Connector to Archive,CN=Connections,CN=Exchange Routing Group (RDBGZMFD01QNBJR),CN=Routing Groups,CN=Exchange Administrative Group (FYDVSOHF23SPDLT),CN=Administrative Groups,CN=The Organisation Ltd,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=organisation,DC=local;0

    That said, I'm beginning to suspect that unless the sender can start sending the messages with <CR><LF> instead of <LF> (UNIX host) then I'm probably stuffed! ;-)

    Thanks.

    Thursday, November 12, 2015 8:26 AM
  • Yea, ultimately, you are stuffed  :P

    So you have access to the journaling servers SMTP logs?

    When I see "400 4.4.7 The server responded with: 550 5.6.2 SMTPSEND.BareLinefeedsAreIllegal; message "

    That tells me the recipient server is blocking it.  If you enable SMTP protocol logging on the send connector, you should see it as well.


    Twitter!: Please Note: My Posts are provided “AS IS” without warranty of any kind, either expressed or implied.

    Thursday, November 12, 2015 12:01 PM