none
Queue job ReportingTimesheetPeriodSync failed RRS feed

  • Question

  • Hi,

    I'm using Project Server 2010.

    I've Closed some Timesheets Reporting Periods (option Server Settings, Time Reporting Periods), because we have just closed the fiscal year and everything has already been reported, and I've received 29 emails with this error (for different Periods, 29 periods)

    Your queue job ReportingTimesheetPeriodSync failed. Please contact your administrator for assistance

    Your ReportingTimesheetPeriodSync job failed.Its current state is FailedNotBlocking.It was 0% complete.It entered the queue at 10/04/2012 09:53:53.
    To get more information about the job failure, please go to Project Web App.Select Personal Settings from the left menu.Then select My Queued Jobs.
    The errors returned from the queue are as follows:
     Error ID: 24013
     Error ID: 26000
    Detailed error below - send it to the administrator for more detailed troubleshooting.
    <?xmlversion="1.0"encoding="utf-16"?>
    <errinfo>
    <general>
    <classname="Reportingmessageprocessorfailed">
    <errorid="24013"name="ReportingTimesheetPeriodMessageFailed"uid="a000b84c-21f8-4792-a3e8-d84090d18a4a"QueueMessageBody="PeriodUid='2db872c3-9e16-45fd-afc5-27cd065a8977'.PeriodStartDate='06
    񳏌00:00:00'.PeriodEndDate='06񳏌23:59:59'.PeriodName='Wk252012'.PeriodStatus='Closed'"Error="StoredProcedureMSP_Epm_SyncPeriodInTimesheetProjectfailed.Returncode=-1"/>
    <errorid="24013"name="ReportingTimesheetPeriodMessageFailed"uid="b20def16-865a-4d54-b3b5-c841ebf78c30"QueueMessageBody="PeriodUid='2db872c3-9e16-45fd-afc5-27cd065a8977'.PeriodStartDate='06
    񳏌00:00:00'.PeriodEndDate='06񳏌23:59:59'.PeriodName='Wk252012'.PeriodStatus='Closed'"Error="StoredProcedureMSP_Epm_SyncPeriodInTimesheetProjectfailed.Returncode=-1"/>
    <errorid="24013"name="ReportingTimesheetPeriodMessageFailed"uid="d70b4a59-3ad9-4c9b-bd28-958fe2e6fcce"QueueMessageBody="PeriodUid='2db872c3-9e16-45fd-afc5-27cd065a8977'.PeriodStartDate='06
    񳏌00:00:00'.PeriodEndDate='06񳏌23:59:59'.PeriodName='Wk252012'.PeriodStatus='Closed'"Error="StoredProcedureMSP_Epm_SyncPeriodInTimesheetProjectfailed.Returncode=-1"/>
    <errorid="24013"name="ReportingTimesheetPeriodMessageFailed"uid="ca27afd3-039b-42c6-badf-c8254b145e50"QueueMessageBody="PeriodUid='2db872c3-9e16-45fd-afc5-27cd065a8977'.PeriodStartDate='06
    񳏌00:00:00'.PeriodEndDate='06񳏌23:59:59'.PeriodName='Wk252012'.PeriodStatus='Closed'"Error="StoredProcedureMSP_Epm_SyncPeriodInTimesheetProjectfailed.Returncode=-1"/>

    <errorid="24013"name="ReportingTimesheetPeriodMessageFailed"uid="5ce09fe5-5c33-4612-97c2-6c42604c3870"QueueMessageBody="PeriodUid='2db872c3-9e16-45fd-afc5-27cd065a8977'.PeriodStartDate='06񳏌00:00:00'.PeriodEndDate='06񳏌23:59:59'.PeriodName='Wk252012'.PeriodStatus='Closed'"Error="StoredProcedureMSP_Epm_SyncPeriodInTimesheetProjectfailed.Returncode=-1"/>
    <errorid="24013"name="ReportingTimesheetPeriodMessageFailed"uid="acc77f91-1309-4dc9-bff0-8d54244f19c6"QueueMessageBody="PeriodUid='2db872c3-9e16-45fd-afc5-27cd065a8977'.PeriodStartDate='06
    񳏌00:00:00'.PeriodEndDate='06񳏌23:59:59'.PeriodName='Wk252012'.PeriodStatus='Closed'"Error="StoredProcedureMSP_Epm_SyncPeriodInTimesheetProjectfailed.Returncode=-1"/>
    </class>
    <classname="Queue">
    <errorid="26000"name="GeneralQueueJobFailed"uid="686fd9d7-2223-42f8-97a9-93b0db5f324e"JobUID="61cab646-52ee-4665-88af-3a09e7b304c4"ComputerName="APPSERVER"GroupType="ReportingTimesheetPeriodSync"MessageType="ReportTimesheetPeriodSyncMessageEx"MessageId="1"Stage=""/>
    </class>
    </general>
    </errinfo>

    I've been looking inside the Stored Procedure MSP_Epm_SyncPeriodInTimesheetProject and it is very simple, it returns an error -1 because it doesn't find a record:

    IF NOT EXISTS (SELECT TaskUID FROM dbo.MSP_EpmTask WHERE ProjectUID = '0000cf75-fb12-4ffc-a404-aec4f3258a9c'

    AND TaskUID = @PeriodUID)

       BEGIN

         RETURN -1

       END

    Do you know how to solve this problem?

    Thank you and regards,

    José Espases

    Thursday, October 4, 2012 9:45 AM

All replies

  • Hi Jose,

    Please see if below article from Andre helps. 
    http://av-epm.blogspot.in/2011/11/project-server-2010-august-2011-cu.html


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    Thursday, October 4, 2012 10:03 AM
  • Hi Amit,

    thank you for your answer, it says that better if I install the CU August 2011.

    The last update I installed was the Project Server 2010 SP1, and I didn't install the CU June 2011 (30th June). I've seen that the latest Cumulative Update is the CU June 2012. Do you know if CU June 2012 contains all the hotfixes issued on June 2011, August 2011, October 2011, December 2011, February 2012 and April 2012?

    If yes, then I will install this one in a test environment and will see if the problem has been solved, otherwise I'll have to install all of them.

    I've been reading the documentation for this CU and it seems that everything is included but I'm not completely sure. It says at the beginning: "Cumulative update packages for Microsoft Project Server 2010 contain hotfixes for the Project Server 2010 issues that were fixed since the release of Project Server 2010."

    Thank you for your help,

    José Espases

    Thursday, October 4, 2012 11:04 AM
  • Hi Jose,

    Microsoft recommended to install the June 2011 CU with SP1.
    http://technet.microsoft.com/en-us/library/hh272536.aspx
    The June 2011 Project Server Cumulative Update was released the same date as the Project Server 2010 Service Pack 1 update. We recommend that you install both. The June 2011 Project Server Cumulative Update contains several fixes and improvements that are not contained in the Project Server 2010 Service Pack 1 update. You can install the June 2011 CU before or after you install the Service Pack 1 Update.

    You can install the latest CU - June 2012 :
    http://support.microsoft.com/kb/2598355

    It says: 

    This cumulative update package contains all the .msp files that we released as hotfixes or as public updates that target Project Server 2010. This update package also targets SharePoint Server 2010 and SharePoint Foundation 2010. Therefore, you do not have to install those packages separately.

    Hope that helps.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    Thursday, October 4, 2012 11:20 AM
  • Hi Amit,

    Sorry, I made a mistake, the last CU that I installed was CU Feb 2012, and before that one I installed SP1 and CU Dec 2011 (one after the other the same day):

    So now I'm not sure if installing the CU Jun 2012 will solve anything. Anyway, I will go for it and will see.

    Thank you for your help,

    José Espases

    Thursday, October 4, 2012 11:41 AM
  • How did you solve your problem??

    Thanks,


    PWAdmin

    Tuesday, June 25, 2013 4:26 PM
  • Hi,

    I'm sorry, I don't remember how I did solve this issue, and I don't have any trace in my records.

    Probably I installed the CU and that was all, last CU I installed was September/November 2012 (and I'm planning to migrate to 2013 in two weeks).

    Regards,

    José Espases

    Wednesday, June 26, 2013 8:05 AM
  • Hello José,

    We are also planning to change for project server 2013. Is it possible for you to tell me how you will do that? By your self? How many time it will take you??

    I am curious

    Did you want my email?


    PWAdmin

    Tuesday, July 2, 2013 5:02 PM
  • Hi,

    yes, I will do it by myself, but I'm in holidays this week,  if you don't mind I will tell you my plan and the result of it when I'll be back.

    You can give me your email address but anyway I will share this info here (new post) probably it will be useful for someone, I will send you, too.

    Regards,

    Jose Espases

    Tuesday, July 2, 2013 8:41 PM
  • Ok!

    Update this post when you will have some news! Thank you so much!


    PWAdmin

    Wednesday, July 3, 2013 1:13 PM
  • So did you switch to project2013?

    Best regards,


    PWAdmin

    Tuesday, July 16, 2013 12:56 PM
  • Hi,

    still working on it, I have already installed SharePoint 2013, Project Server 2013 and now (right now) I'm restoring the 2010 databases to the new environment, I suppose there will be some problems in the next step, which is to migrate the databases to 2013 (only one DB with more schemas).

    Regards,

    José Espases

    Tuesday, July 16, 2013 1:02 PM
  • When you define timesheet periods, the entries will be updated in MSP_EPMTask table for all the timesheet periods. From the error it seems that the Timesheet entries are not updated in MSP_EPMTask Table.

    To fix the issue you might have to insert the entries in the MSP_EPMTask table in Reporting database.

    However, modifying the database directly will lead to an unsupported incident. Please open a support incident with Microsoft and perform these changes with the help of Microsoft Support Team.


    Cheers! Happy troubleshooting !!! Dinesh S. Rai - MSFT Enterprise Project Management

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you. This can be beneficial to other community members reading the thread.


    Tuesday, July 16, 2013 1:20 PM
  • Any updates?

    PWAdmin

    Wednesday, August 7, 2013 4:58 PM