locked
Multiple BSOD, minidump seems to indicate ntsokrnl.exe RRS feed

  • Question

  • Been having problems with my laptop recently.  Whenever I try to connect to my wireless it crashes.  I've tried multiple USB adapters and it's the same result every time.  The included link contains the minidump files and they seem to indicate ntsokrnl.exe.  Any help would be appreciated.

    http://rapidshare.com/share/4B01528A8F4446FA4AA4353224DF6009

    Sunday, April 13, 2014 5:07 PM

Answers

  • Have you tried booting into safe mode (F8) and installing it there.  You can also get a version of the tool that can run from a bootable USB.

    It is pretty obvious the HD is in trouble.  If you have your data backed up it might just be worth moving on.


    Wanikiya and Dyami--Team Zigzag

    • Marked as answer by ZigZag3143x Monday, April 14, 2014 2:44 AM
    Monday, April 14, 2014 2:26 AM

All replies

  • These crashes were related to memory corruption (probably caused by a driver). There were 4 different apparent causes

    Please run this test to find which driver is causing the problem.  

    If you are overclocking (pushing the components beyond their design) you should revert to default at least until the crashing is solved. If you don't know what it is you probably are not overclocking.


    Driver verifier (for complete directions see our wiki here)
    Co-Authored by  JMH3143

    Wanikiya and Dyami--Team Zigzag

    Sunday, April 13, 2014 5:15 PM
  • Here is a link to the dump files and msinfo32 save file.

    http://rapidshare.com/share/5BFE86CBF83303A3F582827887BEACEA

    the laptop is a Dell XPS 17 L702x

    Intel Core i7-2670QM CPU @ 2.20GHz
    8GB ram, what it came with
    Win 7 Ultimate

    I reinstalled windows a week or two ago trying to fix problems, I had to replace a HDD a month or two ago because it died.  Windows won't finish booting if I have the wireless card installed, so I've removed that for now.

    Thanks for your time.

    Sunday, April 13, 2014 6:31 PM
  • Zerix

    None of those had driver verifier enabled.  There are 4 different apparent causes and we need verifier to find the underlying one.  You do have a problematic 4 year old wireless driver that is still loading (netr28ux.sys)

    You can make sure verifier is running by typing verifier /query at an elevated command prompt.  If it is running you should see a list of drivers (we dont care which atm)


    Wanikiya and Dyami--Team Zigzag

    Sunday, April 13, 2014 6:39 PM
  • http://rapidshare.com/share/9D88B301990C8BFED2BCEDD017475A1E

    Here's the most recent dump file.  Driver verifier is enabled according to verifier /query, although my minidump settings weren't what the instructions said, apparently, so I changed those.  If it still isn't showing up I'm not sure what else to do.


    And I got Speccy on the laptop, so if there's any info you need from there let me know.
    • Edited by zerix807 Sunday, April 13, 2014 8:29 PM
    Sunday, April 13, 2014 8:22 PM
  • Zerix

    There is a clue in this one.  There appears to be an I/O error.  (hd, page file, or much less common cpu).  The generic code is F4 and its decription is a critical process terminated.  It means that one of the core (and therefor critical) processes terminated and the system could nto go on.

    Lets eliminate the OS and HD as the issue by running a CHKDSK, and SFC

    CHKDSK /R /F
    Chkdsk disclaimer: While performing chkdsk on the hard drive if any bad sectors are found  any data available on that sector might be lost so as usual backup your data.
    Run CHKDSK /R /F from an elevated (Run as administrator) Command Prompt.
    Do this for each hard drive on your system.
    When it tells you it can't do it right now - and asks you if you'd like to do it at the next reboot - answer Y (for Yes) and press Enter.
    
    Then reboot and let the test run.
    It may take a while for it to run, but keep an occasional eye on it to see if it generates any errors.
    http://www.howtogeek.com/howto/windows-vista/guide-to-using-check-disk-in-windows-vista/
    
    
     See "CHKDSK LogFile" below in order to check the results of the test.
    
    CHKDSK LogFile:
    Go to Start and type in "eventvwr.msc" (without the quotes) and press Enter
    Expand the Windows logs heading, then select the Application log file entry.
    Double click on the Source column header.
    Scroll down the list until you find the Chkdsk entry (wininit for Win7) (winlogon for XP).
    Copy/paste the results into your next post. 

    Please run a system file check (SFC)
    
    All instructions are in our Wiki article below...
    Should you have any questions please ask us.
    
    System file check (SFC) Scan and Repair System Files
    
    

    Microsoft (R) Windows Debugger Version 6.3.9600.17029 AMD64
    Copyright (c) Microsoft Corporation. All rights reserved.
    
    
    Loading Dump File [C:\Users\Ken\Desktop\041314-23337-01.dmp]
    Mini Kernel Dump File: Only registers and stack trace are available
    
    
    ************* Symbol Path validation summary **************
    Response                         Time (ms)     Location
    Deferred                                       SRV*H:\symbols*http://msdl.microsoft.com/download/symbols
    Symbol search path is: SRV*H:\symbols*http://msdl.microsoft.com/download/symbols
    Executable search path is: 
    Windows 7 Kernel Version 7601 (Service Pack 1) MP (8 procs) Free x64
    Product: WinNt, suite: TerminalServer SingleUserTS
    Built by: 7601.18247.amd64fre.win7sp1_gdr.130828-1532
    Machine Name:
    Kernel base = 0xfffff800`02a4a000 PsLoadedModuleList = 0xfffff800`02c8d6d0
    Debug session time: Sun Apr 13 16:02:36.193 2014 (UTC - 4:00)
    System Uptime: 0 days 0:15:02.025
    Loading Kernel Symbols
    ...............................................................
    ................................................................
    ................................
    Loading User Symbols
    Loading unloaded module list
    .............
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    Use !analyze -v to get detailed debugging information.
    
    BugCheck F4, {3, fffffa80096c0b30, fffffa80096c0e10, fffff80002dc47b0}
    
    ----- ETW minidump data unavailable-----
    Probably caused by : wininit.exe
    
    Followup: MachineOwner
    ---------
    
    2: kd> !analyze -v
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    CRITICAL_OBJECT_TERMINATION (f4)
    A process or thread crucial to system operation has unexpectedly exited or been
    terminated.
    Several processes and threads are necessary for the operation of the
    system; when they are terminated (for any reason), the system can no
    longer function.
    Arguments:
    Arg1: 0000000000000003, Process
    Arg2: fffffa80096c0b30, Terminating object
    Arg3: fffffa80096c0e10, Process image file name
    Arg4: fffff80002dc47b0, Explanatory message (ascii)
    
    Debugging Details:
    ------------------
    
    ----- ETW minidump data unavailable-----
    
    PROCESS_OBJECT: fffffa80096c0b30
    
    IMAGE_NAME:  wininit.exe
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  0
    
    MODULE_NAME: wininit
    
    FAULTING_MODULE: 0000000000000000 
    
    PROCESS_NAME:  wininit.exe
    
    EXCEPTION_CODE: (NTSTATUS) 0xc0000006 - The instruction at 0x%p referenced memory at 0x%p. The required data was not placed into memory because of an I/O error status of 0x%x.
    
    BUGCHECK_STR:  0xF4_IOERR
    
    CUSTOMER_CRASH_COUNT:  1
    
    DEFAULT_BUCKET_ID:  WIN7_DRIVER_FAULT
    
    CURRENT_IRQL:  0
    
    ANALYSIS_VERSION: 6.3.9600.17029 (debuggers(dbg).140219-1702) amd64fre
    
    STACK_TEXT:  
    fffff880`083e2e38 fffff800`02e4dab2 : 00000000`000000f4 00000000`00000003 fffffa80`096c0b30 fffffa80`096c0e10 : nt!KeBugCheckEx
    fffff880`083e2e40 fffff800`02df8abb : ffffffff`ffffffff fffffa80`09bf99b0 fffffa80`096c0b30 fffff800`02d77d64 : nt!PspCatchCriticalBreak+0x92
    fffff880`083e2e80 fffff800`02d78674 : ffffffff`ffffffff 00000000`00000001 fffffa80`096c0b30 00000000`00000008 : nt! ?? ::NNGAKEGL::`string'+0x17486
    fffff880`083e2ed0 fffff800`02abee53 : fffffa80`096c0b30 fffff800`c0000006 fffffa80`09bf99b0 00000000`80010001 : nt!NtTerminateProcess+0xf4
    fffff880`083e2f50 fffff800`02abb410 : fffff800`02b0a82f fffff880`083e3a38 fffff880`083e3790 fffff880`083e3ae0 : nt!KiSystemServiceCopyEnd+0x13
    fffff880`083e30e8 fffff800`02b0a82f : fffff880`083e3a38 fffff880`083e3790 fffff880`083e3ae0 00000000`ff37b698 : nt!KiServiceLinkage
    fffff880`083e30f0 fffff800`02abf242 : fffff880`083e3a38 00000000`02950000 fffff880`083e3ae0 00000000`ff37fa20 : nt! ?? ::FNODOBFM::`string'+0x488e4
    fffff880`083e3900 fffff800`02abddba : 00000000`00000000 00000000`ff371dfc 00000000`77a11201 00000000`02950000 : nt!KiExceptionDispatch+0xc2
    fffff880`083e3ae0 00000000`779d8f75 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiPageFault+0x23a
    00000000`028d1420 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x779d8f75
    
    
    STACK_COMMAND:  kb
    
    FOLLOWUP_NAME:  MachineOwner
    
    IMAGE_VERSION:  
    
    FAILURE_BUCKET_ID:  X64_0xF4_IOERR_IMAGE_wininit.exe
    
    BUCKET_ID:  X64_0xF4_IOERR_IMAGE_wininit.exe
    
    ANALYSIS_SOURCE:  KM
    
    FAILURE_ID_HASH_STRING:  km:x64_0xf4_ioerr_image_wininit.exe
    
    FAILURE_ID_HASH:  {7e8d25f6-54c6-2456-f4df-269f2fd35200}
    
    Followup: MachineOwner
    ---------
    
    


    Wanikiya and Dyami--Team Zigzag

    Sunday, April 13, 2014 8:32 PM
  • Attempting to use the event viewer utility is causing a crash. http://rapidshare.com/share/BBDF93121B3FE3ACD5A00BB4BA1CB68B
    Monday, April 14, 2014 12:32 AM
  • Z

    The link is bad


    Wanikiya and Dyami--Team Zigzag

    Monday, April 14, 2014 12:36 AM
  • http://rapidshare.com/share/68279F610231E5914BC9C9BD06D8E9E2 Try this one
    Monday, April 14, 2014 12:46 AM
  • Zerix


    ERROR_CODE: (NTSTATUS) 0xc000009d - STATUS_DEVICE_NOT_CONNECTED

    DISK_HARDWARE_ERROR: There was error with disk hardware

    BUGCHECK_STR:  0x7a_c000009d


    Wanikiya and Dyami--Team Zigzag

    Monday, April 14, 2014 12:59 AM
  • So is that just an error with the HD?  Is there anything to fix it or is it going to have a be replaced? And when running the disk check on the OS drive it replaced a few bad clusters in a couple files.
    • Edited by zerix807 Monday, April 14, 2014 1:16 AM
    Monday, April 14, 2014 1:13 AM
  • Z

    I would get the disk checking utility from the HD mfr and run it.  It will give you a better idea


    Wanikiya and Dyami--Team Zigzag

    Monday, April 14, 2014 1:23 AM
  • It's a Seagate HD and is crashing when I try to install Seatools.  CrystalDiskInfo gave me some warnings for Current Pending Sector Count and Uncorrectable Sector Count.

    Monday, April 14, 2014 2:06 AM
  • Have you tried booting into safe mode (F8) and installing it there.  You can also get a version of the tool that can run from a bootable USB.

    It is pretty obvious the HD is in trouble.  If you have your data backed up it might just be worth moving on.


    Wanikiya and Dyami--Team Zigzag

    • Marked as answer by ZigZag3143x Monday, April 14, 2014 2:44 AM
    Monday, April 14, 2014 2:26 AM
  • I've got my data backed up, so I think I'm just going to go with that.  Thanks for all your time today.
    Monday, April 14, 2014 2:40 AM
  • Z

    Smart move and thanks for letting us know.  Sorry we couldnt fix it, but hey HD's are cheap


    Wanikiya and Dyami--Team Zigzag

    Monday, April 14, 2014 2:44 AM