locked
SIP CANCEL Requests RRS feed

  • Question

  • I have run into a small issue.  When I call some numbers the call does not connect.  I call them form my cell and all is fine.  I open a ticket with my SIP Trunk provider to have a look and they found that the Lync is sending them a CANCEL request after only 6 seconds but it took 6.5 secinds for them to receive the response form the next hop on the PSTN route.  From the email they sent me it sounds like this is a standard value and they suggested I change the CANCEL request time out to 10 seconds, can anyone let me know how I can change that?

    Monday, January 2, 2012 6:32 PM

All replies

  • Hi,JackeDaniels,

    So you use the direct SIP,right? 

    Would you please change the value RTCPActiveCalls & RTCPCallsOnHold to false using Set-CsTrunkConfiguration and see if that makes any difference?

    http://technet.microsoft.com/en-us/library/gg398238.aspx

    Note:disabling the checks for received RTCP media for active calls in Lync Server elements removes an important safeguard for detecting a dropped peer and should be done only if necessary.

    Also please provide more information about this issue,such as the relevant error message in the event viewer and your trunk and voice route configuration.

    Regards


    Sharon Shen

    TechNet Community Support

    ******************************************************************************************************************************************************* Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community memb
    • Proposed as answer by Sharon.Shen Thursday, January 12, 2012 7:00 AM
    • Marked as answer by Sharon.Shen Tuesday, January 17, 2012 8:08 AM
    • Unmarked as answer by JackeDaniels Tuesday, January 24, 2012 4:31 PM
    • Unproposed as answer by JackeDaniels Tuesday, January 24, 2012 4:31 PM
    Wednesday, January 4, 2012 6:48 AM
  • Changing the RTCPActiveCalls and RTCPCallsOnHold did not correct the problem.

    To clarify the issue using better terminology, Lync is sending a SIP CANCEL request after 6 seconds to my SIP Trunk provider.  My SIP Trunk Provider is getting the 180 Ring Back Response to connect the call after 6.5 seconds.  Therefore, the call is dropping.  I am also seeing similar issues with sending some numbers thorugh a Tenor DX2024.

    The question is, Is there a way to change how long Lync waits for a 180 Ring Back response.

    Event Logs from Front End

    First Event (Event ID 46046, Task 1038)

    A call to a PSTN number failed due to non availability of gateways.

    Called Number: +18774954302

    Phone Usage: MH Standard Usage

    Route: W14PSTNRoute

    CallId: 5663722294cee588d29041eb147ff537

    Cause: All gateways available for this call are marked as down.

    Resolution:

    Verify that these gateways are up and can respond to calls.

    Second Event (Event ID 4009, task ID 1038)

    No events on teh mediation server

     

    Diagnostic Header Info form Monitoring Server

    Reported by Client

    12000; reason="Routes available for this request but no available gateway at this point"; source="TDC52.mh.local"; appName="OutboundRouting"; OriginalPresenceState="0"; CurrentPresenceState="0"; MeInsideUser="Yes"; ConversationInitiatedBy="0"; SourceNetwork="0"; RemotePartyCanDoIM="No"
     
    Reported by Server
    12000; reason="Routes available for this request but no available gateway at this point"; source="TDC52.mh.local"; appName="OutboundRouting"
    Tuesday, January 24, 2012 4:28 PM
  • Hi,

    I have the same issue with my SIP provider (Level3). Did you get anywhere with this ?

    Thanks,
    Alex.

    Monday, January 30, 2012 3:28 PM
  • Hi,JackeDaniels,

    Sorry for responsing so late due to a long holiday.

    Did you also set the parameter EnableSessionTimer to false with Set-CsTrunkConfiguration.

    EnableSessionTimer specifies whether the session timer is enabled. Session timers are used to determine whether a particular session is still active.

    Note: Even if this parameter is set to False, session timers can be applicable if the remote connection has session timer enabled. In such a case, the Mediation Server will reply to session timer probes from the remote entity.

    Regards,

    Sharon

     


    Sharon Shen

    TechNet Community Support

    ******************************************************************************************************************************************************* Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community memb
    Thursday, February 2, 2012 9:12 AM
  • Hi,

    We have this issue mainly with mobile devices where it is taking the carrier a while to connect to the device. As you can see from the following SIP trace we try can call a mobile device and after 9 seconds Lync gives up sending a cancel.

    No.     Time        Source                       Destination           Protocol    Info
          1 6.984481    [Mediation Server]       [SIP Partner Gateway]        SIP/SDP  Request: INVITE sip:+447---------@[SIP Partner Gateway];user=phone, with session description

    No.     Time        Source                       Destination           Protocol    Info
          2 7.004197    [SIP Partner Gateway]    [Mediation Server]           SIP      Status: 100 Trying

    No.     Time        Source                       Destination           Protocol    Info
          3 7.206331    [Mediation Server]       [SIP Partner Gateway]        TCP      63608 > sip [ACK] Seq=996 Ack=331 Win=65280 Len=0

    No.     Time        Source                       Destination           Protocol    Info
          4 16.445766   [Mediation Server]       [SIP Partner Gateway]        SIP      Request: CANCEL sip:+447---------@[SIP Partner Gateway];user=phone

    No.     Time        Source                       Destination           Protocol    Info
          5 16.464165   [SIP Partner Gateway]    [Mediation Server]           SIP      Status: 200 OK

    No.     Time        Source                       Destination           Protocol    Info
          6 16.658881   [Mediation Server]       [SIP Partner Gateway]        TCP      63608 > sip [ACK] Seq=1512 Ack=687 Win=64768 Len=0

    No.     Time        Source                       Destination           Protocol    Info
          7 16.675547   [SIP Partner Gateway]    [Mediation Server]           SIP      Status: 487 Request Terminated


    Our Trunk Configuration is as follows :

    Identity                            : Global
    OutboundTranslationRulesList        : {}
    SipResponseCodeTranslationRulesList : {}
    Description                         :
    ConcentratedTopology                : True
    EnableBypass                        : False
    EnableMobileTrunkSupport            : False
    EnableReferSupport                  : False
    EnableSessionTimer                  : False
    EnableSignalBoost                   : False
    MaxEarlyDialogs                     : 20
    RemovePlusFromUri                   : False
    RTCPActiveCalls                     : False
    RTCPCallsOnHold                     : False
    SRTPMode                            : NotSupported
    EnablePIDFLOSupport                 : False

    Thursday, February 2, 2012 9:34 AM
  • Setting EnableSessionTimer to false does not help.  My trunk configurtation is the same as Alex_Harvey in the previous post
    Tuesday, February 7, 2012 2:29 PM
  • Hi,

    I published a solution on my blog: http://ipfone.hu/lync-mediation-server-cancel-problem/

    Attila


    If you find my comment helpful or downright solved your problem, mark it as helpful or propose as answer. Thanks.

    • Proposed as answer by Gerry_Penrose Monday, February 20, 2012 6:31 PM
    Sunday, February 19, 2012 9:04 PM
  • Hi,

    I published a solution on my blog: http://ipfone.hu/lync-mediation-server-cancel-problem/

    Attila


    If you find my comment helpful or downright solved your problem, mark it as helpful or propose as answer. Thanks.

    Many, many thanks for this Attila.

    Have been seeing this issue on a site (integrating with an Avaya) for a couple of weeks and just couldn't find where to change it.  Made the config change this evening so hopefully tomorrow will be a much better day (fingers crossed!!).

    You don't know of any documentation around the values which can be set in the .CONFIG files in that folders such as MinGwWaitingTime, FailuresForGatewayDown, etc?  I can't find anything on them in any Microsoft documentation or Lync 2010 books.

    Cheers again,

    Gerry. 

     
    Monday, February 20, 2012 6:34 PM
  • I have updated my outboundRouting.exe.config file as per the blog post and can confirm all is well. Choose 20000 as the timeout.

    Thanks very much for this solution.

    Alex.

    Tuesday, February 21, 2012 8:52 AM
  • In our case we use Level 3 for our PSTN connection. I contacted Microsoft Support since CU4 updates caused this, and they said that Attila_HUN's workaround IS supported. However, they said that on the PSTN Gateway there should also be a Session Timer setting that should allow you to adjust the time it waits for a response. I have not confirmed this yet with the engineer that supports the gateway.

    Microsoft also said that Level 3 should be able to adjust the response time of the Session Progress and for us to contact them to ask.

    Either way, Microsoft should have published an article on the CU4 update page, but they haven't. So if you apply CU4 updates you may experience this issue. Microsoft says that CU5 updates "should" correct this issue. (Thanks for the info).

    • Proposed as answer by Jeffy-g Friday, February 24, 2012 7:21 PM
    Friday, February 24, 2012 7:19 PM