none
Coreinfo 3.50 RRS feed

  • Question

  • Windows 10 Pro 32-bit on 64-bit hardware - wanting to run coreinfo.exe (in admin mode)

    Not able to run coreinfo.exe - keeps showing me the error:

    C:\Dave's Folder\Temp>coreinfo
    Unsupported processor type: 0
    Unable to extract x64 image. Run Coreinfo from a writeable directory.

    Tried it with -c and -v switches from both this folder and from C:\

    Processor is - from CPU-Z:

    Name         Intel Pentium
    Codename         Merom
    Specification Genuine Intel(R) CPU           T1600  @ 1.66GHz
    Package (platform ID) Socket P (478) (0x7)
    CPUID 6.F.D
    Extended CPUID 6.F
    Core Stepping M0
    Technology 65 nm
    Core Speed 1662.3 MHz

    Laptop: Dell Inspiron 1545 4GB RAM

    What am I doing wrong?

    Friday, September 18, 2020 8:56 AM

All replies

  • Generally you need to run coreinfo from an elevated command prompt. 

    it exists in two flavour x86 and x64. Coreinfo.exe and Coreinfo64.exe.

    So, no need to run coreinfo on a 64 bit machine..

    Eventually, download the 64 bit versin from live.sysinternals.com - /

    HTH
    _mario

    Friday, September 18, 2020 12:11 PM
  • Thanks, but as noted in my question (top line), I've tried running it in admin mode - I guess that equates to "elevated". And it gives the error message.

    The more I look into the processor type (given its age, etc.) it probably shouldn't even be running Windows 10 of any flavour, let alone ver.2004 (which it current is - slowly, but it runs ok for what I use it for). But it would have been nice to run the 64-bit version (and for which I would need to add a bit more memory as well - currently with 4GB of which only 3.5GB is recognised [being a 32-bit OS]).

    I was wanting to see if this processor was able to handle the PAE, NX, SSE2, CX16 processor features. Hence the need to run coreinfo.exe.

    Friday, September 18, 2020 1:18 PM
  • I no longer have any 32 bit OS to test.. so I would stick to the first message:

    coreinfo
    Unsupported processor type: 0

    It may very well unsupported and so won't run in any case.. If you are local administrator ti should work.. as a last chance I would try running it as local System using psexec.
    From an elevated Command prompt run:

    psexec -i -s cmd.exe

    then execute coreinfo in that CMD.

    HTH
    -mario

    Friday, September 18, 2020 2:52 PM
  • Ran the psexec command with just the same error message.

    Given it up as a bad job - processor probably far tooooooo old for the job.

    Thanks for the help, shame it didn't work for me.

    Friday, September 18, 2020 6:50 PM