none
Access is Denied when trying to set a WDS Client Unattend file RRS feed

  • Question

  • Hello,

    I'm having a problem setting WDS to use an unattend.xml file for the WDS client.  I'm pretty sure that there must be some little setting that is incorrect, but I've been poring over the documentation and Google and Bing and I haven't been able to find the cause.

    I downloaded the latest version of WDS and installed it on one of our Win2k3 R2 (SP2) domain controllers.  So far everything has worked really well.  PXE boot is awesome and it is great to be able to grab images off of the server.  So I thought that I would try working with unattended installations.  I originally made up one unattend.xml file with settings for WinPE and the rest of the configuration passes.  I was able to associate that file with the image that I wanted it to go with.  Then, I tried to set the WDS Client Autounattend file.  From the WDS MMC, I right-clicked on my WDS server and selected Properties.  On the Properties window, I selected the Client tab.  I checked the box for "Enable unattended installation" and browsed for my unattend.xml file to load it into the slot for the x64 architecture.  I also checked the option to not create an account in the domain after running WDS Client.  When I hit Apply, I get an error message saying Access is Denied. 

    I have tried every permutation that I can think of.  I have tried creating an unattend.xml file with just settings for the WinPE pass, I have tried putting a value in for each of the architecture types, and I have tried using WDSUTIL, but every time I get the Access is Denied message.  Does anybody know what I might be doing wrong?

    Thanks in advance for any help that you can give,
    John
    Wednesday, January 20, 2010 7:30 PM

Answers

  • Hi John,

     

    Did you log on an account with local administrator privileges?

     

    Or you can set the unattend file for x64 architecture by modifying registry directly:

     

    1.    Click Start, type regedit and press Enter.

     

    2.    Locate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WDSServer\Providers\WdsImgSrv\Unattend\x64.

     

    3.    Right-click FilePath and type the path your unattend file, for example: WdsClientUnattend\WdsUnattend.xml

     

    For detailed information, please refer to the following article:

     

    http://technet.microsoft.com/en-us/library/cc754005(WS.10).aspx#Perf1

     

    Hope it helps.

     

    Tim Quan - MSFT

     

    • Marked as answer by greyseal96 Saturday, January 23, 2010 1:45 AM
    Thursday, January 21, 2010 3:41 AM
    Moderator

All replies

  • Hi John,

     

    Did you log on an account with local administrator privileges?

     

    Or you can set the unattend file for x64 architecture by modifying registry directly:

     

    1.    Click Start, type regedit and press Enter.

     

    2.    Locate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WDSServer\Providers\WdsImgSrv\Unattend\x64.

     

    3.    Right-click FilePath and type the path your unattend file, for example: WdsClientUnattend\WdsUnattend.xml

     

    For detailed information, please refer to the following article:

     

    http://technet.microsoft.com/en-us/library/cc754005(WS.10).aspx#Perf1

     

    Hope it helps.

     

    Tim Quan - MSFT

     

    • Marked as answer by greyseal96 Saturday, January 23, 2010 1:45 AM
    Thursday, January 21, 2010 3:41 AM
    Moderator
  • Tim,

    Thank you very much for taking a look at my question and answering.

    I am logged on as the built-in domain administrator account.  Since the computer on which I am running WDS is a domain controller, I cannot look to see look at the local administrators group.  However, I'm pretty sure that the domain administrator ought to have enough privileges, right?  I read through the article that you linked to and I verified that the domain administrator's account has full control on all of the file system locations listed and I verified that the domain administrator has full control permissions on the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet and all of its subkeys, including the WDSServer sub-key.  I'm really confused as to what is causing the access is denied error because, from all that I've seen, I should have access to everything.  Do you have any ideas?

    I've also noticed that when I restart the WDS service from the MMC that it takes a long time to restart.  Do you think that that could have anything to do with it?  I've noticed that sometimes when I have these strange errors that it turns out to be some obscure permissions setting in DCOM or even the .NET Framework's security settings.  Are there any log files which I could look at to help me to diagnose where the problem might be occurring?

    In any event, I went straight to the registry keys that you mentioned.  I set the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WDSServer\Providers\WdsImgSrv\Unattend key's enabled value to be 1 to enable Unattended Installations.  I also saw a value named CommandLineUnattendPreference.  Do you know what that does?  I left its value at 0 and didn't change it.  I then went to the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WDSServer\Providers\WdsImgSrv\Unattend\x64 key and changed its FilePath value to be WdsClientUnattend\x64Unattend.xml, which is the path to the file on my system.  I restarted the WDS service (just in case) and I attempted another installation.  The first time that I tried it, it failed but the second time that I tried it, it worked.  I'm not sure why that is, but I'm happy that it worked.  I'm going to try it a few more times because there were some other bugs that I have to work out with my unattend file.  At least the workaround worked, though!

    If you, or anybody else, has any ideas or suggestions on how to get this to work correctly, I'd be very appreciative of the help.  I'd like to be able to figure out the root cause so that I don't have to go to the registry every time I need to change a setting.  :)  Thanks for all of your help.  This was a major roadblock and it's really nice to be able to proceed forward.

    Thank you,
    John
    Thursday, January 21, 2010 6:19 PM
  • Hi John,

     

    Thank you for the reply.

     

    The “Access is denied” error usually indicates lacking of enough permission.

     

    Please make your account has full permission on the RemoteInstall folder and the WdsClientUnattend\WdsUnattend.xml file.

     

    If the issue persists, I suggest un-initializing and reinitializing WDS by running the following commands:

     

    wdsutil /uninitialize-server

    wdsutil /initialize-server /reminst:D:\REMOTEINSTALL

     

    Note: D is the drive which you would like to put the REMOTEINSTALL folder on.

     

    Re-add your unattend file to the WdsClientUnattend folder and test the result again.

     

    Hope it helps.

     

    Tim Quan - MSFT

     

    Friday, January 22, 2010 3:35 AM
    Moderator
  • Hi Tim,

    I tried the uninitialize and initialize of the server and that still didn't help.  However, I am able to move ahead with the fixes that you have suggested, so I'm going to go ahead and document the fix and mark this as resolved.  Thank you so much for your help.

    Regards,
    John
    Saturday, January 23, 2010 1:45 AM