locked
Approach for installing word templates into virtual office 2010 RRS feed

  • Question

  • Hi All,

    I'm virtualizing office 2010 proplus 32bit with the package accelerator from MS. Target OS is windows 7 32bit. I need to include some template files. The templates are installed with an MSI. The MSI appears to locate winword.exe and install to the correct path. I've had issues trying to get this to work with my virtual office. I have tried the following:

    Opened my package for an update in the sequencer. I ran the MSI. The files appear to install to C:\Program Files\Microsoft Office. I get a message from the sequencer that the files have been excluded. I followed the instructions in the help to remove the path from the exclusion list and add the files into the package with the VFS tab when I edit the package. I saved the package and deployed it but it the templates did not appear.

    Next I tried to copy the files I needed manually into the relevant folders in Q:\Microsoft Office 2010. In the prepare for streaming section I when to file -> options -> Add-Ins, changed the "Manage" drop down to "Word Add-ins" and clicked the "Go" button. I click add, browsed to the template file I just copied in, selected it and clicked ok. The "Add-Ins" tab appeared at the top of the ribbon and a message about enabling the macro. I click enable content. The Add-Ins were there so I saved the package.

    When I deployed the package the "Add-ins" tab was not on the ribbon. If I go into  file -> options -> Add-Ins, changed the "Manage" drop down to "Word Add-ins" and clicked the "Go" button. The template file is appearing there but its checkbox is not selected for some reason. I check it and click ok. The Add-In's tab appears on the ribbon. When I try to use one of the templates I get an error

    Microsoft Visual Basic

    Run-time error '5174':

    This file could not be found.

    I'm thinking the template file needs to be updated maybe it has some paths hardcoded. I was wondering if anyone has deployed templates (physical or virtual) to virtual office using the DSC tool ? What method did you use to create/deploy the templates ?

    Regards,
    Jack

    Thursday, October 6, 2011 1:28 PM

Answers

  • Hello,

    I would try to perform the steps the MSI performs manually.

    To better understand how it works in a virtual environment - you could use process monitor would should show you where it tries to locate files
    /Znack
    • Marked as answer by JackORegan Friday, November 11, 2011 2:02 PM
    Thursday, October 6, 2011 1:35 PM

All replies

  • Hello,

    I would try to perform the steps the MSI performs manually.

    To better understand how it works in a virtual environment - you could use process monitor would should show you where it tries to locate files
    /Znack
    • Marked as answer by JackORegan Friday, November 11, 2011 2:02 PM
    Thursday, October 6, 2011 1:35 PM
  • Also see this KB article:

    How to manage templates in 2007 Office programs and in 2010 Office programs: http://support.microsoft.com/kb/924460

    Find out where the MSI is installing the template files and add them manually, as Znack says. Alternatively, configure workgroup templates to a location outside of the package and add them manually to that location.



    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    • Proposed as answer by znack Friday, October 7, 2011 7:46 AM
    Thursday, October 6, 2011 1:45 PM
    Moderator
  • Followed the steps manually. The templates were not loading on word load, the user still had to go in and select them. I found that this was because they previous had a trusted path set by group policy. This was replicated in the 2010 GPO's. Thanks for all the help guys.
    Friday, November 11, 2011 2:04 PM