locked
error of new-pssession -authenticate CredSSP RRS feed

  • Question

  • I ran the following lines on both the client and server.

    Enable-WSManCredSSP -Role client -DelegateComputer *
    Enable-WSManCredSSP -Role server

    Then the "new-pssession -authenticate CredSSP ..." command always returned:

    "New-PSSession : [serverB] Connecting to remote server serverB failed with the following error message : There are currently no logon servers available to service the logon request."

    Later I ran this command on the server side:

    winrm quickconfig -transport:https -force

    Then the "new-pssession -authenticate CredSSP ..." command always returned:

    [serverB] Connecting to remote server serverB failed with the following error message : The WinRM client received an HTTP server error status (500), but the remote service did not include any other information about the cause of the failure.

    I tried all kind of settings on both of the client and server but no any success. The PowerShell is V3. The client machine is a Windows 7 and the server machines I tried are Windows 2008 R2 and Windows 8 RP. All machines are in the same domain.

    What else I can do? Thanks for any advice.


    • Edited by Shangwu Wednesday, August 22, 2012 7:57 PM Correction
    Wednesday, August 22, 2012 7:12 PM

Answers

All replies

  • Hi,

    Check out in Server Manager if "WinRM
    IIS Extensions" are installed. If not install it. If it
    is already there :

    1. Uninstall it and Install it again.

    2. Run "WinRM Quickconfig".

    Regards,

    Yan Li


    Yan Li

    TechNet Community Support


    • Edited by Yan Li_ Monday, August 27, 2012 5:52 AM
    Monday, August 27, 2012 5:51 AM
  • I don't think "WinRM IIS Extensions" will resolve the problem. This is not the case of fan-in remoting when PowerShell is hosted in IIS. There are few things in the original post that are not clear. Why do you set both, server and client, CredSSP roles on both sides. That's not needed. Running winrm quickconfig -transport:https -force is not enough to establish remote session using SSL (SSL is not needed if both computers are in the same domain and you use computer names). Have you tried Enable-PSRemoting instead of winrm quickconfig?


    Aleksandar Nikolić http://powershellers.blogspot.com http://twitter.com/alexandair

    Monday, August 27, 2012 7:53 AM
  • Thanks for your responses. Both client and server computers are in the same domain. If I specify -Auth Kerbros, the PSsession will be created without problem. I tried all kind of settings I can find if it is related in order to resolve the error.

    One possible cause of the problem may be that the domain has trusted another domain. The system admin is fixing the DNS replication issue.

    Is there any WINRM troubleshooting procedure for CREDSSP issue?

     
    Monday, August 27, 2012 2:24 PM
  • Hi,

    I would like suggest you refer to below links for more details:

    Enable-PSRemoting –force

    http://social.technet.microsoft.com/Forums/en-US/winserverpowershell/thread/968a5cdb-f383-4f07-9249-6585192aa144/

    Multi-Hop Support in WinRM

    http://msdn.microsoft.com/en-us/library/windows/desktop/ee309365(v=vs.85).aspx

    WinRM(Windows Remote Management) Troubleshooting

    http://blogs.technet.com/b/jonjor/archive/2009/01/09/winrm-windows-remote-management-troubleshooting.aspx

    Regards,

    Yan Li



    Yan Li

    TechNet Community Support


    • Edited by Yan Li_ Tuesday, August 28, 2012 4:53 AM
    • Proposed as answer by Livio von Büren Tuesday, August 28, 2012 6:47 AM
    • Marked as answer by Yan Li_ Monday, September 3, 2012 2:12 AM
    Tuesday, August 28, 2012 4:53 AM