none
the name cannot be resolved the connection to microsoft exchange is unavailable

    Question

  • Client:

    Windows 7 Pro. (64 bit)

    Outlook 2010

    Server:

    Windows Server 2003 SBS (w/Exchange Server 2003)

    Everything has been working fine for literally years with this server setup and even for months with Outlook 2010 connecting to Exchange 2003. But, just yesterday, I started getting certificate errors during the Send/Recieve talking about connecting to the autodisover.domain service.  After backing up the mailbox, I removed it from Outlook 2010 and attempted to re-create it.  When I try this I get the error in the subject line, even though the user is in AD and can log into the domain successfully.

    To make matters more interesting, I can still connect and get mail from an Outlook 2007 client on a different box, so I know the account is fine on the server and that must be a client issue.

    I've seen many articles talking about Exchange 2007, but I'm not using that.

    HELP!

    Friday, August 06, 2010 12:01 AM

All replies

  • What is the full exact text of the error messages and under what
    circumstances do you get the messages.
     
    --
    Ed Crowley MVP
    "There are seldom good technological solutions to behavioral
    problems."
    ..
     
     
    On Fri, 6 Aug 2010 00:01:10 +0000, Scott M. _ wrote:
     
    >
    >
    >Client:
    >
    >Windows 7 Pro. (64 bit)
    >
    >Outlook 2010
    >
    >Server:
    >
    >Windows Server 2003 SBS (w/Exchange Server 2003)
    >
    >Everything has been working fine for literally years with this server setup and even for months with Outlook 2010 connecting to Exchange 2003. But, just yesterday, I started getting certificate errors during the Send/Recieve talking about connecting to the autodisover.domain service. After backing up the mailbox, I removed it from Outlook 2010 and attempted to re-create it. When I try this I get the error in the subject line, even though the user is in AD and can log into the domain successfully.
    >
    >To make matters more interesting, I can still connect and get mail from an Outlook 2007 client on a different box, so I know the account is fine on the server and that must be a client issue.
    >
    >I've seen many articles talking about Exchange 2007, but I'm not using that.
    >
    >HELP!
     

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Friday, August 06, 2010 2:54 AM
  • Hi Ed,

    There are several different errors that come up depending on exactly how I try to retrieve messages.

    At first, I was getting a warning dialog, saying that autodiscover.domain.com found a problem with the certificate:

    "There is a problem with the proxy server's security certificate.

    The name on the security certificate is invalid or does not match the name of the target site <domain URL".

    I removed that outlook data file and tried to create a new one and when I enter the exchange information and hit the "Check Name" button, I get "Your server or mailbox names cannot be resolved."

    Again, other Outlook clients (Outlook 2007) are able to connect and retrieve mail from the same server and the same account and, Outlook 2010 was doing it fine for several months, until yesterday.  This is a small network that I exclusively maintain - - no account changes or server settings have been modified.

    Another test involved removing the only mail profile for this machine and starting completely from scratch.  When the "Add new account" dialog appears (upon starting outlook 2010) the name and email address field, which have always automatically populated themselves, do not automatically populate.  When I try to populate them myself Outlook cannot connect to Exchange and responds with the message I mentioned earlier.

    Scott

    Friday, August 06, 2010 4:42 AM
  • Which certificate are you using? self-signed? check if it has expired.
    Yanir Ben-Nun / System Team Leader / IT / IS Professional
    Friday, August 06, 2010 10:22 AM
  • It is self-signed and hasn't expired.  As I said, I can access this account/mailbox from other clients with no problem.  In addition, I can get to OWA from the machine that can't get to the mailbox via the Outlook 2010 client.

    -Scott

    Friday, August 06, 2010 12:35 PM
  • Do you have outlook anywhere enabled ?

    Friday, August 06, 2010 2:25 PM
  • I'm not sure what you mean by this.  The Oulook 2010 client is NOT in off-line mode, if that's what you mean.

    -Scott

    Friday, August 06, 2010 4:33 PM
  • Could it be that the user is configured to be hidden from the address list ?

    If you go to properties for the ad user and select the "exchange advanced" tab, is "hide from exchange address lists" checked ?

    Sunday, August 08, 2010 8:51 PM
  • Hi,

    Did you create the profile for others user account on this special computer? Is it fine?

    Thanks

    Allen

    Tuesday, August 10, 2010 8:42 AM
  • I really don't understand what you are asking.
    Tuesday, August 17, 2010 1:46 PM
  • There is nothing wrong/special about the user account.  As I've said, I can connect and access mail (under this account) fine on any other client and, in fact, can do it from this particular machine via OWA.  The problem isn't with the account as it is with Outlook being able to connect to Exchange on this particular machine, which is the only one that has Outlook 2010 on it.
    Tuesday, August 17, 2010 1:48 PM
  • Is your Exchange updated to the latest SP and updates?
    Yanir Ben-Nun / System Team Leader / IT / IS Professional
    Wednesday, August 18, 2010 12:52 PM
  • Yes.  As I've said many times now, this is only happening on one client and mail is working properly everywhere else.  The client is the only one using Outlook 2010.
    Saturday, August 28, 2010 9:14 PM
  • Have you tried Office 2010 on any other computer in your network.
    Sunday, August 29, 2010 9:13 AM
  • No.  Clearly the problem is with Office 2010 and I'm not going to risk the same problem on other machines until I can correct it on this one first.
    Thursday, October 07, 2010 9:12 PM