none
WDS PXE Deployed Images With Driver Nightmares RRS feed

  • Question

  • Hi everyone, this project has been irritating my coworker and I for a while now, so I hope somebody here can help out.

    We set up a WDS server (virtual machine) so we can perform PXE boot image deploys to physical devices (laptops, desktops) but we cannot figure out the issues with the drivers. We can PXE boot machines just fine (except Surface Pro 4s, but that's a whole other question) and the image deploys, but when we log in to the machine, it is missing drivers. To handle the drivers issue, we added driver packages to our WDS server by right-clicking on the "Drivers" folder and going through the "Add Driver Package..." process. We pointed it to a recovery disk containing the drivers for the particular model machine we are hoping to add (however, sometimes the process fails on adding a couple of drivers, so we move on without including those few--it doesn't really give any option otherwise). 

    So this is what we thought was going to work. We deployed our images thinking that the drivers would be included in a Plug-n-Play style with whatever ones were needed, since we didn't include any filters on the driver groups. However, the drivers didn't seem to get installed on the target machines at all. So, our next attempt was to add drivers to the boot image itself. This initially solved an issue we were having where a laptop couldn't boot to pxe at all because of a missing driver, so we figured this way would probably work as well. However, the issue was not resolved with adding the drivers to the boot image. By this time I was getting suspicious that we had too many/conflicting drivers on a single boot image, so I duplicated our original boot image (just added it to WDS again) and created individual boot images for our various model machines and added the respective driver packages. However, this did not solve the issue. 

    Whenever we try to plug in a USB device to an image that has been pxe-deployed, we get a blue screen with an irql_not_less_or_equal error. This is why I thought it might be some conflicting driver issues and hence the separating of the boot images, but we still get this error. And when we check under Device Manager, there are several missing drivers when compared to a non-pxe-deployed machine of the same model. We've tried so many different things and have not found any information to help us out with this, so we would really appreciate some help with this. Thanks.

    Also, we are running WDS on Windows Server 2012 Standard and we have been using Windows 7 images captured with sysprep (OOBE and generalize). 

    Wednesday, May 4, 2016 11:04 PM