none
DHCP, DNS and multiple network cards RRS feed

  • Question

  • This request is different than all the others I see. Typically, most people are trying to not have an adapter register in DNS. I am wanting to have each adapter register in DNS with different FQDNs while using DHCP on both adapters. My setup is as follows:

    dc1 running dns, two nics (vlan2:192.168.2.1/24, vlan3:192.168.3.1/24), I don't think dc1 is relevant but I included it as full disclosure

    dc2 running dns and dhcp (two different subnets/scopes, vlan2 scope with gateway:192.168.2.2/24 and vlan3 with gateway:192.168.3.2/24), two nics (vlan2:192.168.2.2/24, vlan3:192.168.3.2/24)

    client server two nics (vlan2, vlan3), setup for DNS thru DHCP on both nics, vlan2 nic DNS properties (register connection DNS selected), vlan3 nic properties (dns suffix = backup.domain.net, register connection DNS selected, use connection DNS suffix selected)

    vlan2 is the production AD network with domain name of domain.COM 

    vlan3 is the backup network with domain name of backup.domain.NET

    The end result of this is that it *almost* works. The client server gets DHCP on vlan2nic:192.168.2.100, DNS record of client.domain.com -> 192.168.2.100, DHCP on vlan3nic:192.168.3.100, DNS record of client.backup.domain.net -> 192.168.3.100 and a third unwanted record of client.domain.com -> 192.168.3.100

    I have tried many, many variations with the DNS settings but can not stop the extra DNS registration from the client, maybe it is a bug?. I believe this to be a DNS issue and not DHCP but enlighten me if I am wrong. Any help or suggestions would be greatly appreciated. Thanks in advance.

    Monday, March 26, 2018 10:10 PM

All replies

  • correction:

    dc2 running dns and dhcp (two different subnets/scopes, vlan2 scope with DNSServer:192.168.2.2/24 and vlan3 with DNSServer:192.168.3.2/24), two nics (vlan2:192.168.2.2/24, vlan3:192.168.3.2/24)

    Tuesday, March 27, 2018 12:59 AM
  • Hi Dimitri,

    Have a nice day! Thanks for your question.

    From your post, if the client server joined in the domain and set DNS properties to Register this connection’s addresses in DNS, it would update its record mapping to NIC IP with the domain suffix. So the client server would register its two NICs addresses pointing to the same record client.domain.com to local DNS server as the following figure.

    Based on your specific situation, you may uncheck the selection “Register this connection’s addresses in DNS” in vlan3 NIC (192.168.3.100) of the client server, and then remove the corresponding record ( the third record) by manual.

    Hope above information helpful. I look forward hearing your good news.

    Highly appreciate your effort and time. If you  have any questions and concerns, please feel free to let me know.

    Best regards, 

    Michael

    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, March 27, 2018 5:56 AM
  • When I remove records from DNS, uncheck "Register this connection’s addresses in DNS” on vlan3, and then do a 'ipconfig /registerdns' on the client server, I no longer have records for client.domain.com -> 192.168.3.100 (which is desired) and client.backup.domain.net -> 192.168.3.100 (which is undesired). I still want vlan3 NIC to register on backup domain.
    Tuesday, March 27, 2018 1:48 PM
  • Hi Dimitri,

    I created a similar environment as yours in my lab and made testing. However, I'm afraid to tell you the record with the domain suffix and the specific suffix would be registered to DNS server when checking "Register this connection's addresses in DNS".

    Moreover, when uncheck "Register this connection's addresses in DNS", "Use this connection's DNS suffix in DNS registration" is also disabled.

    Therefore, only creating the static record by manual into DNS server and uncheck "Register this connection's addresses in DNS" can implement the solution.  

    Hope above information can help you.

    Highly appreciate your successive effort and time. If you have any questions and concerns, please feel free to let me know.

    Wish you have a nice day!

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, March 28, 2018 10:49 AM
  • Hi Dimitri,

    How are things going on? Was your issue resolved?

    Please let us know if you would like further assistance.

    Wish you have a nice day!

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, March 30, 2018 11:46 AM