locked
custom host header IIS - DNS- proxy server RRS feed

  • Question

  • Hello,

    We have created a Web Application with a Site Collection using a custom host header :

    http://sd-sviluppo.it

    in a Windows 2003 server / WSS 3.0.


    If we use a client connecting without travel in our proxy server all work fine else the URL can not be solved.

    Our environment is composed by different server where we have running several services:

    - Windows Server 2008 - Microsoft Forefront (firewall)
    - Windows Server 2008 - MS Exchenge, AD
    - Windows Server 2008 - DNS
    - ...

    we have configured the MS Forefront to allow connection to our farm sharepoint.

    We can't understand what we are missing to configure out to let the custom host header be solved by our proxy.

    Anyone got any suggestion? We havent much experience using custom host header / DNS.


    We have also tried to create another web application without use a custom host header and in this case clients connectioning through proxy can find the web application..

    thanks for any help
    Monday, March 14, 2011 5:47 PM

Answers

  • Thank you for the suggestions.

    The thing I cant understand is that I have already used a custom host name during the creationg of the web application: instead of let sharepoint apply the suggested name for example

    http://nameserver:portnumber

    I have used a custom host header like:

    "http://customWebAppName" on port 80.

    In my specific case I have used: "http://sd-sviluppo.it"

    Then we have modified the file hosts.

    Now like I said, all work fine if we connect to our web application by a client not using our proxy.

    If I go in AAM I already see the correctly URL (default) that I need users use: "http://sd-sviluppo.it"

    In IIS I have configured this:

    • IP Address: noone
    • PORT: 80:
    •  host header: sd-sviluppo.it

    In the DNS server it seems correctly setup, I have added  a new zone using the IP address of our sharepoint server and specified the url linked at that address: "http://sd-sviluppo.it".

    I also added a new voice in our firewall proxy Forefront but the URL cant be solved anyway

     

     

    • Marked as answer by A. Testa Tuesday, July 15, 2014 10:03 AM
    Wednesday, March 16, 2011 8:12 AM

All replies

  • Hi,

    Is the Alternate Access Mappings configured correctly?

    thanks.


    -- techChirag
    Monday, March 14, 2011 10:25 PM
  • We have tried to setup a specific URL for intranet like the default but it doesnt work anyway...

    If we type the IP address all work but we cant assign a host header in client connecting through proxy server

     

    Tuesday, March 15, 2011 1:33 PM
  • Hi,

     

    As techChirag suggest, you should configure in both DNS and Alternate Access Mapping (AAM). You need to add an alternate access mapping in Central Admin so that the SharePoint database knows what that URL is and how to route it. Adding AAM’s allow IIS to get updated accordingly-you typically don’t want to make changes directly to IIS, because then the SharePoint Database doesn’t know about it. You also need to make sure that DNS knows what to do with that new sub-domain. 
    You can try to following the below link to configure your URL which I’ve tested to be correct:
    http://blog.henryong.com/2007/01/17/alternate-access-mapping-in-sharepoint/
     
     
    Best regards
    David Hu

     

    Wednesday, March 16, 2011 2:00 AM
  • Thank you for the suggestions.

    The thing I cant understand is that I have already used a custom host name during the creationg of the web application: instead of let sharepoint apply the suggested name for example

    http://nameserver:portnumber

    I have used a custom host header like:

    "http://customWebAppName" on port 80.

    In my specific case I have used: "http://sd-sviluppo.it"

    Then we have modified the file hosts.

    Now like I said, all work fine if we connect to our web application by a client not using our proxy.

    If I go in AAM I already see the correctly URL (default) that I need users use: "http://sd-sviluppo.it"

    In IIS I have configured this:

    • IP Address: noone
    • PORT: 80:
    •  host header: sd-sviluppo.it

    In the DNS server it seems correctly setup, I have added  a new zone using the IP address of our sharepoint server and specified the url linked at that address: "http://sd-sviluppo.it".

    I also added a new voice in our firewall proxy Forefront but the URL cant be solved anyway

     

     

    • Marked as answer by A. Testa Tuesday, July 15, 2014 10:03 AM
    Wednesday, March 16, 2011 8:12 AM