locked
Error while launching xls file, located inside the app-v bubble. RRS feed

  • Question

  • Hi Experts,

    I have a sequenced app which launches an mde file (microsooft access file) (office is not part of the bubble), the launch works fine, one of the forms of mde file contains a button, which points to an excel file. When we click this button it shows following error:

    After clicking on OK, the excel file launches.

    We can see in procmon that the excel.exe is not able to find the path specified initially, and then it is able to resolve.

    I also tried running EXCEL.exe "V:\oilAndGasReservesDatabase2011V1_01\Reserves Database\ABOilReserves2010.xls" from the cmd.exe which was launched from the bubble. File launches fine wihout any error.

    When I try to Run EXCEL.exe "V:\oilAndGasReservesDatabase2011V1_01\Reserves Database\ABOilReserves2010.xls" from local cmd.exe it throws the same exact error.

    Please guide me towards resolution.

    Thanks in Advance.

    ~Puneet

    Thursday, March 1, 2012 1:18 PM

Answers

  • LOCAL_INTERACTION_ALLOWED won't fix your issue - see this blog post for details on what it does. Excel must be launching outside of the virtual environment, so you'll need to ensure the Excel alway launches inside the virtual environment to see the file.


    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.

    • Proposed as answer by J.Badia Wednesday, March 14, 2012 11:54 AM
    • Marked as answer by Aaron.ParkerModerator Friday, November 16, 2012 10:20 PM
    Thursday, March 1, 2012 2:38 PM
    Moderator

All replies

  • To Add more to it....local interaction is set true.

    WORKINGDIR: %SFT_MNT%\oilAndGasReservesDatabase2011V1_01\Reserves Database. This is the folder which contains the excel files.

    OSD:

    <?xml version="1.0" standalone="no"?>
    <SOFTPKG GUID="E53752C0-9598-4C4A-8A56-AD35E1DE9325" NAME="Reserves Database" VERSION="1.0">
     <IMPLEMENTATION>
      <CODEBASE HREF="RTSP://%SFT_SOFTGRIDSERVER%:554/oilAndGasReservesDatabase2011V1_01/oilAndGasReservesDatabase2011V1_01.sft" GUID="3F78BE8C-BCDF-407E-8DA9-4ACA62BC6784" PARAMETERS="" FILENAME="oilAndGasReservesDatabase2011V1_01\Reserves Database\Reserves.mde" SYSGUARDFILE="oilAndGasReservesDatabase2011V1_01\osguard.cp" SIZE="96173901"/>
      <VIRTUALENV TERMINATECHILDREN="FALSE">
       <POLICIES>
        <LOCAL_INTERACTION_ALLOWED>TRUE</LOCAL_INTERACTION_ALLOWED>
       </POLICIES>
       <ENVLIST/>
      </VIRTUALENV>
      <WORKINGDIR>%SFT_MNT%\oilAndGasReservesDatabase2011V1_01\Reserves Database</WORKINGDIR>
      <VM VALUE="Win32">
       <SUBSYSTEM VALUE="windows"/>
      </VM>
     </IMPLEMENTATION>
     <DEPENDENCY>
      <CLIENTVERSION VERSION="4.6.0.0"/>
     </DEPENDENCY>
     <PACKAGE NAME="oilAndGasReservesDatabase2011V1_01"/>
     <ABSTRACT>Sequenced On : Windows 7 64 bit Image
    Application ID : DVN0130</ABSTRACT>
     <MGMT_SHORTCUTLIST>
      <SHORTCUT LOCATION="%CSIDL_PROGRAMS%\My Software\Oil and Gas Reserves Database" FILENAME="Reserves Database.lnk" OVERRIDDEN="TRUE" DISPLAY="Reserves Database" ICON="%SFT_MIME_SOURCE%/oilAndGasReservesDatabase2011V1_01 Icons/Reserves_Database_1_0_DVN0130.ico"/>
     </MGMT_SHORTCUTLIST>
     <MGMT_FILEASSOCIATIONS>
      <PROGIDLIST/>
      <FILEEXTENSIONLIST/>
     </MGMT_FILEASSOCIATIONS>
    </SOFTPKG>

    Thursday, March 1, 2012 1:27 PM
  • Hmm... I'm just throwing this out there, but could the space be causing this?  I thought I read somewhere about spaces causing an issue. I'm refering to the space here:

    <WORKINGDIR>%SFT_MNT%\oilAndGasReservesDatabase2011V1_01\Reserves Database</WORKINGDIR>

    Try changing the working directory to "c:\temp" or something local.  Like I said, I am just throwin' this out there.  I could be way off :)

    Thursday, March 1, 2012 2:28 PM
  • LOCAL_INTERACTION_ALLOWED won't fix your issue - see this blog post for details on what it does. Excel must be launching outside of the virtual environment, so you'll need to ensure the Excel alway launches inside the virtual environment to see the file.


    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.

    • Proposed as answer by J.Badia Wednesday, March 14, 2012 11:54 AM
    • Marked as answer by Aaron.ParkerModerator Friday, November 16, 2012 10:20 PM
    Thursday, March 1, 2012 2:38 PM
    Moderator
  • Hi Aaron,

    The launch is initiated by the mde file which is running from the bubble. And from what you are saying it seems that, the msaccess engine (or vb engine) which is making the call excel is actually outside and its failing for the first time. This makes sense, but why after clicking on OK button a new excel process (pid:2656, see in the picture above) is created and that succeeds to launch the excel file.

    After clicking on OK button of the above image we get following message (Opening Excel file) and excel file launches:

    Some fall back mechanism is being used behind the scene. Can you throw some light on this Aaron?

    Appreciate your help.

    ~Puneet

    Friday, March 2, 2012 6:40 AM
  • Hello,

    Use Procmon to see what process starts Excel - then investigate howto alter that behavior

    Nicke Källén | The Knack| Twitter: @Znackattack

    Friday, March 2, 2012 2:08 PM
  • Try to pull in the local Excel into your bubble?

    Start a locally installed Excel while you are sequencing .. or even better; push that button which starts Excel, while sequencing.

    Thursday, March 8, 2012 4:07 PM
  • I had a problem with an application that runs reports and opens them excel after completion. when I virtualized this application, it worked fine except for the final step, which is opening excel, which is installed locally. I then virtualized excel, and that fixed the problem or at least provided a valid workaround.

    I am not sure if this possible for you or not, but I would give it a shut and see it helps.


    Mohsen Almassud

    Wednesday, March 14, 2012 2:30 AM
  • If Excel is going to be on the machine, then you dont actually have to sequence excel as well.

    Just make sure Excel is installed on the local machine before you start the sequence.

    If the local install of Excel needs to launch files that are in your appv application, this can be a problem. To get around this copy the files out using prelaunch and protect=true as your options inside HREF that run your script.

    Monday, October 8, 2012 8:52 PM