locked
Calendar not visible in Outlook 2007 / 2010 after mailbox move RRS feed

  • Question

  • We recently migrated from Exchange 2003 to Exchange 2010.  All the mailboxes have been moved from the 2003 servers to the new 2010 MB servers.

    Most of our users were on POP clients.  We are now beginning to migrate them to Outlook 2007 / 2010. 

    We started noticing that, for many of them, the calendar does not show up in Outlook 2007/2010.  It crashes the first time the calendar link is accessed.  It doesn't afterwards but the calendar link still doesn't work.  The calendar does not appear in the folder list view either.  The only way to make it work is to right-click on the calendar link and choose to open it in another window.  In OWA, it works fine without problems.

    The only solution I found is to mail-disable the user and create a new mailbox.  At first, this was acceptable for a few cases but it's starting to look like it's a more widespread issue.

     

    Thanks in advance to anyone who might have an idea for a resolution

     


    Michel Dubé IT analyst (servers) - UQAR
    Friday, October 7, 2011 8:41 PM

Answers

  • My problem was solved by MS support by using an MS utility called EXFolders.  This allowed bulk changes on mailbox folders on a designated database.

    Provided here are the steps suggested by MS support to use EXfolders to unhide the calendars folder on each mailbox.  I must advise extreme caution and cannot garrantee anything.  I strongly suggest that you try any changes you want to do on test DBs.

    Steps taken to resolve the Issue:

    Launch the new version of ExFolder.exe from the bin folder

    • On the ExFolder console connect to the Mailboxes, GC and the database on which the users are
    • After this follow the below steps on the ExFolders console:

    Click on Tools--> Custom Bulk Operation-->Click on Add-->select Other folder Properties-->In the property slot drop down and select PR_ATTR_HIDDEN-->in value slot set the value to FALSE-->click OK-->click OK again

    • The above operation will process all the mailboxes and set the PR_ATTR_HIDDEN to FALSE
    • The calendars and tasks folders showed up in outlook
    • Issue was resolved
    • But folders "Quick Steps Settings” and “Conversation Action Settings” which by default were hidden started to show in outlook
    • So to hide these folders we followed the below steps

    # Launch ExFolders.

    # Click on Tools -> Export Folder Properties.

    # Select properties PR_ATTR_HIDDEN,PR_DISPLAY_NAME,PR_FOLDER_PATHNAME to export to a txt file.

    # Edit the txt file in Excel and set the PR_ATTR_HIDDEN property for “Quick Steps Settings” and “Conversation Action Settings” to "True".

    # Save the file as txt.

    # Import this modified txt file using Tools -> Import (in ExFolders)

    • After following above steps the two folders were hidden and everything was working fine

    Again, proceed with care, your problem might be different from mine.  Hope this helps.


    Michel Dubé IT analyst (servers) - UQAR


    • Edited by TheShape1 Wednesday, September 12, 2012 1:38 AM
    • Marked as answer by TheShape1 Monday, May 13, 2013 12:39 PM
    Wednesday, September 12, 2012 1:37 AM

All replies

  • POP doesn't know anything about a calendar folder because the protocol doesn't support the notion of folders.  The Calendar folder won't get created until you log in to a mailbox for the first time with a client that creates it, such as Outlook with MAPI or OWA.  Maybe that's your problem.
    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Friday, October 7, 2011 10:26 PM
  • I know that POP does not know anything about the Exchange calendar.  I was just providing context for my problem.  As I said in my original post, the calendar is accessible in OWA without problems, so this is not a "calendar not created" issue.  However, I didn't specified that all Outlook 2007/2010 were configured in full Exchange mode, sorry for that omission.
    Michel Dubé IT analyst (servers) - UQAR
    Saturday, October 8, 2011 4:57 PM
  • Are you sure that it's just not omitted in the view you're using in Outlook?  It's easy to think something's not there based on what you see in the left-hand pane.  Try clicking on the other icons at the bottom of the left-hand pane.
    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Sunday, October 9, 2011 12:55 AM
  • I wish the solution was that simple but it's not.  That's why I'm posting here, which I usually don't do at after a good amount of research of my own.

     

    The problem:

    1) A new Outlook profile is configured in Exchange mode either manually or via autodiscover. 

    2) Mail, contacts, tasks and notes work fine.

    3) Outlook crashes the first time the Calendar link at the bottom left is used.

    4) After Outlook is restarted and the same profile is reopened, the calendar link doesn't show anything in the left pane and the rights pane display doesn't change.

     

    To date, I have one drastic solution and 1 (unacceptable) workaround:

    Solution:

    - Exporting the mailbox to a local PST

    - Mail disable the user (via EMC or EMS)

    - Mail-enable the user

    - Importing the PST

     

    Workaround:

    - Right-clicking in the calendar link to open it in another window.

     

    Everything works fin in OWA and this behavior can be reproduced on each workstation I've tried with Outlook 2007 and 2010.

     

     


    Michel Dubé IT analyst (servers) - UQAR


    • Edited by TheShape1 Sunday, October 9, 2011 8:01 PM
    • Marked as answer by Xiu Zhang Tuesday, October 11, 2011 6:43 AM
    • Unmarked as answer by TheShape1 Tuesday, October 11, 2011 12:18 PM
    Sunday, October 9, 2011 5:54 PM
  • It sounds as if you have some sort of mailbox corruption.  What you describe isn't something I've seen and so I don't have anything to offere that's better than the workaround you have, sorry.
    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Sunday, October 9, 2011 8:08 PM
  • Hi,

    Please have a look at the article below,please verify if you have correctly configured for pop3.

    Configure Calendar Options for POP3

    http://technet.microsoft.com/en-us/library/bb124133.aspx

    Xiu

    Tuesday, October 11, 2011 6:45 AM
  • You marked a description of my problem as an ANSWER.  You are not helping at all. 

    If you took the time to read AND understand the thread so far before replying you would quickly understand that my problem is NOT related to POP3.

     


    Michel Dubé IT analyst (servers) - UQAR
    • Edited by TheShape1 Tuesday, October 11, 2011 12:20 PM
    Tuesday, October 11, 2011 12:18 PM
  • I thought it could be mailbox corruption too at first.  But the fact that the calendar displays and works properly in OWA made me search elsewhere.  Thanks for taking some of your time to help me.  Always appreciated.  I'll keep looking and post my findings here.  Since most of the users were using POP3 before, their mailboxes are not very big, I'm thinking about doing PS scripts that would do automate my only solution so far:

    1) Export to PST (using the new-mailboxexportrequest cmdlet)

    2) Mail disable the user

    3) Wait for the DC to replicate properly

    4) Mail enable the user again

    5) Import the PST back to the new, problem-free mailbox (new-mailboximportrequest cmdlet)

     

    I'll give myself a bit more time to come up with another solution.  We'll see

     

    Thanks again

     


    Michel Dubé IT analyst (servers) - UQAR
    Tuesday, October 11, 2011 12:33 PM
  • Hi,

    Since we can access calendar via OWA, mailbox could be normal.

    In this issue, I do not know how did you migrate outlook 2003 to outlook 2007. If you still try to use pop3 via Outlook 2007, then I think you need to care how to correctly configure pop3 on Exchange 2010 first.

    Configure Calendar Options for POP3

    http://technet.microsoft.com/en-us/library/bb124133.aspx

    If you access mailbox via MAPI(Exchange account), then please try to use online mode with outlook.

    Xiu

     

    Thursday, October 13, 2011 2:37 AM
  • For the second time please: make sure you understand the problem before you reply with something that's totally unrelated to the issue at hand.

    A clue: it's NOT about POP3....

    Just read the thread.

     


    Michel Dubé IT analyst (servers) - UQAR

    • Edited by TheShape1 Thursday, October 13, 2011 2:45 AM
    Thursday, October 13, 2011 2:42 AM
  • We recently migrated from Exchange 2003 to Exchange 2010.  All the mailboxes have been moved from the 2003 servers to the new 2010 MB servers.

    Most of our users were on POP clients.  We are now beginning to migrate them to Outlook 2007 / 2010. 

    We started noticing that, for many of them, the calendar does not show up in Outlook 2007/2010.  It crashes the first time the calendar link is accessed.  It doesn't afterwards but the calendar link still doesn't work.  The calendar does not appear in the folder list view either.  The only way to make it work is to right-click on the calendar link and choose to open it in another window.  In OWA, it works fine without problems.

    The only solution I found is to mail-disable the user and create a new mailbox.  At first, this was acceptable for a few cases but it's starting to look like it's a more widespread issue.

     

    Thanks in advance to anyone who might have an idea for a resolution

     


    Michel Dubé IT analyst (servers) - UQAR

    Thursday, October 13, 2011 2:52 AM
  • We recently migrated from Exchange 2003 to Exchange 2010.  All the mailboxes have been moved from the 2003 servers to the new 2010 MB servers.

    Most of our users were on POP clients.  We are now beginning to migrate them to Outlook 2007 / 2010. 

    We started noticing that, for many of them, the calendar does not show up in Outlook 2007/2010.  It crashes the first time the calendar link is accessed.  It doesn't afterwards but the calendar link still doesn't work.  The calendar does not appear in the folder list view either.  The only way to make it work is to right-click on the calendar link and choose to open it in another window.  In OWA, it works fine without problems.

    The only solution I found is to mail-disable the user and create a new mailbox.  At first, this was acceptable for a few cases but it's starting to look like it's a more widespread issue.

     

    Thanks in advance to anyone who might have an idea for a resolution

     


    Michel Dubé IT analyst (servers) - UQAR

    For the last time, read the thread before posting, not just the first post...

     

     

    Michel Dubé IT analyst (servers) - UQAR


    • Edited by TheShape1 Thursday, December 1, 2011 7:20 PM
    Thursday, December 1, 2011 7:19 PM
  • Have you had any further luck troubleshooting this issue?  I have a client with the same issue, but just for a single user.  MS Support so far has not gotten anywhere with fixing the issue.

    I was thinking deleting the mailbox and recreating it would solve it, but apparently this user is involved in a lot of meetings and they would not longer be linked to them and that may cause issues.  The problem seems to be identical to what you are experiencing though. 
    Friday, December 16, 2011 6:31 PM
  • I opened a support call with Microsoft and my issue is close to a solution.    In your case, since this is only one user, I would recommend giving MFCMAPI a try (http://mfcmapi.codeplex.com/).  It allows to connect to the mailbox folder set of a specfic user and "unhide" a specific folder.  In our case, it allowed me to check the folders of a problematic user and manually changing some properties to show the affected folders again (calendars, tasks, notes,etc.).  Since the problem was affecting many users, this wasn't a practical solution but for a handful of users, this could work well.

    I'm far from being a specialist on MFCMAPI, but here's how I did it:

    - MFCMAPI will see and connect to existing Outlook profiles on the PC it is run onto  It doesn't seem to allow connecting to any mailbox on an Exchange server.  So, for a specific user, it might be more practical to run it directly on that user's PC (or a PC with that user mailbox already configured in Outlook.)

    - The version to use (32 or 64-bit) depends on the Outlook version you use, not the OS.

     

    Here's what I had to do to "unhide" the folders I needed to show:

    - Start MFCMAPI

    - In the menu, choose Session => Logon and display store table

    - Select the Outlook profile of the affected user

    - If everything worked ok, 2 items should show up in the upper pane, the user's mailbox and it's public folders

    - Double-click on the first item (name of the user's mailbox) and another window should appear

    - Expand the root then expand IPM_SUBTREE.  It should list the folders of the user's mailbox.

    - To unhide a folder, I had to show it's properties (in the right pane) by selecting the folder (the Calendar folder for example).  You then change the PR_ATTR_HIDDEN property from TRUE to FALSE by doubleclicking the property and checking the "boolean" check box.  For the affected users, some folders that were supposed to have this property set to FALSE (not hidden) were set to TRUE (hidden).  The change was effective as soon as Outlook was reopened (no reboot necessary). It also solved the problem in OWA.

     

    To finish, I would advise extreme caution when using this type of utility.  Some folders are made to be hidden by default (such as "Conversation Action Settings").  Also, I haven't changed any other properties with this utility, just the PTR_ATTR_HIDDEN so I haved no idea what effect modifying other properties would have on the user's mailbox.  This may not be the solution for you but you can use the utilty to check if some folders are hidden when they shouldn't be. 

     

    Hope this helps.

     


    Michel Dubé IT analyst (servers) - UQAR
    • Edited by TheShape1 Tuesday, January 10, 2012 3:41 PM
    • Proposed as answer by TP4700 Tuesday, August 12, 2014 8:26 PM
    Tuesday, January 10, 2012 3:22 PM
  • We have similar problem. After upgrading user from pop3 to MAPI his calenders/contacts are not visible.  Its impractical to do MFCMAPI for 100 of users in my case.What is the solution provided by MS for set of users?

    Thanks in advance

    Nitin

    Thursday, August 23, 2012 2:17 PM
  • My problem was solved by MS support by using an MS utility called EXFolders.  This allowed bulk changes on mailbox folders on a designated database.

    Provided here are the steps suggested by MS support to use EXfolders to unhide the calendars folder on each mailbox.  I must advise extreme caution and cannot garrantee anything.  I strongly suggest that you try any changes you want to do on test DBs.

    Steps taken to resolve the Issue:

    Launch the new version of ExFolder.exe from the bin folder

    • On the ExFolder console connect to the Mailboxes, GC and the database on which the users are
    • After this follow the below steps on the ExFolders console:

    Click on Tools--> Custom Bulk Operation-->Click on Add-->select Other folder Properties-->In the property slot drop down and select PR_ATTR_HIDDEN-->in value slot set the value to FALSE-->click OK-->click OK again

    • The above operation will process all the mailboxes and set the PR_ATTR_HIDDEN to FALSE
    • The calendars and tasks folders showed up in outlook
    • Issue was resolved
    • But folders "Quick Steps Settings” and “Conversation Action Settings” which by default were hidden started to show in outlook
    • So to hide these folders we followed the below steps

    # Launch ExFolders.

    # Click on Tools -> Export Folder Properties.

    # Select properties PR_ATTR_HIDDEN,PR_DISPLAY_NAME,PR_FOLDER_PATHNAME to export to a txt file.

    # Edit the txt file in Excel and set the PR_ATTR_HIDDEN property for “Quick Steps Settings” and “Conversation Action Settings” to "True".

    # Save the file as txt.

    # Import this modified txt file using Tools -> Import (in ExFolders)

    • After following above steps the two folders were hidden and everything was working fine

    Again, proceed with care, your problem might be different from mine.  Hope this helps.


    Michel Dubé IT analyst (servers) - UQAR


    • Edited by TheShape1 Wednesday, September 12, 2012 1:38 AM
    • Marked as answer by TheShape1 Monday, May 13, 2013 12:39 PM
    Wednesday, September 12, 2012 1:37 AM
  • Hi,

    I am facing the same problem. I am unable to edit the properties from Excel as i don't know how to set the value... Can you please help?

    Monday, May 13, 2013 10:54 AM
  • Are you using Exfolders?

    Michel Dubé IT analyst (servers) - UQAR

    Monday, May 13, 2013 12:44 PM
  • yes, i am using Exfolders. I am unable to change the value of “Quick Steps Settings” and “Conversation Action Settings” to "True" from the text file because i dont see the value...just numbers. I am using excel to edit the value. Do you mind telling me how you do it?

    Btw, I can solve the problem using MFCMAPI but not Exfolders. I created a dummy Mailbox Database and migrated few users in it. Once after changing the attribute using Exfolders, I figured the users are still not able to see their calendars.


    • Edited by Bremen6 Tuesday, May 14, 2013 3:14 AM
    Tuesday, May 14, 2013 3:02 AM
  • The key is to export the right values with ExFolders.  Assuming the txt file has been imported with the right properties selected, the column named PR_ATTR_HIDDEN should have a value of either "True" of "False".  So, it must be set to "True" for the folder that must remain hidden. Afterwards, it must be saved to txt and imported back to ExFolders.  It worked for me when I did it but it was more that 1 year ago.  I just tried an export on on my test domain and I can see the PR_ATTR_HIDDEN column in Excel once the txt file has been opened (with the True of False values).

    If you don't have values of "True" of "False" for the PR_ATTR_HIDDEN column, I would suggest to check the way you import the txt file in Excel.  For me, a tab delimited type import worked well.

    Hope this helps.


    Michel Dubé IT analyst (servers) - UQAR

    Tuesday, May 14, 2013 3:03 PM
  • Finally I managed to export with values. I couldn't see the values earlier because I don't have Full Access Permission to the mailbox, so I gave Mailbox permissions to the admin using Powershell. I have changed the value to FALSE according to the steps given above but I don't see any change on users' Calendar, their Calendar is still not visible. Is this due to permission? I would appreciate if you can help . Thanks.

    Thursday, May 16, 2013 2:59 AM
  • I'm afraid I can't offer you more advice other than tell you that the steps mentioned above have been done with full administrative permissions on the databases and mailboxes.  If it's still not working for you, I suggest you open a support call with Microsoft.

    Michel Dubé IT analyst (servers) - UQAR

    Thursday, May 16, 2013 2:46 PM