none
A device attached to the system is not functioning. RRS feed

  • Question

  • Getting Windows 7 (64 bit) hanging every couple of days - stepping back with system restore seems to clear it for another two days. Event viewer shows a series of errors - including the message 'A device attached to the system is not functioning' - but how can I trace what this is. Is it likely to be an external peripheral, or an integral part pf the laptop?
    Wednesday, June 8, 2011 7:07 PM

Answers

All replies

  • When you see this error, have you looked in Device Manager to see if any devices are flagged?

    Control Panel->Device manager...

    Usually malfunctioning devices are flagged with a yellow background icon with an ! in it.

     

    Wednesday, June 8, 2011 9:28 PM
  • It's actually a friend's PC - so I have not seen the problem myself and (as so often happens) having had the PC here for a week it hasn't reoccured - the only thing I have really done is to remove a couple of trojans, but I am not 100% convinced they are the problem.

    Obviously I can hand the machine back and wait for it to break (perhaps this points to a peripheral - I just have the PC here) - and we will then certainly check the device manager. I was really wondering if there is ny other log or whatever other record that would show the problem after the conflict has gone away.

    Thanks

    Neil

    Thursday, June 9, 2011 7:46 AM
  • I am occasionally receiveing a similar error when I attach a USB2.0 hard drive, it loses

    the USB mouse connection.

    cheers


     

     


    • Edited by Ryan Tailor Monday, January 27, 2014 7:09 AM
    Thursday, June 9, 2011 9:32 AM
  • Hi,

    The following link is for your reference.

    http://technet.microsoft.com/en-us/library/cc978749.aspx 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, June 10, 2011 8:56 AM
    Moderator
  • Thanks for the replies - this happens when no external device is attached, so it would seem to be one of the integral parts of the PC. Device manager is no help, as the PC hangs to the extent that NOTHING can be done. We have now found that if left long enough eventually it will clear. I did find another warning message in event log and following that up have now updated the (INtel) graphics driver (all other drivers up to date) and reinstalled latest Intel management interface SW (I think! Should have noted it down!). Now back with owner to see if it breaks again -t ime will tell....
    Monday, June 20, 2011 10:38 AM
  • As usual with Microsoft, 'help' is anything but. Totally USELESS information. I have no devices 'attached to the system' - I get this error when I simply attempt to install certain softtware.
    • Edited by Lord Childe Thursday, March 31, 2016 12:54 PM
    Thursday, March 31, 2016 12:54 PM
  • I had this error running some application after connecting my android phone, I restarted, ran AV's registry cleaners to no avail.  I finally connected my phone back to the usb and just shut the computer completely down.  Once it came back up the error was gone.   I think that the phone caused a problem with the usb and shutting completely down cleared it up.  I hope that helps. 
    Tuesday, October 18, 2016 7:56 PM
  • I've had the exact same problem. It actually fixes the problem if you change USB ports. Although it's pretty clear, I thought I'd mention it

    Monday, September 25, 2017 5:51 PM
  • I had the same problem... I tried reinstalling the drivers or restarting both devices but it didn't help.

    In the end I noticed that I can copy small files, so there must be some kind of interruption in the connection. I changed the usb cable and the problem was solved. 

    That was the solution for me I hope it may help you.


    • Edited by thenyuu Wednesday, March 14, 2018 9:34 AM
    Wednesday, March 14, 2018 9:33 AM