locked
SCOM firing alerts for disabled SQL jobs RRS feed

  • Question

  • Experts,

    We have a disabled SQL Server job. However SCOM still fires alerts for that job.

    Will SCOM not know that the SQL job is disabled and it need not fire alerts for that job.

    If not, can you please let me know what changes I need to do so that SCOM doesn't fire alerts for that disabled SQL job.

    Thanks.

    Regards,

    Praveen

    Wednesday, July 24, 2013 8:18 PM

Answers

  • Hi,

    create new group with dynamic expression filter for Microsoft.SQLServer.xxx.AgentJob class (example :Microsoft.SQLServer.2008.AgentJob for 2008 sql server ) with expression filter on property  IsEnable Equal False.
    create an override and disabled alerting monitor for newly created group, by this you will only receive alerts for enabled jobs in sql.

    Regards


    sridhar v

    Thursday, July 25, 2013 7:49 AM
  • If you don't want the monitor to send alerts at all you can right click the alert select override and then target it to the appropriate class or object of a class.

    Unfortunately I have seen cases with some of the SQL Agent monitors whereby the only classes or members of classes that are presented to you as options would disable monitoring for more than a single desired server that might have an agent stopped/disabled for a reason. To get around this you can go to authoring - create a new group - drop the server and associated SQL objects into the group - then create an override and target it to your newly created group. Not as quick and easy as I would prefer, but it should resolve your issue.

    • Proposed as answer by OpsConfig Thursday, July 25, 2013 1:41 AM
    • Marked as answer by Nicholas Li Tuesday, July 30, 2013 2:21 PM
    Thursday, July 25, 2013 1:41 AM
  • Hi,

    Please also see if the following method helps:

    Remove-DisabledMonitoringObject

    http://blogs.technet.com/b/jonathanalmquist/archive/2008/09/14/remove-disabledmonitoringobject.aspx

    Thanks.

    Nicholas Li
    TechNet Community Support

    • Marked as answer by Nicholas Li Tuesday, July 30, 2013 2:21 PM
    Thursday, July 25, 2013 7:19 AM

All replies

  • If you don't want the monitor to send alerts at all you can right click the alert select override and then target it to the appropriate class or object of a class.

    Unfortunately I have seen cases with some of the SQL Agent monitors whereby the only classes or members of classes that are presented to you as options would disable monitoring for more than a single desired server that might have an agent stopped/disabled for a reason. To get around this you can go to authoring - create a new group - drop the server and associated SQL objects into the group - then create an override and target it to your newly created group. Not as quick and easy as I would prefer, but it should resolve your issue.

    • Proposed as answer by OpsConfig Thursday, July 25, 2013 1:41 AM
    • Marked as answer by Nicholas Li Tuesday, July 30, 2013 2:21 PM
    Thursday, July 25, 2013 1:41 AM
  • Hi,

    Please also see if the following method helps:

    Remove-DisabledMonitoringObject

    http://blogs.technet.com/b/jonathanalmquist/archive/2008/09/14/remove-disabledmonitoringobject.aspx

    Thanks.

    Nicholas Li
    TechNet Community Support

    • Marked as answer by Nicholas Li Tuesday, July 30, 2013 2:21 PM
    Thursday, July 25, 2013 7:19 AM
  • Hi,

    create new group with dynamic expression filter for Microsoft.SQLServer.xxx.AgentJob class (example :Microsoft.SQLServer.2008.AgentJob for 2008 sql server ) with expression filter on property  IsEnable Equal False.
    create an override and disabled alerting monitor for newly created group, by this you will only receive alerts for enabled jobs in sql.

    Regards


    sridhar v

    Thursday, July 25, 2013 7:49 AM