locked
Print to network printer hosted on W7 does not print after W7 has been in standby RRS feed

  • Question

  • I have a small (4 PC) network of Xp and w7 machines. One PC (w7) has a printer attached (parallel port)

    Printing works fine until the w7 with the printer is put into standby/sleep mode.

    Then. once this PC was been woken up, it will not print until the PC is rebooted. Print jobs stack up in the local print queue but will not print. stopping and staring print spooler does not help.

    As soon as PC is rebooted the queued jobs print OK.

    How to I get the w7 pc wiht printer to print jobs in the queue without rebooting?

    Wednesday, November 13, 2013 8:05 PM

All replies

  • Hi,

    Have you tried to clear the spooler content?

    net stop spooler

    del %systemroot%\system32\spool\printers\*.shd

    del %systemroot%\system32\spool\printers\*.spl

    net start spooler


    Alex Zhao
    TechNet Community Support

    Monday, November 25, 2013 2:41 PM
  • Thanks for the thoughts - sadly no help. The full story is as follows


    The first DOS command produced System Error 5
    The 2nd and 3rd appeared to execute OK
    Printing from the client still did not work.

    So I thought I'd start from scratch.
    I deleted rebooted and reinstalled the printer on host and client machine.
    Printed a test page from both machines OK

    Put the client machine on standby; woke it up and printing was fine

    Put the host machine on standby; woke it up and tried to print. 
    Got 'Document failed to print' on client Document remains in client machine print queue

    Executed your commands in a Run as Admin Dos window
    Job disappeared from client print queue after net stop spooler
    Net start spooler and the job appeared in the host computer print queue (status printing) but did not print 
    Tried Net Stop Spooler followed by the two delete commands but there were no shd or spl files.
    The Net start spooler and the job shows job in queue status printing  but doesn't print.

    I rebooted the host computer and the job started to print.

    Hope that provides some clues


    Monday, November 25, 2013 7:51 PM