locked
AppV 4.6: Updated package not launching in Citrix XenApp RRS feed

  • Question

  • I updated an application in our environment using the "update my package wizard" in the app-v sequencer.  My desktops work just fine, however my citrix server gives me an error, "cannot find the path specified".  Upon further looking around, in our version of the App-V "Q" it has the 8.3 folder already there.  I have deleted all the applications (sftmime delete obj:app /global) and the folder and a couple of others still reside in the "Q" virtual directory.  Any idea's on how to clear these folders without an uninstall/reinstall of the app-v client?  My sftlog has corrupt cp file detected.

    RDS Client Version: 4.6.1 SP3

    Server OS: 2008 SP2

    Any direction would be appreciated.


    Brian


    Thursday, March 7, 2013 6:48 AM

Answers

  • In theory, an updated package should replace the original one quite nicely when using the Sequencing Wizard tu 'update' or 'add new application' to an exisitng package - what you did. And when not trying to save it 'as a new package' - did you?

    Note that you have to have 'one second' on a machine where nobody uses any application from the original package before the App-V Client can update it to the new version (none of the applications of that packages has the 'in use' status in the Client MMC)

    Sometimes it is enough to re-open the (updated) package on the Sequencer again and just save it.

    I'm afraid that you'd either have to delete the 'old' package that is causing the conflict on the 8.3 folder when things are messed up. Also for this the apps must not be in use.

    You may use the App-V Analyzer tool (against the content share/repository) to identify such conflicts before they occur: http://kirxblog.wordpress.com/2011/08/25/new-free-login-consultants-application-virtualization-analyzer-tool/



    Falko

    Twitter @kirk_tn   |  Blog kirxblog   |  Web kirx.org

    Thursday, March 7, 2013 7:05 AM
    Moderator