none
Error: An error occurred: "System.IO.InvalidDataException" "Multiple Active Directory entries were found for type "ms-RTC-SIP-ConferenceDirectory" with ID "40"." RRS feed

  • Question

  • Hi Everyone.

    I Have a forest with 10 domain. I Upgrade Lync 2013 to skype for Business 2019. in 2 domain skype installed without any problem but when i  upgrade another domian i show Error on publish topology.

    When I publish Skype for Business 2019 topology I Get this Error:

    Error: An error occurred: "System.IO.InvalidDataException" "Multiple Active Directory entries were found for type "ms-RTC-SIP-ConferenceDirectory" with ID "40"."

    But when i  get  Get-CsConferenceDirectory with this ID , show bellow message:

    Get-CsConferenceDirectory : Cannot find "ConferenceDirectory" "40" because it does not exist.

    At line:1 char:1
    + Get-CsConferenceDirectory  -Identity  40

    And when I continue my configuration 2 service not started

    1- Skype for Business Server Audio Test service

    2- skype for Business Server Front-End

    Then show This 3 error Log , skype for Business Server Front-End service were Stopping: 

    LS Application Module 30236
    LS Application Module 30211

    LS Server                   12308

    How can I solve This Problem?





    Saturday, June 22, 2019 7:40 AM

Answers

  • Hi javad shoaei,

    About the conference directory error, I think you may use ADSIEdit to check:

    Open “ADSIEdit”, “Action” – “Connect to”, select “Configuration”, then navigate to “CN=Configuration,DC=domain,DC=com” - CN=Services - CN= RTC Service, expand the “CN=Conference Directories”, filter if there is any CN with “msRTCSIP-ConferenceDirectoryID=40”. If it exists, you could manually delete it in ADSIEdit.

    About the FE service issue, according the Event, it may be related to the above issue, please re-run “Enable-cstopology” after you resolve the above issue, and re-run the setup steps in deploy wizard.

    In addition, please check the installation account permission, make sure it has the sufficient permission. You may add it into the domain admin group for child domain, and remove it from the group after installation finishes.


    Best Regards,
    Shaw Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by javad shoaei Tuesday, June 25, 2019 2:05 AM
    Monday, June 24, 2019 2:07 AM
    Moderator

All replies

  • Hi javad shoaei,

    About the conference directory error, I think you may use ADSIEdit to check:

    Open “ADSIEdit”, “Action” – “Connect to”, select “Configuration”, then navigate to “CN=Configuration,DC=domain,DC=com” - CN=Services - CN= RTC Service, expand the “CN=Conference Directories”, filter if there is any CN with “msRTCSIP-ConferenceDirectoryID=40”. If it exists, you could manually delete it in ADSIEdit.

    About the FE service issue, according the Event, it may be related to the above issue, please re-run “Enable-cstopology” after you resolve the above issue, and re-run the setup steps in deploy wizard.

    In addition, please check the installation account permission, make sure it has the sufficient permission. You may add it into the domain admin group for child domain, and remove it from the group after installation finishes.


    Best Regards,
    Shaw Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by javad shoaei Tuesday, June 25, 2019 2:05 AM
    Monday, June 24, 2019 2:07 AM
    Moderator
  • Hi Shaw Lu.

    Thank you for your answer. I'm very grateful.

    Tuesday, June 25, 2019 2:07 AM
  • You are welcome. Glad to see it is helpful.


    Best Regards,
    Shaw Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, June 25, 2019 7:46 AM
    Moderator