none
Cannot add search engines in IE11 RRS feed

  • Question

  • I can't add any search engines in Internet Explorer 11 anymore.

    When I try to add Google (or any other) I get an error message saying "The search provider could not be installed".

    As I am Swedish it is searching for Swedish search engines. When I force it to go to the English iegallery site it can't even find Google as a search engine and it only finds about 16 different addons total.

    I have tried this on several computers, both domain joined and not. I have tried to completely uninstall IE11 and re install it with no luck.

    Any idea on what's going on?

    Thursday, January 22, 2015 10:32 AM

Answers

All replies


  • Hello niklas.henningsson,

    Do you mean that when you try to add search engines like google, youtube to any Internet Explorer 11 in your environment get the error message ‘The search provider could not be installed’?
    Do you uninstall and reinstall Internet Explorer 11 in Control panel, turn windows features on or off?

    Based on my test, I can’t see google search to add when I use the language English(United State).
    1. Open Internet Option(General tab)
    2. Click Language, then set Language Preference, add English(United Kingdom) and move it up.
    3. Restart Internet Explorer and then I can find google search.

    I can add it normally, please try to run the Internet Explorer 11 as administrator and check if the issue still exists.

    Best regards,
    Fangzhou CHEN


    Fangzhou CHEN
    TechNet Community Support

    Friday, January 23, 2015 6:32 AM
    Moderator
  • I press the magnifying glass at the search bar and then press Add which takes me to http://www.iegallery.com/sv-se/addons?callback=true&featuretype=2.

    From there I search for Google and choose Add to Internet Explorer. I get an error message that translates roughly to 

    The search provider could not be installed. It can depend on one of the following:

    * Could not find file
    * The Website is not available
    * Your are not connected to the internet

    Please try again later

    This happens with all search providers I try with

    At the top of the screen you can change language, if I go there and change it to the English site http://www.iegallery.com/en-us/PinnedSites and from there I can only find about 16 addons, none of them which are Google.

    I tried to change the language but get the same error


    Friday, January 23, 2015 1:22 PM
  • Ok, so I just found a solution. And this is so dumb and must be something wrong on the iegallery.com site.

    If I go to the Swedish iegallery site I can find Google. I can go into that addons page which takes me to http://www.iegallery.com/sv-se/Addons/Details/1682. As we concluded earlier if I press the Add to Internet Explorer button here it just gives me the error message.

    But if I change the sv-se in the url to en-us instead it takes me to the English version of the site and directly into that addon. I can then press Add to Internet Explorer and it works!

    What's strange is that if I go the the en-us version of iegallery (http://www.iegallery.com/en-us/Addons) I cant find any addons, but if you know the exact URL to the Google Addon you can manually type it and it works.

    Friday, January 23, 2015 1:26 PM
  • Google is no longer an available choice for a default search engine add-on. I tried niklas.henningsson's link (thank you) at http://www.iegallery.com/en-us/Addons/Details/1682 which DID get me to a Google add-on option but it's in Swedish. By chance does anyone have the direct link to the US Google add-in?

    Edit:

    Got it!

    http://www.iegallery.com/Addons/Details/813

    Friday, January 23, 2015 2:17 PM