none
DPM 2010 Tape colocation problems RRS feed

  • Question

  • Hello,

    I'm having problems with colocating 2 protection groups to one tape.

    I have enabled colocation of tapes.

    I have set TapeWritePeriodRange to 0,9

    I have set ExpiryToleranceRange to 1 (100%)

    Both PGs have same long term protection retention (1 week, backup every day)

    I tried to create recovery point to tape manually, or schedulled long term protection on the same time (13:00 daily), but DPM don't want to use same tape for both PG.

    I've made it pretty simple, just one DS in every PG, one is Exchange Public folder database, the other is Windows 2003 system state. Total data is 6 GB, and I'm using LTO 5 tapes. Encryption is disabled, Compression is on.
    Does anybody know why DPM won't put backups to the same tape?


    Tonza

    Thursday, February 14, 2013 3:19 PM

Answers

  • Hi,

    Please open SQL management studio and run the following query. 

    use dpmdb
    SELECT PropertyName,PropertyValue
      FROM [DPMDB].[dbo].[tbl_DLS_GlobalSetting]
      where PropertyName = 'OptimizeTapeUsage'
      or PropertyName = 'tapewriteperiodratio'

    If the OptimizeTapeUsage is not = True, or if the tapewriteperiodratio contains a comma (0,9) instead of a period (0.9) then change it so it has a period using the following script.

      update [DPMDB].[dbo].[tbl_DLS_GlobalSetting]
      set propertyvalue = 'True'
      where PropertyName = 'OptimizeTapeUsage'
      update [DPMDB].[dbo].[tbl_DLS_GlobalSetting]
      set PropertyValue = '0.9'
      where PropertyName = 'tapewriteperiodratio'

    Then try some ad-hoc backups.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.


    Thursday, February 14, 2013 8:01 PM
    Moderator

All replies

  • Hi,

    Are the tapes being marked "offsite ready" after each manual backup ?

    Please run the power shell script in this post and verify both PG's show as being able to co-locate.

    http://social.technet.microsoft.com/Forums/en-US/dpmtapebackuprecovery/thread/9d22936a-a1e0-4ba3-8585-cebf5621999a


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, February 14, 2013 3:51 PM
    Moderator
  • Hi,

    Tapes are not being marked as "offsite ready" after manual backup.

    I allready found the similar script, but I ran the one you said. As I was suspecting, the result is that both PGs can be colocated:

    -----------------------------------------------------------
    Protection Groups that can share the same tape based on recovery goals/Encryption:
     
    Exchange Servers  (PG1)
    Sistemski Diskovi (PG2)

     


    Tonza

    Thursday, February 14, 2013 5:16 PM
  • Hi,

    Please open SQL management studio and run the following query. 

    use dpmdb
    SELECT PropertyName,PropertyValue
      FROM [DPMDB].[dbo].[tbl_DLS_GlobalSetting]
      where PropertyName = 'OptimizeTapeUsage'
      or PropertyName = 'tapewriteperiodratio'

    If the OptimizeTapeUsage is not = True, or if the tapewriteperiodratio contains a comma (0,9) instead of a period (0.9) then change it so it has a period using the following script.

      update [DPMDB].[dbo].[tbl_DLS_GlobalSetting]
      set propertyvalue = 'True'
      where PropertyName = 'OptimizeTapeUsage'
      update [DPMDB].[dbo].[tbl_DLS_GlobalSetting]
      set PropertyValue = '0.9'
      where PropertyName = 'tapewriteperiodratio'

    Then try some ad-hoc backups.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.


    Thursday, February 14, 2013 8:01 PM
    Moderator
  • Hi,

    I did some patching, installed rollup package 7 (previously had rollup 1 installed), and tried manually again, and everything worked. So it must be some issue that was repaired applying patch. I tried rebototing server serveral times before patching, so it's not something like that.

    Then I scheduled real jobs. I have 3 PGs that I want to store to tape; 2 jobs are colocated on the same tape, each about 1,1 TB (2,3 Tb together) and 3rd job, exchange, with cca 50 GBs went to new tape. Is there any event or log where I can find why this 50 GB wasn't stored to same tape? How can I tell that the tape was full or something like that?

    Tonza


    Tonza

    Friday, February 15, 2013 1:01 PM
  • Hi,

    Is the first tape marked offsite ready ?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, February 15, 2013 1:57 PM
    Moderator
  • No it is not.

    Aren't tapes marked offside ready sometime during night?


    Tonza

    Friday, February 15, 2013 2:00 PM
  • No,

    If the tape gets filled, or if we get an under the covers IO error, then the tape is marked offsite immediately.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, February 15, 2013 4:00 PM
    Moderator
  • Ok, so what do you sugest?

    Should I run the SQL query that you posted?

    This server wasn't initially installed by me, so it is possible that something is wrong, but I'm not sure where to check anymore.

    Today, I tried to run few PGs to tape again, and again it uses separate tapes, for one system state  (600 MB) and one for exchange of 5 GB.

    I will try to erase tapes, which are only marked as free, not erased, but I have my doubts...


    Tonza

    Friday, February 15, 2013 4:40 PM
  • Hi,

    No need to erase the tape.  Yes, please run the sql script.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, February 15, 2013 4:55 PM
    Moderator
  • Ok, I will run the script. I need to find credentials to sql first.

    Is DPM trying to "predict" if recovery point is gonna fit to tape? I have another server, with LTO 3 tapes, and I succesfully stored 120 GB, but when I perform another recovery point to tape manually (exchange again) it uses new tape.

    This is really strange to me, and inconsistent.


    Tonza

    Friday, February 15, 2013 6:00 PM
  • HI,

    DPM does not do any predicting, however it's strange that it always seems to want to place the exchange data on a separate tape.    I can try to repro, Is that Exchange 2010 DAG ?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, February 15, 2013 6:10 PM
    Moderator
  • no, its exchange 2010 in mixed environment with 2003 and 2007 at another customer.

    I have managed to run SQL script you posted, and I saw that my tapewriteratio property was using comma (,) instead of a period. I have changed it and I will try to run job again and get back with the results.


    Tonza

    Friday, February 15, 2013 6:39 PM
  • Ok, now this is realy crazy.

    As I stated in previous post, I have ran the sql script, and corrected comma with period. I thing this is a serious bug, since in my country (croatia), we use comma for decimal separator. Further more, when I entered the value in powershell, I had to enter it using period; if I use comma, poweshell scriplet won't accept it. So I entered it with period, and its still stored in SQL table using comma. That is just bad programming.

    Next, after correcting entry, I ran a jobs by hand yesterday at night, and they were all stored to same tape.

    Today, scheduled job started at 13:00 and again it is splitting my backups, now it's using 3 tapes. This is just redicolous. And no logs and no errors. I must say that I'm feeling sad for windows 2003 era when logs was detailed, and some good engineer could actually fix something. Now, I'm losing 4 days allready, and cannot fix this silly thing. Furthermore, I feel like in black night without any light, since there is nothing I can find wrong, and there is no trace in any log what is happening. It is like MS thinks that everything will just work, no need for admins. Again, really silly.

    Is there anything you can suggest me to try, since I really need to make this work, and I have no options to help myself since there is no logs.

    All I can find is "This job started", "this job finished."


    Tonza

    Saturday, February 16, 2013 1:44 PM
  • Hi,

    Yes, the , vs . is a localization bug, and that is why I asked you to change it.

    DPM log files are located in the Program Files\Microsoft DPM\DPM\Temp.  Since manual backups are being co-located, it's not a co-location problem per say.

    Please make sure DPM 2010 is on the latest QFE V3.0.8195 KB2751231-Description of hotfix rollup package 7 for System Center Data Protection Manager 2010


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Saturday, February 16, 2013 2:22 PM
    Moderator
  • Ok, i will try to run through those logs. 

    Nice place to store logs, temp folder. :-) 

    I already know about those, is there anything in particular that I should try to find?

    I'm sorry for rage in earlier post, it's just that I'm pretty frustrated by now, because this is really annoying and I'm already behind all schedules with this.

    I have already pathed it, as I mentioned in post #4. It's on rollup package 7.

    I have another DPM server with similar setup, and I'm having some strange issues there to.

    FOr example, I set up TapeWritePeriodRatio to 0.9 and then I managed to have backups on the same tape. Then I changed it back to 0.15 (default) and it splitted it again on 3 tapes.

    If I understand this correctly, this is percentage of total retention time for PG, and it is used to control for how long DPM will use same tape. I have set retention to 7 days, and I would like to have backups start on a new tape every day, not to continue to use tape used day before. default setting od 15% is just over a day (1,05) so I thought that this is the correct setting, but when I use 0.15, it splits backups to multiple tapes again; and all jobs were started at the same time.

    My goal would be this:

    1. colocate data to tapes, use as many tapes as needed, just use whole capacity

    2. next time the job runs, use new tape, whatever space has left from yesterday

    is it possible to achieve?


    Tonza

    Saturday, February 16, 2013 3:32 PM
  • Hello,

    I found another problem and this is posible the reason why I had this problems.
    The registry entry TapeExpiryTolerance was misspelled, with missing E, so the defaults was used.
    I have fixed it and now it works.

    I will mark as answer Mike's post with SQL script and localization bug, since without that answer I would never resolve this issue.
    Tnx Mike.


    Tonza

    Tuesday, February 19, 2013 8:00 AM