locked
Spell check feature - completely inaccurate? RRS feed

  • Question

  • Hello,

    I have an issue with a SP2010 publishing portal. When I go to check in a page, the spell check will run and inform me of the number of spelling mistakes. On one page, it tells me there are 128 spelling mistakes, but it highlights about 10 on the page. There are only about 300 words on the page and theres no way there are that many mistakes.

    Can anyone shed any light on what might be causing this behaviour? Also how would I go about adding new words to the SP dictionary (eg company names)

    ** I have just tried a fresh blank page and I get 109 errors, but there is no content on the page!

    Thanks

    • Edited by cbundy Thursday, August 19, 2010 1:23 AM Updated
    Thursday, August 19, 2010 1:21 AM

Answers

  • Hello,

    Thank you for the detailed steps. We have confirmed that the behavior you have reported is reproducible at our end and requires in depth troubleshooting. This has been reported to the SharePoint Product Group however, If you wish to pursue this proactively, please open up a Premier Support Incident with Microsoft for continued troubleshooting on this issue.

    Also, please see if http://support.microsoft.com/kb/2571999 can serve as a workaround for you.


    Please remember to click 'Mark as Answer' on the post that helps you or click 'Unmark as Answer' if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Regards,
    Nishant Shah
    Microsoft Online Community Support

    Monday, February 13, 2012 7:29 AM
  • I'm also having a similar issue. To confirm that it wasn't caused by custom code I created a blank publishing site, and copied the Article Page Layout, modifying it to have a Contact (SharePointWebControls:UserField) field as well. When I create a new page using this page layout, it has bound the new Contact field to my user context. Without editing or adding any other text, running Spell Check on the page brings back 99 errors, all due to the html code behind the contact control.

    The only change I make to the Article page layout is to add the following code, just above the edit mode panel for the roll-up image.

     

    <
    
    div
    
    >
    
    
     <
    
    SharePointWebControls
    
    :
    
    UserField
    
     FieldName
    
    =
    
    "aea1a4dd-0f19-417d-8721-95a1d28762ab"
    
     runat
    
    =
    
    "server"
    
    >
    
    </
    
    SharePointWebControls
    
    :
    
    UserField
    
    >
    
    
    </
    
    div
    
    >
    
    
    

    [EDIT]

    I've found one work-around, which is to use javascript to inject the "excludeFromSpellCheck" attribute onto the html rendered for the control. I name the div around the asp control something distinctive, then when the page loads scripts run that get the wrapper then iterate across child elements of type input and textarea.

    Example:

    var tableCell = document.getElementById('excludeContentFromSpellCheck');
    
    var inputNodeArray = tableCell.getElementsByTagName('input');
    for (var i = 0; i < inputNodeArray.length; i++) {
      inputNodeArray[i].setAttribute("excludeFromSpellCheck", "true");    
    }
    
    var textNodeArray = tableCell.getElementsByTagName('textarea');
    for (var i = 0; i < textNodeArray.length; i++) {
      textNodeArray[i].setAttribute("excludeFromSpellCheck", "true");    
    }

     

    • Edited by nickl_ Monday, February 28, 2011 10:34 AM Work-around found
    • Proposed as answer by nickl_ Monday, February 28, 2011 12:22 PM
    • Marked as answer by Margriet Bruggeman Tuesday, April 17, 2012 12:46 PM
    Thursday, February 17, 2011 5:26 PM

All replies

  • Hi Cbundy,

     

    First, you can try to deactivate the spell checking feature, then enable it again, check the effect.

     

    Second, create a new page, when you finish editing, click the spelling button, then select the appropriate language, check the effect.

     

    You can add a custom dictionary to your publishing site to prevent words that are unique to your content from being reported as spelling errors. For example, if your site includes unique product names, you can add them to the custom dictionary. Make a list of all product names, frequently used acronyms, and other words that you want to be included in a custom dictionary for your site.

     

    If you want to add some new words which should not be considered as spelling mistakes, you can do this by adding your custom dictionary.

     

    For more information about how to do that, please refer to the following articles:

    Adding custom spelling in SharePoint

    http://manish-sharepoint.blogspot.com/2010/05/adding-custom-spellings-in-sharepoint.html

     

    Web page authoring planning

    http://technet.microsoft.com/en-us/library/cc263367.aspx

     

    Hope this helps.

     

    Rock Wang


    Regards, Rock Wang Microsoft Online Community Support
    Saturday, August 21, 2010 8:45 AM
  • Hi Rock,

    I tried deactivating spell check and enabling it again, but I get the same thing, even on a blank page (109 spelling errors)

    Do you have any other suggestions?

    Thank you

    Wednesday, August 25, 2010 5:36 AM
  • I'm having the same issue.  It appears to be checking the HTML code.  Have you found any solutions/suggestions?

    Thursday, August 26, 2010 9:37 PM
  • Thats what I suspected. I haven't found a solution yet, I think I will raise this with MS. 
    Friday, August 27, 2010 7:45 AM
  • Let me know what they say, please.
    Tuesday, August 31, 2010 4:13 PM
  • I've found the same thing, ive got people pickers on the page and the spell check function is telling me that the HTML contains many spelling mistakes. Some of the things being checked are the ID's of various spans in the page and that sort of thing, naturally these are full of non-english words and markup.

    Its quite annoying - any suggestions?

    Friday, November 12, 2010 4:46 AM
  • I have the same problem and it is the UserField controls (people picker) that is causing the spell check errors. I am still looking for a way to fix this or disable spell check for this specific control.
    Friday, December 10, 2010 8:30 AM
  • Has anyone found the real answer to this problem?  I am having the same issue.  The bottom line is that it appears to be spell checking the HTML.  A friend told me that he had seen an article that indicated it had something to do with the page layout but he has not been able to find the article.  We are using custom page layouts.

     

    Updated - 02-03-2011

    Here is what I have discovered so far.  We are using a set of 5 custom page layouts that were created when our SharePoint site was still 2007.  These were converted with the rest of the site to 2010.  The custom page layouts are copies of existing page layouts with an addition of the following at the bottom of the layout:

     

                    <div class="FCS-Modified-Info">
                        Modified: <SharePointWebControls:ListItemProperty Property="Modified" runat="server" /> <br />
                        Contact: <SharePointWebControls:UserField FieldName="PublishingContact" runat="server" />
                    </div>

    In addition, somehow a <tbody> tag has been inserted into one of the tables near the top without a closing </tbody> tag.  (Not sure where that came from)  Using SharePoint designer I fixed the <tbody> tag and comment out the inserted div, published and approved the change then tested it on a new page.  Everything works.  I then uncomment the div and republish and approve and it works great.  As a matter of fact, the other 4 page layouts that I didn't touch all work. 

    When I go back a few hours later and create another page with those layouts, I get the errors again.  If I go back to the page I created earlier, everything works.  If I try to apply the layouts to older existing pages the errors are still present.

    I am at my wits end on this one.  Placed a call to Microsoft.  I guess I'll have to burn a support incident.

    Wednesday, January 19, 2011 4:01 PM
  • I'm also having a similar issue. To confirm that it wasn't caused by custom code I created a blank publishing site, and copied the Article Page Layout, modifying it to have a Contact (SharePointWebControls:UserField) field as well. When I create a new page using this page layout, it has bound the new Contact field to my user context. Without editing or adding any other text, running Spell Check on the page brings back 99 errors, all due to the html code behind the contact control.

    The only change I make to the Article page layout is to add the following code, just above the edit mode panel for the roll-up image.

     

    <
    
    div
    
    >
    
    
     <
    
    SharePointWebControls
    
    :
    
    UserField
    
     FieldName
    
    =
    
    "aea1a4dd-0f19-417d-8721-95a1d28762ab"
    
     runat
    
    =
    
    "server"
    
    >
    
    </
    
    SharePointWebControls
    
    :
    
    UserField
    
    >
    
    
    </
    
    div
    
    >
    
    
    

    [EDIT]

    I've found one work-around, which is to use javascript to inject the "excludeFromSpellCheck" attribute onto the html rendered for the control. I name the div around the asp control something distinctive, then when the page loads scripts run that get the wrapper then iterate across child elements of type input and textarea.

    Example:

    var tableCell = document.getElementById('excludeContentFromSpellCheck');
    
    var inputNodeArray = tableCell.getElementsByTagName('input');
    for (var i = 0; i < inputNodeArray.length; i++) {
      inputNodeArray[i].setAttribute("excludeFromSpellCheck", "true");    
    }
    
    var textNodeArray = tableCell.getElementsByTagName('textarea');
    for (var i = 0; i < textNodeArray.length; i++) {
      textNodeArray[i].setAttribute("excludeFromSpellCheck", "true");    
    }

     

    • Edited by nickl_ Monday, February 28, 2011 10:34 AM Work-around found
    • Proposed as answer by nickl_ Monday, February 28, 2011 12:22 PM
    • Marked as answer by Margriet Bruggeman Tuesday, April 17, 2012 12:46 PM
    Thursday, February 17, 2011 5:26 PM
  • Also looking to fix this issue.
    Wednesday, August 31, 2011 3:53 PM
  • Still seems to be an issue in 2012 even after the Dec CU. For us the issue occurs in a list form created for a dept who's main request was to have a spell check on their list. Any resolutions from Microsoft other than hacking the html?
    Wednesday, January 11, 2012 6:30 PM
  • Has anyone found a fix for this?
    Wednesday, February 1, 2012 12:03 PM
  • Have you got a fix for this?
    Tuesday, February 7, 2012 12:56 PM
  • Hello,

    I tried on SharePoint 2010 with SP1 + Dec'11 CU and I wasn't able to notice this issue for both publishing and non-publishing page. If you are able to still notice this issue after successful install of Dec'11 CU, could you please provide me detailed steps to repro this issue?


    Please remember to click 'Mark as Answer' on the post that helps you or click 'Unmark as Answer' if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Regards,
    Nishant Shah
    Microsoft Online Community Support

    Thursday, February 9, 2012 12:02 PM
  • Hi Nishant. Our issue is a little different as it doesn't have to do with publishing pages but affects our forms with people picker controls so appears to be a related issue. If we spell check a list form it returns hundreds of errors even if only the people picker is filled out. We have successfully installed the Dec CU.
    Thursday, February 9, 2012 4:21 PM
  • Hello,

    Can you provide steps so that I can reproduce this issue in-house and investigate further?


    Please remember to click 'Mark as Answer' on the post that helps you or click 'Unmark as Answer' if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Regards,
    Nishant Shah
    Microsoft Online Community Support

    Friday, February 10, 2012 6:53 AM
  • Can u Let me know what they say, please?

    thanks!

    Friday, February 10, 2012 7:07 AM
    1. Create custom list
    2. create column of "Person or Group"
    3. add new item
    4. fill in username making sure to "Check Names"
    5. Spell Check the form

    Those simple instructions return 122 spelling errors in the form with only Title and Person or Group control as columns.

    Friday, February 10, 2012 4:10 PM
  • Hello,

    Thank you for the detailed steps. We have confirmed that the behavior you have reported is reproducible at our end and requires in depth troubleshooting. This has been reported to the SharePoint Product Group however, If you wish to pursue this proactively, please open up a Premier Support Incident with Microsoft for continued troubleshooting on this issue.

    Also, please see if http://support.microsoft.com/kb/2571999 can serve as a workaround for you.


    Please remember to click 'Mark as Answer' on the post that helps you or click 'Unmark as Answer' if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Regards,
    Nishant Shah
    Microsoft Online Community Support

    Monday, February 13, 2012 7:29 AM
  • Hello.

    It is now almost 16 months later and the issue still exists. Has this been addressed? Thank you.

    Thursday, May 30, 2013 8:21 PM