locked
Updating Enterprise Global template RRS feed

  • Question

  • Hi there Server Gurus,

    In the past I've updated the global template settings to change the default view of all my MS Project files (created in Proj Centre).. but for some reason it's not working anymore

    I am opening my Project in the Project Center via Project Professional. When I open my file,  I change some views such as:

    * In Resource Usage - on the left pane ive added some extra columns

    * In Resource Usage view - on the right pane ive selected to view Work only

    When I publish the file and reopen it, extra columns do not save.

    I've tried updating the Resource Usage views in the Global Template by clicking Server Settings->Enterprise Data->Enterprose Global-> Select 'Configure Proj Professional' and made the changes. I then click Publish

    Problem is that when I reopen my file, the changes that I made on the global do not appear on my file.

    Pls help me :)

    Tuesday, October 9, 2012 11:49 PM

Answers

  • The reason why these changes are not saved is that you are editing non-enterprise views. The resource usage view is a local view. To change that you need only change it in your client. If you want to share a new Resource Usage view, then create an "Enterprise Resource Usage View."

    Be careful because when you checkout the enterprise global and apply a local view as you stated above, this usually pollutes the Enterprise Global file and will cause every project you open to throw errors about a duplicate view name. You should read the documentation on TechNet or get my book.


    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG

    Wednesday, October 10, 2012 5:49 PM

All replies

  • I am sure you must have tested it but still wanted to ask, did you closed & reopened the project pro, as it takes effect only after the MSP has been reopened, also another test if any other user connects to server, he should get a message saying new Enterprise Global is available & update is required, if that's not the case it means Enterprise Global is not getting saved & updated, Just try & see if you are following the process as outlined here : http://technet.microsoft.com/en-us/library/gg188104.aspx

    Thanks | Sunil Kr Singh | http://epmxperts.wordpress.com

    Wednesday, October 10, 2012 1:53 AM
  • I tried the above and it still doesn't work. 

    Initially I thought that clicking 'Publishing' the global made it available, but according to Technet you need to click 'Save'

    When I click save i get an error "Project is unable to access the cache location. Reconnect to the Network and try again".

     Are there any suggestions on how to fix this?

    Wednesday, October 10, 2012 2:26 AM
  • Hi, Nichola? It looks as though there are two questions here:

     - Connecting to the Network - for this I would exit Project Professional and restart making sure to select the right Project Server account.

      - Publishing Project Professional views that are available to all Project Pro users on your network - for this you should create new views, tables, filters, groups, etc. with new names. Don't try and change the Project default ones (Gantt Chart, Task Usage, etc.) in the Enterprise Global. The problem is that each installation of Project has its own local Global which holds the default ones. You need to create (e.g. by copying) new views and tables with organisation related names (e.g. Swan Gantt Chart). Best practice is to create these in your own Project Pro environment and then use Organiser to copy them into the Enterprise Global.

    Graham

    Wednesday, October 10, 2012 1:51 PM
  • Try do delete the project server account on the project professional 2010 and then create again the account.<o:p></o:p>

    To create view on the project professional 2010, I recommend you to create a new table with fields you want then associate the view you want to show to that table.<o:p></o:p>


    Wednesday, October 10, 2012 2:03 PM
  • The reason why these changes are not saved is that you are editing non-enterprise views. The resource usage view is a local view. To change that you need only change it in your client. If you want to share a new Resource Usage view, then create an "Enterprise Resource Usage View."

    Be careful because when you checkout the enterprise global and apply a local view as you stated above, this usually pollutes the Enterprise Global file and will cause every project you open to throw errors about a duplicate view name. You should read the documentation on TechNet or get my book.


    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG

    Wednesday, October 10, 2012 5:49 PM
  • Hi Gary,

    Sorry for my stubbornness. In the past I've made updates to the Resource Usage view in the global settings which updated the view globally. (I tested this by sign in as another user on another machine and checked that the updates appeared on my second account).

    It just seems like an easier method (but unfortunately it's no longer saving the updates for me. 

    If I plan to create a new Enterprise Resource Usage View as you've stated above... how do I revert my Resource Usage view back to it's default? Because right now it's got some custom views and fields which will no longer be required if i create a enterprise view

    Sunday, October 14, 2012 11:29 PM