none
How to save subsite as template, when the the Save site as Template is not availible ?

    Question

  • Hi

    I have a standard Sharepoint Online site Collection and want to be able to make one subsite, that should act as template for the next subsites that I create. I haven't changed or enabled/disabled any features in the SharePoint Admin, it's the standard config used when first time using SharePoint Online in a Office 365 subscription.

    However this "Save site as Template" option is nowhere to be found - can anyone help ?

    Wednesday, January 25, 2017 11:49 AM

Answers

  • Hi,

    The “Save site as template” link doesn’t occur in Site Settings in your SharePoint site, am I right?

    Please try to deactivate the “SharePoint Server Publishing” feature at site level.

    If it still doesn’t appear, you can open this site via SharePoint Designer 2013 > click Site Options > set “SaveSiteAsTemplateEnabled” property to true > Refresh.

    Thanks,

    Dean Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Proposed as answer by Victoria XiaModerator Thursday, February 2, 2017 10:53 AM
    • Marked as answer by Jam2811 Sunday, February 5, 2017 11:43 AM
    Friday, January 27, 2017 7:22 AM
    Moderator

All replies

  • Hi JAM,

    try with this link pls.

    https://support.office.com/en-us/article/Create-and-use-site-templates-60371b0f-00e0-4c49-a844-34759ebdd989?ui=en-US&rs=en-US&ad=US

    Best Regards,

    Surendar S

    Please remember to mark the replies as answers 

    Wednesday, January 25, 2017 12:47 PM
  • Hi,

    The “Save site as template” link doesn’t occur in Site Settings in your SharePoint site, am I right?

    Please try to deactivate the “SharePoint Server Publishing” feature at site level.

    If it still doesn’t appear, you can open this site via SharePoint Designer 2013 > click Site Options > set “SaveSiteAsTemplateEnabled” property to true > Refresh.

    Thanks,

    Dean Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Proposed as answer by Victoria XiaModerator Thursday, February 2, 2017 10:53 AM
    • Marked as answer by Jam2811 Sunday, February 5, 2017 11:43 AM
    Friday, January 27, 2017 7:22 AM
    Moderator
  • Hi Jam2811,

    Does "Save as template" show in Site Settings after you set "SaveSiteAsTemplateEnabled" property in SharePoint Designer?

    If my reply is helpful to you, you can mark as answer.

    Thanks,

    Dean Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, January 31, 2017 1:18 PM
    Moderator
  • Hi Dean

    The Sharepoint Designer 2013 did indeed work with Sharepoint online, I just had to do these changes first -> http://blog.stw-services.com/connect-sharepoint-online-using-sharepoint-designer-2013/

    For others with same problem, please give the enable scripting setting in Sharepoint Admin - 24 hours after you save the change. I tried right after the change and it didn't work - waited to the day after and it worked.

    I can now logon and I can save as template in Sharepoint Designer (Option is currently not visible in the Site Settings though, but maybe the "SaveSiteAsTemplateEnabled" property will also take some time to work as well

    Thanks Dean for the help

    Sunday, February 5, 2017 11:43 AM