none
how to change monitor identities on window 10 RRS feed

All replies

  • Click drag to the desired location

    Wanikiya and Dyami--Team Zigzag Windows IT-PRO (MS-MVP)

    Wednesday, March 8, 2017 1:15 AM
    Moderator
  • Main Display - Change in Windows 10

    S.Sengupta, Windows Insider MVP

    Thursday, March 9, 2017 12:07 AM
  • Hi,

    Try this:

    Settings ->System, select Display in the left pane. Click Advanced display settings link. Then click and drag one of the monitors to its correct location. The Identity numbers don't matter.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, March 9, 2017 6:38 AM
    Moderator
  • hi..

    Right click on the desktop and OPEN

    Intel Graphics Properties

    Youl find the  display options etc..

    If your using a laptop..

    You may need to be connected to an external display monitor, as the setting maybe set to only display externally. 

    good luck

    Thursday, March 9, 2017 9:19 AM
  • You Rock!!!  I have been racking my brain and you just nailed it!

    Thursday, March 15, 2018 6:44 PM
  • I am having a similar problem and looked at the Intel Graphics Properties. Under the details tab I found a huge list of items. Would you kindly elaborate a bit on what you did to make the settings change? Thank you!
    • Proposed as answer by ItsthePandster Thursday, June 21, 2018 4:38 AM
    Friday, May 4, 2018 1:19 PM
  • Hi,

    Try this:

    Settings ->System, select Display in the left pane. Click Advanced display settings link. Then click and drag one of the monitors to its correct location. The Identity numbers don't matter.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact 

    You are absolutely wrong that the identity number do not matter.  I am routinely having the issue where I turn on my TV to watch cable show and my computer is detecting that it is on as a monitor.  The TV for some stupid ass reason is identified as 1.  Especially when I return from sleep/hibernation, even though the display identified as 2 is set as my main display, when I open a new window it automatically opens on the display set as 1, and even some of the windows that were originally on the main monitor now show on 1 as well.  I have to go and switch the tv input to the computer input, drag the windows back over (including the window for Settings) and then disconnect the display via the Display options window.  

    There is absolutely no reason that the number identity should not be a user configured setting, the fact that it isn't shows the utter ineptitude of the programmers and designers of Microsoft.  

    Wednesday, June 20, 2018 6:07 PM
  • Hiya Calathan, I've just found out the answer after hoping to find it here. For Windows 10 dual-monitor owners:
    Start > Settings > System > Display > drag box 1 or 2 within the space on the black rectangle where 1 & 2 are.

    I get what they're trying to do by making this universal sort of, where typing in a question would bring up different results, versus it being directly in someone's face, but so many people are used to settings-based changing of things that they'd never think to simply drag or move something to get it working. 

    ... That is, until in vain (like I did) they try clicking the 1 & 2 boxes to try to forcefully set the proper order up, XD

    I DO find it terrible in an OCD capacity that I can't change the identity numbers, but at least the order of the 'boxes with numbers on them' can be changed around, including through the Intel Graphics Settings > Display > Multiple Displays > Arrange Displays & Set One or More Active Displays sections. I agree, it's very annoying that Windows couldn't employ someone to work with Intel on this to improve things. C'est la vie, for now. Watch them include it in Windows 12 or something.

    Thursday, June 21, 2018 4:24 AM
  • Hiya Maxc73, 

    For Windows 10 dual-monitor owners:

    Start > Settings > System > Display > drag box 1 or 2 within the space on the black rectangle to reorder the monitor's layouts.

    Doesn't look like the numbers themselves that are assigned to the monitors can be adjusted, or the setting hasn't been found yet by me at least.

    Hope this helps!

    • Proposed as answer by ItsthePandster Thursday, June 21, 2018 4:27 AM
    Thursday, June 21, 2018 4:27 AM
  • Hiya RipperB, when you've right-clicked on your desktop and gone into the Intel Graphics Settings area:

     Intel Graphics Settings > Display > Multiple Displays > Arrange Displays & Set One -OR- More Active Displays sections. Make sure to click apply in the lower right corner once finished fiddling about.

    Maybe you can figure out how to get the re-titling to carry on through Windows? I seem to make the adjustments in changing the numbers for both displays, but have no luck with Windows noticing them once applied.


    Thursday, June 21, 2018 4:37 AM
  • I, too have the same problem.  I run WinUAE, an AmigaOS emulator, which runs on display #1 regardless of where it's positioned in the rearrangment panel.  I had everything running good the way I liked, and then, after an Update, Windows renumbered the screens and now my WinUAE program doesn't display on the correct monitor the way I want.  The main screen I use used to be display #1, now it is numbered #3.

    I really hate the way Windows 10 takes our ability to configure things away from us.  Maybe Linux will get mainstream soon.

    Sunday, October 14, 2018 11:51 PM
  • Moving the boxes around also entails dismounting the physical monitors and swapping them, when your software only shows on display #1.
    Monday, October 15, 2018 12:04 AM
  • Go to Display Settings (from Settings or by right-clicking on the Desktop). Click the monitor which you would like to be your primary monitor. Scroll down and check the box labeled "Make this my main display." If this option is not enabled, your main display is already selected; if it is not the one you wanted to be your main display, double-check that the system recognized your selection. You may want to click "Identify" to ensure that you know which monitor Windows sees as which.
    Friday, November 16, 2018 5:19 PM
  • I've just worked through this same problem and found that there is currently no way to change monitor identities, HOWEVER you can change which monitor or display is the PRIMARY display which I believe can fix your issues as it did mine. You simply click on the monitor that you want to be the primary monitor in settings>display, and then scroll down and select the box that says "Make this my main display". 

    Hope this helps.

    Thursday, January 10, 2019 9:22 PM
  • It does matter, actually.

    I have a laptop and 2 external monitors connected to its docking station.

    When I use the laptop outside the docking station everything goes to the one and only display #1.

    Back in the docking station everything stays in the #1 display but in this case it's not the main display anymore so I find myself dragging allthe windows back to the main one.

    In my paticular case I "solved the problem" by switching places the 2 external displays on my desk (switching the ports was not enough) but it would be nice to have the choice of controling the identities of the monitors.

    Monday, February 25, 2019 7:59 PM
  • I have found people asking this same question on help boards for ten years now. 

    The short answer is that you cannot with MS settings alone.  

    You have to hope you have a graphics card with settings that will let you override this.  I do not :(

    You will find a hundred people (see below) who say "drag it to the other side" but that's not what you (or I) am asking.  I want the monitor that is identified as 1 to be 2 and the one that is 2 to be 1. 

    And YES, it DOES matter.  If I have two monitors 1 is considered the primary where apps open and the toolbar fully displays. And if you want the left side of one monitor to match the right side of the other, you HAVE to be able to switch the monitor identity. It's insanity that this was overlooked in their UX design, yet here we are.

    Saturday, March 2, 2019 7:13 PM
  • This is a REAL PROBLEM Microsoft! I have a 4 monitor configuration:

    Intel Graphics adapter on my MB is connected to two 8 inch displays 

    GTX-1060 is connected to a 2k display and an HD display

    Whenever I boot the first Intel graphics adapter is where the danged system icons are and where the search bar is! I have to MANUALLY SEVERAL TIMES switch the primary back and forth before the 2K is finally my REAL primary.

    I don't mean to be rude but try understanding the question and the problem before you throw out that same old BS answer! This is a REAL PIA and it pisses me off every time I start my computer. This  is directly related to the fact that the windows Operating System has a clear affinity to integrated graphics cards and when it enumerates displays it starts there!

    Friday, March 8, 2019 7:22 PM
  • Hi there everyone. :)

    @maxc73 I wish my monitor identities would change on their own, just once though. I have a GTX1080FE and have a 22" HD TV connected by display port and a 55" 4k HDR connected by HDMI. My Win 10 1809 shows the 22" as number 2 and the 55" as number 1. I use the 22" most of time for work stuff and the 55" for gaming and watching films/TV shows.

    It's not as essential for me as others but it would be very useful to swap the identity numbers . 

    And yeah... the display identity number cannot be changed in the Windows display settings. It's something much deeper than that. Hopefully some awesomely clever hero/heroine will come along and tell us how to do it. :)


    • Edited by everway9 Saturday, March 30, 2019 12:52 PM
    Saturday, March 30, 2019 12:51 PM
  • This is a real issue for some users of specific projection software such as OpenLP, Easyworship, VideoPsalm etc., especially when using one monitor for desktop work and the second monitor is hooked to a projector.

    The answer is to delete some registry keys and then restart the PC with only one monitor - the one you want to use as main monitor - monitor 1.  All other video leads MUST be removed FROM THE PC.  This will then force the OS to assign that monitor on that video output as 1.  Then you can attach the second monitor, detect monitors and away you go.  Do the usual dragging to how you like to use them if you wish.  Make sure you've then assigned the monitor you want as the primary monitor and (probably) extended the displays.

    The registry keys you need to delete are these:

    HKEY_LOCAL_MACHINE\Systems\CurrentControlSet\Control\GraphicsDrivers\Configuration
    HKEY_LOCAL_MACHINE\Systems\CurrentControlSet\Control\GraphicsDrivers\Connectivity

    Don't forget to make a backup of your registry first!

    Many thanks to https://support.displaylink.com/knowledgebase/articles/736116-windows-display-properties-identify-numbers-are   for this.  Took some tracking down.  But it works.  

    best, revdv

    Wednesday, April 10, 2019 6:45 PM
  • OMG RIGHT!?!?!?! Brooo like are people just simple or something?! I've been up all night looking at forums, and EVERYONE is like, "you gotta put the thing where the other thing is and set the thing to main thing blah blah!" omg soooo annoying! We're trying to change the display IDENTITY people!!! My Rocketdock shows on the wrong screen now! I upgraded from my 1070 to a 1080 Ti. And the monitor Identities switched, at first my audio was coming from the wrong display. But I switched it in the playback devices settings. And switched priority. And I can switch my rocket dock to the other screen as well. But i'll be honest...i'm OCD AS HECK!!!! I want the left screen to be 1 and the right to be 2. NO MATTER WHAT! Sooo triggered! lmao ps add me on Instagram @Synth__Plissken
    Saturday, April 20, 2019 7:22 AM
  • THANK YOU!!! DEAR LORD!!!!!!! FINALLY! if I WAS A CHICK I'D KISS YOU ON THE LIPS BRO! WTF!!!
    Saturday, April 20, 2019 7:25 AM
  • Nice one @DaUrbanMunky. Great post! At least you had the guts to post something very similar to what I've thought about posting. :D

    I have an obsessive compulsive nature myself so I know just how frustrating these things can be. 

    Arrrrrrgggh! :D


    Sunday, April 21, 2019 2:32 AM
  • I just grappled with the screen identity thing, as I am running three monitors including the laptop screen, and I have found out this:

    Although I couldn't change the screen identity once the computer decided what each screen was to be called, I did find out that the computer liked monitor identified as number 1 to have the blue D-sub cable, and identity 2 to be HDMI. Once I switched cables around, the monitor identities changed and all was good in the world again!

    • Proposed as answer by waldoz76 Thursday, June 6, 2019 12:38 AM
    Wednesday, May 29, 2019 6:57 AM
  • Wow, I was getting so frustrated, and all I had to do was switch the cables! :). Thanks Jana_K. 
    I think I had figured this out a while back, but forgot about it (I must have mixed up the cables when I moved my desk).

    It was frustrating me because under Intel Graphics Settings, my PC was Screen 1, but under Display Settings it was Screen 2. Thanks for the quick fix. I'm glad I read this answer before changing my registry!
    ...and props to JohnyCamach and DaUrbanMunky for expressing the frustrations I was having, and clarifications I needed.

    Thursday, June 6, 2019 12:46 AM
  • I followed the steps, but this method doesn't work for me. (revdv/displaylink method)

    It starts fine with the two displays connected to the discrete card. (Displayport) And they get numbered correctly as 1&2.

    But once I add also the TV to the iGPU (HDMI) it doesnt get #3. There is some override and the TV becomes #1. Am I doing it wrong? Or is that typical?

    This is super annoying. I use Avid Media Composer (NLE) and it displays dialog boxes only on display #1 (by design) - regardless of the display arrangement.

    In this case #1 (TV) is the client monitor which is not part of the user interface. It's a real problem - not an OCD thing.

    Nice to see I am not alone. DaUrbnaMunky said it well.

    Thanks



    • Edited by Sivanxyz Wednesday, July 10, 2019 11:38 PM
    Wednesday, July 10, 2019 8:09 PM
  • Identities Does Matter on my end... in our work it screenshots our monitor 1 to our server so i want to change from 1 to 2 and 2 to 1..
    Sunday, July 21, 2019 5:57 AM
  • This may be late for those having this issue but hopefully this will be useful to anyone who encounters the same problem. I recently update my PC and after the new update, my system crashed and so I had to reinstall windows. I use two monitors as well and reset my settings in the BIOS(in an attempt to figure out why Windows wouldn't load) which also reset my monitor settings in the BIOS. When I finally got everything up and running, I realized that the screens were switched in the Display settings. Searched in vain and got no answer but to switch the displays around. That wasn't a great solution for me but it occured to me that I may have changed something in the BIOS to where even though I enabled the iGPU for the second monitor that's connected to the CPU, I didn't select which one of the two displays (The one connected to the GPU and the one connected to the iGPU) would be my main one. I went back into the BIOS and set it to automatically choose the main display and now it's back to normal.

    Tuesday, August 6, 2019 5:19 AM
  • Just switch the connectors (DVI, display port or HDMI) on video card behind your computer.
    Saturday, August 31, 2019 12:32 AM