none
Programs on client machines can't see server when operating in elevated (admin) mode

    Question

  • HI,

    I've created a symbol store on our server and the continuous build system populates it.  However, to attached to a process and debug it requires that the client computer open visual studio with admin privileges and this then kills access to the server where the symbol database is.

    So my question is, how can I set the server to allow connections from clients machines running processes in admin mode?

    The environment:

    All client PC's are using office 365 (azure AD) for user accounts.  The accounts are linked to the server.  Users use Launchpad to sign in to the server and get access.  

    e.g. my workstation log in is "dave@precisionostech.com", but I also then log in to the server as "dave" - but the pw is linked across both systems.  Once logged in to both, the user has access to all the company shares.  If they run as admin (any program or powershell/dos prompt) that process can not see the server or shares.

    Any help much appreciated.

    Dave


    Dave Roberts

    Thursday, May 9, 2019 11:16 PM

All replies

  • hi,

    1 can you enter winver in command prompt on both your problematical server and client computer then look the os version and os version number ?[for example server 2016 standard ]

    2 "I've created a symbol store on our server and the continuous build system populates it. "
    did you symbol store on server essentials ?

    3 "However, to attached to a process and debug it requires that the client computer open visual studio with admin privileges and this then kills access to the server where the symbol database is."
    did you try to add the user account to local admin group on client computer .
    why you not use domain admin account to debug it on client computer directly?

    4 there are some limitation (include hardware and feature) about server essentials , so i am not sure your software(or code)can work fine on server essential.is it possible to store your symbol to other member server or domain added workstation pc then let client to access it ?


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, May 10, 2019 3:27 PM
    Moderator
  • Is there any progress on your question?

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, May 15, 2019 11:26 AM
    Moderator
  • Is there anything to help you?

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, May 17, 2019 5:41 AM
    Moderator