locked
Windows desktop manager RRS feed

  • Question

  • I have a serious problem. From sutarday, my windows don't wotk anymore how should be. Aero is working, but any opened windows flicker from time to time. When opened window flicker, in tasbar area, button for that window disapper and again appear. Also when I open Visual FoxPro and click on button to modify form, window flicker for second, and nothing. Thus, repeat about 5 times the same procedure and than I got form on desktop. Also double click on form to open code window and nothing, I repeat 3-4 time and than, code window is appear. During that time, main window constantly flicker and in taskbar area disappear and again appear! I try reinstall, uninstall driver for graphic card and again install, but the problem is here all the time. Also I install and service pack 1, but nothing is changed, problem is still here, so I do system restore to point before service pack. If I, in services, disable WDM than flicker and all other problems are gone, but AERO also gone, and system somehow becomes slow?

    Even to mention that on Friday night everything worked properly. On Saturday when I turned on the computer problems began. Only on Friday night that I did that I started a some Cytrix client that has crashed, during which time the Aero stopped working, but when I turned off the client (task manager + end process), AERO returned.

    What i shoul do? Do I have to reinstall Windows? Because we running out of options!


    • Edited by Kopljan Michael Monday, March 28, 2011 11:01 AM wrong word in topic
    Monday, March 28, 2011 7:22 AM

Answers

  • That’s seem your system suffered with a serious issue. May be system files were broken or corrupted.  Remove windows SP1 package first:

    http://windows.microsoft.com/uninstallwindows7sp1

     

    Then perform an in-place upgrade to fix your system:

    http://support.microsoft.com/kb/2255099

     

     

    Regards,

    Leo   Huang

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, March 30, 2011 6:39 AM

All replies

  • If I, in services, disable WDM than flicker and all other problems are gone, but AERO also gone, and system somehow becomes slow?


    this is by design. The DWM is needed to run Aero Glass. If Glass is disabled the CPU renders the GUI again which slows down the speed because the graphic card is no longer used.

    Set the compatibility options for Visual FoxPro and disable Aero Glass for that application. Visual FoxPro is very old and not Aero compatible.

    Also update your graphic card driver.


    André


    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Monday, March 28, 2011 12:15 PM
  • I already write that Visual FoxPro is only one program that have problem! Any window that is opened e.g. : IE, Windows explorer, Outlook ... ANY WINDOW flicker and dissapear and again appear in taskbar! Before Saturday, everything is working fine for months ago, and now any window flicker and not responsable!
    Monday, March 28, 2011 12:40 PM
  •  Before Saturday, everything is working fine for months ago, and now any window flicker

    Do a system restore to a point before Saturday:

    http://www.sevenforums.com/tutorials/700-system-restore.html


    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Monday, March 28, 2011 2:06 PM
  • I can't. When I installed Service pack 1, all restore points are gone. There is just one before service pack 1.
    Monday, March 28, 2011 2:45 PM
  • That’s seem your system suffered with a serious issue. May be system files were broken or corrupted.  Remove windows SP1 package first:

    http://windows.microsoft.com/uninstallwindows7sp1

     

    Then perform an in-place upgrade to fix your system:

    http://support.microsoft.com/kb/2255099

     

     

    Regards,

    Leo   Huang

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, March 30, 2011 6:39 AM
  • That’s seem your system suffered with a serious issue. May be system files were broken or corrupted.  Remove windows SP1 package first:

    http://windows.microsoft.com/uninstallwindows7sp1

     

    Then perform an in-place upgrade to fix your system:

    http://support.microsoft.com/kb/2255099

     

     

    Regards,

    Leo   Huang

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thanks Leo,

    You saved me! It's take 2.5 hours to complete in-place upgrade but problems are gone. Only PostgreSQL RDBMS can't start, there is no service for PostgreSQL in Service list, but I managed to register service manualy and start it, and now everything is OK! Thank you again.

    Wednesday, March 30, 2011 10:47 AM