locked
SP 2007 Survey Results Disapeared RRS feed

  • Question

  • I setup a basic survey on SP 2007 and have provided myself as well as another user "full control" on the survey.  I am unable to view any survey results (except my own)!  What's even weirder, is that I first was able to view the other user's survey results, but all of a sudden I am unable to.  I can also not view any graphical results of the survey.  Has anyone had any experiences with something like this?  I really do not want to have to re-create the survey.  Thank you!
    Tuesday, November 29, 2011 5:55 PM

All replies

  • Hi,

    Go to the advanced settings and check if you have proper settings or not.


    Thanks, Rahul Rashu
    Wednesday, November 30, 2011 4:07 AM
  • Hi,

    Thanks for your comment, but I do have the proper permissions assigned.  I think someone else may have come in and tampered with our settings, because we were originally able to view survey results and now we cannot.  Additionally, I created a new "test survey" and configured it with the same permissions as the survey in question.  I am able to view all survey results, as expected. 

    Is there any way I can check past logs/backup data to see if anyone may have changed anything/what just happened to change the settings to the survey?  Thank you.

    Wednesday, November 30, 2011 2:53 PM
  • Unless you've got auditing turned on, than no.  The surveys within SharePoint are fairly basic

    One thing is somewhat contradictory though, if you have full permissions, you wouldn't be constrained by survey specific settings to only view your own entries.  What exactly do you have full permissions on, the survey, the site level or the site collection?


    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/
    Wednesday, November 30, 2011 3:03 PM
    Answerer
  • I know surveys are quite basic, which is why this is so puzzling to me.

     

    I have full control on the site level and within the survey.  When I select "view graphical summary of responses" I get a screen that says "there are no responses" and when i select to "view all responses" the only entry I can view is when I completed the survey. 

    Wednesday, November 30, 2011 3:25 PM
  • All I can suggest then is two things: -

    1 - Ask your site collection administrator to get an export of the entries.  This will confirm what is actually within it

    2 - Check what permissions are in the permission group.  By this I don't mean check what permission group is attached to the member group you're in, but check the permission compisition as well.  You may find an errant admin has been tinkering and accidently changed something.


    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/
    Wednesday, November 30, 2011 3:40 PM
    Answerer
  • Thanks again for your continued responses.  The permission group has "full control" and my account is listed individually for having "full control" as well.  It is just very odd that I cannot view the other results.  The survey is set so that users can read all responses as well. 

    I had the farm site administrator take a look at the survey, and he too is unable to view the results.  This is just very odd.  I don't know if someone did some tinkering, but I am just concerned that if we re-build the survey, that something like this happen again and we lose our data after say 100 people take the survey.

    Wednesday, November 30, 2011 3:58 PM
  • The farm admin or the site collection admin?  If neither of them can see the data, then it's not there.

    Have you checked the recycle bin for deleted entries?


    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/
    Wednesday, November 30, 2011 4:01 PM
    Answerer
  • I checked with the site collection admin, sorry.  It's just odd because the survey displays that 4 people have completed the survey.  Recycle bin does not have any of the entries, either.  And the other 3 users completed the entire survey!

    Wednesday, November 30, 2011 4:04 PM