none
Select deployment server from WinPE boot image RRS feed

  • Question

  • We have multiple MDT servers spread across many sites around europe.

    We create all MDT deployment task sequences etc at a central site in the UK, then push them out to the multiple sites who then have to put the WinPE image on their local PXE server.

    We are in the process of changing how the PXE servers are managed and would like to create a WinPE image in the UK and push it out to all the PXE servers across Europe.

    But when the image boots it tries to connect to the UK server and not the local one, is there a way to add an option so that they can select their local MDT server?

    Friday, July 1, 2016 9:39 AM

Answers

  • I've found the way to deal with this.

    I'll place this here just in case anyone else is looking for the answer.

    Place a file called LocationServer in the following folder

    <DeploymentShare>\ExtraFiles\Deploy\Control

    Lay it out in the following format:

    <?xml version="1.0" encoding="utf-8" ?>

    <servers>
        <QueryDefault></QueryDefault>

        <server>
            <serverid>1</serverid>
            <friendlyname>
              Server1
            </friendlyname>
            <UNCPath>\\server\deploymentshare</UNCPath>
        </server>

        <server>
            <serverid>2</serverid>
            <friendlyname>
              Server2
            </friendlyname>
            <UNCPath>\\server\deploymentshare</UNCPath>
        </server>

    </servers>

    In the Deployment share properties via mdt goto the WinPE tab

    In the Extra directory to add box put <Driveletter>:\<Deploymentshare>\ExtraFiles

    Update your deploymentshare, the new WinPE image will now have the option at the begining.

    • Marked as answer by pgilbert11 Thursday, July 28, 2016 2:40 PM
    Thursday, July 28, 2016 2:40 PM

All replies

  • DefaultGateway is the key: https://deploymentbunny.com/2012/04/21/back-to-basic-customsettings-ini-explained/

    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    Friday, July 1, 2016 7:52 PM
    Moderator
  • I've found the way to deal with this.

    I'll place this here just in case anyone else is looking for the answer.

    Place a file called LocationServer in the following folder

    <DeploymentShare>\ExtraFiles\Deploy\Control

    Lay it out in the following format:

    <?xml version="1.0" encoding="utf-8" ?>

    <servers>
        <QueryDefault></QueryDefault>

        <server>
            <serverid>1</serverid>
            <friendlyname>
              Server1
            </friendlyname>
            <UNCPath>\\server\deploymentshare</UNCPath>
        </server>

        <server>
            <serverid>2</serverid>
            <friendlyname>
              Server2
            </friendlyname>
            <UNCPath>\\server\deploymentshare</UNCPath>
        </server>

    </servers>

    In the Deployment share properties via mdt goto the WinPE tab

    In the Extra directory to add box put <Driveletter>:\<Deploymentshare>\ExtraFiles

    Update your deploymentshare, the new WinPE image will now have the option at the begining.

    • Marked as answer by pgilbert11 Thursday, July 28, 2016 2:40 PM
    Thursday, July 28, 2016 2:40 PM