locked
Does the registry mod DisableStrictNameChecking still work on Server 2008? RRS feed

  • Question

  • Hello,

    On server 2003, you could add the DisableStrictNameChecking parameter to the registry and you would be able to connect to the server using an alias.  This doesn't seem to work on Server 2008?  The error I am getting when I try to connect to an aliased server share is: Logon Failure: The target account name is incorrect.  Does this registry mod still work on Server 2008?  Is there a different registry mod to make this work?

    Thanks.

    Friday, June 20, 2008 4:09 PM

Answers

  • Hello,

     

    In my test, the DisableStrictNameChecking registry value is also applied to the Windows Server 2008 as described in the following Microsoft KB article:

     

    281308          Connecting to SMB share on a Windows 2000-based computer or a Windows Server 2003-based computer may not work with an alias name

    http://support.microsoft.com/kb/281308

     

    For the "account name is incorrect" error, you should have a try to disable the authentication loopback check that as the Method 1 in the following KB article:

     

    926642          Error message when you try to access a server locally by using its FQDN or its CNAME alias after you install Windows Server 2003 Service Pack 1: "Access denied" or "No network provider accepted the given network path"

    http://support.microsoft.com/kb/926642

     

    Hope it helps.

    • Marked as answer by Miles Li Monday, June 30, 2008 6:02 AM
    Tuesday, June 24, 2008 8:33 AM

All replies

  • Hello,

     

    In my test, the DisableStrictNameChecking registry value is also applied to the Windows Server 2008 as described in the following Microsoft KB article:

     

    281308          Connecting to SMB share on a Windows 2000-based computer or a Windows Server 2003-based computer may not work with an alias name

    http://support.microsoft.com/kb/281308

     

    For the "account name is incorrect" error, you should have a try to disable the authentication loopback check that as the Method 1 in the following KB article:

     

    926642          Error message when you try to access a server locally by using its FQDN or its CNAME alias after you install Windows Server 2003 Service Pack 1: "Access denied" or "No network provider accepted the given network path"

    http://support.microsoft.com/kb/926642

     

    Hope it helps.

    • Marked as answer by Miles Li Monday, June 30, 2008 6:02 AM
    Tuesday, June 24, 2008 8:33 AM
  • Hi there.

    Thanks for this, I've tried it and I'm able to browse the shared printers on the NLB cluster but can't connect to any of them.

    I'm running 2008 Std and there was no MSV1_0 key so I created it. I've also added NETBIOS names to each node but still no use...

    Any ideas???

    Be the change you wish to see in the world
    Monday, July 7, 2008 4:58 PM
  • i opened up a new thread here:
    http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2networking/thread/210d739f-7ab4-4839-8775-9027eea41864

    As i cannot get this to work on windows 2008 either, i no longer get duplicate but now i get 3 random folders, printer share which is not much use.
    Sunday, November 15, 2009 8:46 PM