locked
ESENT ERRORS IN EVENT VIEWER RRS feed

  • Question

  • I have a Dell Studio XPS 9100 computer with Windows 7 Prof, with 12gb of ram, and two internal HDs. The computer normally operates without any major errors noted in computer management event viewer. However, ESENT errors appear shortly after I complete the monthly MS security updates, and I will see mulitiple ESENT entries. I would appreciate any help in resolving this problem. Thanks Sam.

    The following is an example of one of the entries:

    Log Name: Application

    Source: ESENT

    Date: 11/01/2012 6:59:42 AM

    Event ID: 474

    Task Category: Database Page Cache

    Level: Error

    Keywords: Classic

    User: N/A

    Computer:

    Description:

    Catalog Database (1196) Catalog Database: The database page read from the file "C:\Windows\system32\CatRoot2\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\catdb" at offset 17862656 (0x0000000001109000) (database page 4360 (0x1108)) for 4096 (0x00001000) bytes failed verification due to a page checksum mismatch. The expected checksum was [77547754d6bb9432] and the actual checksum was [77567756d6bb9492]. The read operation will fail with error -1018 (0xfffffc06). If this condition persists then please restore the database from a previous backup. This problem is likely due to faulty hardware. Please contact your hardware vendor for further assistance diagnosing the problem.

     

    Event Xml

    Saturday, January 14, 2012 8:10 PM

Answers

All replies

  • Please refer to:

    ESENT Event ID 474 Database page cache error
    http://www.techtalkz.com/windows-help/37155-esent-event-id-474-database-page-cache-error.html


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Friday, January 20, 2012 8:21 AM
    Monday, January 16, 2012 2:50 AM
  • Arthur, many thanks for your reply.  Will study the reference you gave and then will try the suggested actions.  Will post back my results.  Have a good week, Sam.
    • Proposed as answer by SHORTTY99 Friday, May 11, 2012 4:56 AM
    Monday, January 16, 2012 12:06 PM
  • Dear All Baffled Administrators,

    I too had this problem and was perplexed as to what the problem was.  However, I have found out what was causing the problem and what I did to resolve it.  This is not to say that it will be your exact problem, but may help you in your own diagnosis.

     

    Brief summary of my problem...

    HP DL360G5 with 2x4c CPU, 8GB. Win2008R2 would not perform MS updates, would not run SmartStart or Insight.  .  Event viewer showed ESENT 474 and other erroneous problems.

     

    Initial diagnosis....

    Rebuilt with many copies of OS disk (not resolved)

    Tried to install HP agents and management (not resolved)

    Update to latest firmware and back again! (not resolved)

    Low level format of disks (not resolved)

    Intensive memory check (not resolved)

    Conclusion....

    Nothing! Frustrating that I can’t install any helpful software as anything I try crashes.  Spent many hours believing it must be a software issue.

     

    Second diagnosis...

    Hard thinking on the underlying problem that anything that used any form of database would fail.  Why?

    Found a few blogs where admins had repaired the jet database and done all sorts of things to fix the problem.  But no luck with me on trying this.

    Back to hardware again and as I have an identical server I started swapping parts. First was the working (and updating) OS from S2. Boots OK.  However, when I try updates, same problem. Disks back in to S2 and no problem.

    Swapped P400i RAID controller. Still problem.

    Swapped memory. Still problem.

    Found blog where admin talks of taking out one of the CPUs and that sorted it.  Don’t really want to do this as I don’t have the right tools and don’t want to mess the heatsink.

    Now thinking that the problem is the system board. Server out of warranty, so no calling HP!.  Don’t want to buy one and don’t want to rip out from S2 as it would mean swapping CPUs for the sake of complete diagnosis.

     

    Solution...

    While trying different BIOS config, I noticed that I could reduce the number of cores used on the CPUs. Thinking this might be the same as removing a CPU, I tried it. I enabled this option and the server went from 8 cores to 4 across both CPUs.

    Hey presto! Problem resolved and updates pouring in.  Smartstart and InSight with no problems.

     

    Conclusion....

    Faulty CPU, but which one?  Or faulty system board. 

    As to why seemingly good hardware that does everything else has a problem with database type processing is too deep for me.  Maybe somebody has an answer on that that would explain.

    Friday, May 11, 2012 4:56 AM
  • This note is also to baffled system administrators, it's is a little late, but for others who find this thread, please ignore the advice above.

    Dude... It's a software configuration issue.

    Replacing the HDD... not going to fix it.
    Replacing the RAID controller... not going to fix it.
    Replacing the memory... not going to fix it.

    BIOS? CPU? Now system board? OMG! Stop it please, my head hurts just thinking about the extra issues you are bringing to the table. 

    When you said, "Found a few blogs where admins had repaired the jet database and done all sorts of things to fix the problem.  But no luck with me on trying this." <-- your fix starts here.

    Saturday, August 15, 2015 3:17 AM