locked
Problem installing Lync server, unable to meet MSMQ prerequisite RRS feed

  • Question

  • Hi,

    We have 3 domain controllers(2 x 2008R2, 1 x 2003R2) and a member server in our network, I am trying to install Lync Server 2010 on the 2008R2 member server. I am now at step 2 under the Install or Update Lync Server System but I keep getting an error message saying 'Prerequisite not satisfied: Message Queuing Server (MSMQ) and Message Queuing Directory Service Integration must be installed before attempting to install this product. MSMQ must not be in workgroup operation mode.'

    I have installed MSMQ with Directory Service integration on the member server and the two 2008R2 domain controllers, do I need to install this on all domain controllers?

    On the member server I have two different events in the event application log. The first is error ID 2116 which says 'Message Queuing was unable to create the msmq (MSMQ Configuration) object in Active Directory Domain Services. Error c00e0025h: ' and the second is event ID 2124 which says 'The Message Queuing service failed to join the computer's domain 'fabrikam'. Error 0xc00e0025: '

    Can anybody help with these messages please?

    Thanks

    Thursday, April 12, 2012 9:26 AM

Answers

  • I tried rebuilding the server and I still had problems, so I went over the install of MSMQ again and it turned out some of the permissions were not correct, once this was done it was ok
    • Proposed as answer by Kent-Huang Tuesday, April 17, 2012 3:36 AM
    • Marked as answer by dean-ot Tuesday, April 17, 2012 11:22 AM
    Monday, April 16, 2012 12:01 PM

All replies

  • You don't need MSMQ on the domain controllers, but it seems you have an issue with MSMQ on the member server.

    You could try removing and rejoining the member server to the domain. Or formatting the member server and starting again (extreme, but MSMQ can be tricky to troubleshoot on a forum).

    Tom


    Tom Arbuthnot, Consultant Modality Systems
    Blog: Lync'd Up Blog Join over 300 UC Pros who subscribe for blog updates: Email or RSS
    Twitter @tomarbuthnot

    Thursday, April 12, 2012 10:21 AM
  • The member server that I having problems with MSMQ on, was previosuly a domain controller until I demoted it a few months ago. If possible do you have any links I can read over about this.

    Thanks

    Thursday, April 12, 2012 11:25 AM
  • If your server was previously a domain controller, then your demoted it and now trying to install Lync; my advise would be to reinstall the OS on the member server and rename the server something different.  There are probably some reminants left behind from the DC demotion.  As Tom says, you do not need MSMQ on the DC's to support Lync, only on the member server that will  have Lync.

    Tim Harrington | MVP: Lync | MCITP: EMA 2007/2010, Lync 2010, MCTS: OCS | Blog: http://HowDoUC.blogspot.com | Twitter: @twharrington

    Thursday, April 12, 2012 1:11 PM
  • I dropped the server off the domain and then renamed it and joined it back again, and I am still getting the same error. Is there anything else I can do before having to reinstall the OS?
    Thursday, April 12, 2012 5:01 PM
  • Might want to see if this article helps: http://technet.microsoft.com/en-us/library/cc733521(WS.10).aspx 

    Tim Harrington | MVP: Lync | MCITP: EMA 2007/2010, Lync 2010, MCTS: OCS | Blog: http://HowDoUC.blogspot.com | Twitter: @twharrington

    • Proposed as answer by Sharon.Shen Monday, April 16, 2012 10:15 AM
    Friday, April 13, 2012 12:22 AM
  • Hi dean-ot,

     

    It seems like old DC isn't decomissioned/demoted properly. Please try to delete the orphan entry if exists:

     

    http://support.microsoft.com/kb/555846

     

    Regards,

    Kent

    • Edited by Kent-Huang Friday, April 13, 2012 7:35 AM format
    Friday, April 13, 2012 7:34 AM
  • I tried rebuilding the server and I still had problems, so I went over the install of MSMQ again and it turned out some of the permissions were not correct, once this was done it was ok
    • Proposed as answer by Kent-Huang Tuesday, April 17, 2012 3:36 AM
    • Marked as answer by dean-ot Tuesday, April 17, 2012 11:22 AM
    Monday, April 16, 2012 12:01 PM
  • Hi

    on server where you are trying to install Lync please navigate to the reg key

    HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

    A value named "Workgroup" with a value of 1 (0x1) indicates that MSMQ 2.0 was installed in Workgroup mode.

    change the value to (0). close regedit and try installation again...

    Regards
    Dhruv


    Dhruv

    Thursday, April 18, 2013 4:19 AM
  • Hi Dhruv,

    I was facing this issue. changing the DWORD value worked for me.

    thanks and Regards,

    Raunak

    Thursday, January 2, 2014 3:26 PM