none
Windows 7 Ultimate- error regarding allowing Log in as Service "An unexpected error has occurred, Failed to save Local Policy Database" RRS feed

  • Question

  • Question 
    • You are subscribed to this thread
    15 views

    Windows 7 Ultimate- error regarding allowing Log in as Service "An unexpected error has occurred, Failed to save Local Policy Database"

    TageAndersson asked on <button aria-label="Date" class="msaActionText msgHistoryBtn info-panel-toggle-link" data-panelcontainer=".userInfo" data-paneltarget="#message-history-holder-4326ef11-7243-4aff-947a-6bf7ef764212" style="color:#006cd8;font-style:inherit;font-variant:inherit;font-weight:inherit;font-size:inherit;line-height:inherit;font-family:inherit;margin:0px;cursor:pointer;padding:0px;border:none;display:inline;" title="See post history">April 7, 2016See post history</button>

    During a long period, I'm  doing a huge jobs to take back ownership for files, as attributes (write protected) atrib. My database for network policy setting, secedit.sdb have problem, corrupted(?). So to check my database, I went to CMD as administrator. From CMD I run:

    esentutl /g %windir%\security\database\secedit.sdb

    Result:

    C:\Windows\system32>esentutl /g %windir%\security\database\secedit.sdb

     

    Extensible Storage Engine Utilities for Microsoft(R) Windows(R)

    Version 6.1

    Copyright (C) Microsoft Corporation. All Rights Reserved.

     

    Error: Access to source database 'C:\Windows\security\database\secedit.sdb' failed with Jet error -1032.

     

    Operation terminated with error -1032 (JET_errFileAccessDenied, Cannot access file, the file is locked or in use) after

    20.31 seconds.

    I was try same commando attributt /r:

    Operation terminated with error -1003 (JET_errInvalidParameter, Invalid API parameter) after 0.0 seconds.

    Last command, /p:

    Error: Access to source database 'C:\Windows\security\database\secedit.sdb' failed with Jet error -1032.

     

    Operation terminated with error -1032 (JET_errFileAccessDenied, Cannot access file, the file is locked or in use) after

    20.31 seconds.

    So, to me it sounds like another problem, as how to get privilege administrator rights? Before this database check was done, I change my Bitdefender Total security, from controlled firewall, with change to off witch force firewall to be take over by  Windows. This sounds like Bitdefender as Firewall control manage did not causes this error. 

    Pleas help me, wath next to do, other with any ideas? 

    Tks. so Rega.

    Thursday, May 5, 2016 5:40 PM

Answers

All replies

  • You need to have the required user ID added to admin group to get admin rights. 

    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, May 5, 2016 11:43 PM
    Moderator
  • Hi Roof-55NO,

     

    Based on your description, I noticed the error message.

     

    It seems that the problem relate to Exchange. Have you used Exchange? If yes, please refer to the link:

     

    Exchange VSS : At Exchange Server 2010 ESEUtil fails with Jet error–1032:

    https://blogs.msdn.microsoft.com/deva/2013/05/10/exchange-vss-at-exchange-server-2010-eseutil-fails-with-jet-error1032/

     

    Operation terminated with error -1003 (JET_errInvalidParameter, Invalid API parameter) after 0.0 seconds

    https://social.technet.microsoft.com/Forums/office/en-US/20180b7b-1773-4729-b399-fee2f1b462fa/operation-terminated-with-error-1003-jeterrinvalidparameter-invalid-api-parameter-after-00?forum=exchangesvravailabilityandisasterrecoverylegacy

     

    In addition, we could also enable the (Hidden) Administrator Account to check the result.

    http://www.howtogeek.com/howto/windows-vista/enable-the-hidden-administrator-account-on-windows-vista/

    Please Note: Since the websites are not hosted by Microsoft, the links may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Saturday, May 7, 2016 10:23 AM
    Moderator
  • Hi Tao.

    In fact, never used Exchange server. To work around this problem, I decided to install it any way. I download 854Mb file, E2K7SP1EN64.exe. Exchange Server 2007 SP1 Setup report:

    Summary: 3 item(s). 0 succeeded, 3 failed. 
    Elapsed time: 00:00:48


    Hub Transport Role Prerequisites
    Failed

    Error:
    Active Directory does not exist or cannot be contacted.
    Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=EN&v=ExBPA.3&id=51e5500d-8b18-4eee-bb8e-925d063b60a1

    Error:
    Setup encountered a problem while validating the state of Active Directory: Could not find information about the local domain.

    Error:
    Microsoft Exchange Server 2007 setup cannot continue because this computer belongs to a domain that has a single-labeled DNS name. DNS domain name: 

    Error:
    This computer is not part of a Windows domain.

    Error:
    The server name is invalid. It contains characters other than 'A'-'Z', 'a'-'z', '0'-'9' and '-'.

    Error:
    The user is not logged on to a Windows domain

    Warning:
    Setup cannot detect an SMTP or Send connector with an address space of '*'. Mail flow to the Internet may not work properly.

    Warning:
    Setup cannot verify that the 'Host' (A) record for this computer exists within the DNS database on server 130.67.15.198.


    Elapsed Time: 00:00:27


    Client Access Role Prerequisites
    Failed

    Error:
    Active Directory does not exist or cannot be contacted.
    Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=EN&v=ExBPA.3&id=51e5500d-8b18-4eee-bb8e-925d063b60a1

    Error:
    Unable to read data from the Metabase. Ensure that Microsoft Internet Information Services is installed.
    Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=EN&v=ExBPA.3&id=a4a4d339-4009-4fb7-b842-ca2ba79f13f0

    Error:
    Setup encountered a problem while validating the state of Active Directory: Could not find information about the local domain.

    Error:
    Unable to access the 'Default Web Site' on this computer.
    Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=EN&v=ExBPA.3&id=aadc8176-1c47-49b7-83a0-9493a1093af1

    Error:
    Microsoft Exchange Server 2007 setup cannot continue because this computer belongs to a domain that has a single-labeled DNS name. DNS domain name: 

    Error:
    The Distributed Transaction Coordinator service must be started before Setup can continue.
    Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=EN&v=ExBPA.3&id=280ca216-ea9a-46fc-a23e-137e92527eb4

    Error:
    This computer is not part of a Windows domain.

    Error:
    The server name is invalid. It contains characters other than 'A'-'Z', 'a'-'z', '0'-'9' and '-'.

    Error:
    The user is not logged on to a Windows domain

    Warning:
    Setup cannot verify that the 'Host' (A) record for this computer exists within the DNS database on server 130.67.15.198.


    Elapsed Time: 00:00:10


    Mailbox Role Prerequisites
    Failed

    Error:
    Active Directory does not exist or cannot be contacted.
    Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=EN&v=ExBPA.3&id=51e5500d-8b18-4eee-bb8e-925d063b60a1

    Error:
    Unable to read data from the Metabase. Ensure that Microsoft Internet Information Services is installed.
    Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=EN&v=ExBPA.3&id=a4a4d339-4009-4fb7-b842-ca2ba79f13f0

    Error:
    You must be a member of the 'Exchange Organization Administrators' or 'Enterprise Administrators' group to continue.
    Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=EN&v=ExBPA.3&id=1d750594-9222-44d7-8f80-45e522e889e6

    Error:
    Setup encountered a problem while validating the state of Active Directory: Could not find information about the local domain.

    Error:
    Microsoft Exchange Server 2007 setup cannot continue because this computer belongs to a domain that has a single-labeled DNS name. DNS domain name: 

    Error:
    This computer is not part of a Windows domain.

    Error:
    The server name is invalid. It contains characters other than 'A'-'Z', 'a'-'z', '0'-'9' and '-'.

    Error:
    The user is not logged on to a Windows domain

    Warning:
    Setup cannot verify that the 'Host' (A) record for this computer exists within the DNS database on server 130.67.15.198.


    Elapsed Time: 00:00:10

    Overall, if my problem are straight a result from another problem, I have loosing my privilege as administrator log in and recognize my opportunities with change of properties is not allowed. This status applies to all of my hard drive devices. My OS allows applications installed programs provide commands for file changes, storage and load, yet does not allow such changes performed by me as Administrator. Perhaps, initially, this alleged first problem error is more about reducing privilege, than other bugs? 

    When this new trouble appointed, I allowed entry to the files and libraries, change properties such as read only to readable files, but always ends back to unchanged properties. Google a bit about this issues, and pinpointed a change of my registry file tree, "Take ownership" for libraries and content. This opportunity for change I have possibility to do when I click on a library and its properties. This provides no change of file attributes. In addition, I have branded all set-up in my security program (Bitdefender total security 2016), for check whether this program manages my admin options. Re-boot the PC, but still no changes. I do sent a request to WinPatrol, and here report and stated that this program does not take over me like online administrator and opportunities.

     

    It all seems hopeless, and a clean new installation of Win7 OS is undesirable, with a great job of re-installing applications etc. 

    Hope this gives new interesting details and fresh approach of the issue.

    Thanks for helpful clues and links.    

      


    Monday, May 9, 2016 2:02 AM
  • I want to confirm that have you enabled the (Hidden) Administrator Account to check the result? If not, please try it.

    http://www.howtogeek.com/howto/windows-vista/enable-the-hidden-administrator-account-on-windows-vista/

    Please Note: Since the websites are not hosted by Microsoft, the links may change without notice. Microsoft does not guarantee the accuracy of this information.


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Monday, May 23, 2016 3:26 AM
    Moderator
  • Hi folks.

    Something has happens :)

    Sorry for late response, but now I'm at Windows 10, for the 2th time this year. First time in February this year, with a lot of problems. Now OS windows 10 are in function, and due to this actually problems, thanks to  Tony_Tao for helping. Yes, I went to URL you mention.  I could now see I'm only a user with some rights, and the hidden administrator was opening by me. Non files are read only log in as Administrator. I just kept it open (not closed as hidden) administrator, I prevent a password for the Administrator. When not try out to close this hidden Admin. The files are also not read only when I'm log in as a user account. The link informed to close the hidden admin account, which I did not.

    Just  stumbling into an issue when Admin is open (not hidden), after that I have attributed password for this system account, when virtually all my actions that a user must enter password required for opening! It's stressful.

    It was such a shame is that all my user settings, software installations are done under my user account. This means that the administrator account does not have such settings. If it was up to me, I could delete my user account, BUT this will lead to many, many changes in the e-mail accounts, settings, etc. etc.

    How to transfer the user settings I have under my user account to an administrator account. Is this at all a possibility to perform?

    Thank you very much!
    Monday, May 23, 2016 5:53 PM
  • Hi again.

    Now, a new situation occur. After to have active the hidden administrator to YES, was log in as my user account, was opening different program, must confirm with log in password for each software opening, after a while I run CMD as administrator and set this hidden administrator account as NO (-active). Now I get a huge problems, many program will not starting, even the dialog box ask me (in tex formulara) to entry my password and confirm with YES for opening, no password box can be seen!

    CMD as administrator give same result!

    Hmmm, now it's most worse case to handle for me.... please give me a hint. 

    Tuesday, May 24, 2016 1:16 AM