none
I am getting MFC application has stopped working RRS feed

  • Question

  • Hi,
    I have an application named idg1429.exe developed in vc++ using VS6. When I run this application on Windows Server 2008, in English Locale, it runs successfully. But when we run the application with Japanese Locale, initially it starts successfully but if we try move away from the focus of application then it crashes and gives error "MFC application has stopped working".
    The same application works well on Windows XP for both English as well as Japanese Locale.
    Below is the even veiwer logs:
    General:
    Faulting application idg1429.exe, version 1.0.0.1, time stamp 0x51516925, faulting module idg1429.exe, version 1.0.0.1, time stamp 0x51516925, exception code 0xc0000005, fault offset 0x001adad8, process id 0xc14, application start time 0x01ce2a04dc5b86b7.
    Details:
    + System 
      - Provider 
       [ Name]  Application Error 
     
      - EventID 1000 
       [ Qualifiers]  0 
     
       Level 2 
     
       Task 100 
     
       Keywords 0x80000000000000 
     
      - TimeCreated 
       [ SystemTime]  2013-03-26T10:40:49.000Z 
     
       EventRecordID 3135 
     
       Channel Application 
     
       Computer WIN2k832 
     
       Security 
     
    - EventData 
       idg1429.exe 
       1.0.0.1 
       51516925 
       idg1429.exe 
       1.0.0.1 
       51516925 
       c0000005 
       001adad8 
       c14 
       01ce2a04dc5b86b7 
    Initially, when I tried to complie my code on vs2008, I got few syntax errors(windows server 2008 doesnot have support for VS6) but that got resolved after minor changes and so I sarted debugging the application.
    It's been 1 month and I have got nothing in my hand.
    Firstly,I thought of some thread getting terminated while the application runs, but through debugging I was not able to trace it down.
    Secondly, thought of memory leak. Used tools such as memoryleakdetector.exe and application verifier.exe but got nothing.
    Also used Dependecy Walker.exe to list down the faulty dll. It listed IMJP10K.dll in the red category and not much I was able to figure out of it.
    While debugging I have been getting the below error before the crash:
    "Windows has triggered a breakpoint in idg1429.exe. This may be due to corruption of the heap, which indicates a bug in idg1429.exe or any of the DLLs it has loaded-. This may also be due to user pressing F12 while javaw.exe has focus. The output window may have more diagnostic information. [BREAK] [CONTINUE] [IGNORE]"
    Any help in this regard will be appriciated.
    Thanks!
    Wednesday, March 27, 2013 5:08 AM

Answers